cannot build 20111003 developer/lt-panda image

Bug #867416 reported by Fathi Boudra on 2011-10-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Image Tools
Fix Released
Medium
Mattias Backman
Linaro Ubuntu
Medium
Ricardo Salveti

Bug Description

linaro-image-tools version: 2011.09

$ wget http://snapshots.linaro.org/11.05-daily/linaro-hwpacks/lt-panda/20111003/0/images/hwpack/hwpack_linaro-lt-panda_20111003-0_armel_supported.tar.gz http://snapshots.linaro.org/11.05-daily/linaro-developer/20111003/0/images/tar/developer-n-tar-20111003-0.tar.gz

$ sudo linaro-media-create --dev panda --mmc /dev/sdb --hwpack hwpack_linaro-lt-panda_20111003-0_armel_supported.tar.gz --binary developer-n-tar-20111003-0.tar.gz

[...]

Traceback (most recent call last):
  File "/usr/bin/linaro-media-create", line 171, in <module>
    args.is_live, args.is_lowmem, args.consoles)
  File "/usr/lib/python2.7/dist-packages/linaro_image_tools/media_create/boards.py", line 747, in populate_boot
    rootfs_uuid, boot_disk, boot_device_or_file)
  File "/usr/lib/python2.7/dist-packages/linaro_image_tools/media_create/boards.py", line 855, in make_boot_files
    cls.set_appropriate_serial_tty(chroot_dir)
  File "/usr/lib/python2.7/dist-packages/linaro_image_tools/media_create/boards.py", line 840, in set_appropriate_serial_tty
    os.path.join(chroot_dir, 'boot', 'vmlinuz*'))
  File "/usr/lib/python2.7/dist-packages/linaro_image_tools/media_create/boards.py", line 1464, in _get_file_matching
    raise ValueError("Too many files matching '%s' found." % regex)
ValueError: Too many files matching '/tmp/tmpCV3VX6/binary/boot/vmlinuz*' found.

See the full build log for details.

It seems an issue with the developer image as nano image can be built with the same hardware pack. feel free to re-assign if needed.

Related branches

Fathi Boudra (fboudra) wrote :
Fathi Boudra (fboudra) on 2011-10-04
description: updated
Mattias Backman (mabac) wrote :

This is caused by a fix for an old problem (set_appropriate_serial_tty) which should be disabled for V2 hwpacks.

This will break building images for any Omap board if the hwpack and image combined give more than one file matching /boot/vmlinuz* until I can fix it.

Changed in linaro-image-tools:
assignee: nobody → Mattias Backman (mabac)
status: New → In Progress
Fathi Boudra (fboudra) on 2011-10-04
Changed in linaro-image-tools:
importance: Undecided → Medium
milestone: none → 2011.10
Mattias Backman (mabac) wrote :

I proposed a fix for this which solves the problem for V2 hwpacks. The image won't work for V1 hwpacks though since the combination results in more than one kernel.

Mattias Backman (mabac) on 2011-10-06
Changed in linaro-image-tools:
status: In Progress → Fix Committed
Ricardo Salveti (rsalveti) wrote :

Removed the package lttng-modules-dkms from the developer-image for now, as it needs at least one working kernel when installing any dkms related package, what is not the case when creating the image.

Changed in linaro-ubuntu:
importance: Undecided → Medium
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → 11.10
status: New → Fix Released
Mattias Backman (mabac) on 2011-10-20
Changed in linaro-image-tools:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers