linaro-media-create for headless + hwpack installs packages from net

Bug #670711 reported by Alexander Sack on 2010-11-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Image Tools
Fix Released
Critical
Unassigned
Linaro Seeds
Critical
Unassigned

Bug Description

Unpacking hardware pack ...Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  devio flash-kernel linux-firmware linux-image-2.6.35-1006-linaro-omap linux-image-linaro-omap u-boot-linaro-omap3-beagle uboot-mkimage wireless-crda x-loader-omap
Suggested packages:
  uboot-envtools redboot-tools
The following NEW packages will be installed:
  devio flash-kernel linux-firmware linux-image-2.6.35-1006-linaro-omap linux-image-linaro-omap u-boot-linaro-omap3-beagle uboot-mkimage wireless-crda x-loader-omap
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 48.8kB/30.5MB of archives.
After this operation, 258kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  wireless-crda linux-image-2.6.35-1006-linaro-omap linux-firmware linux-image-linaro-omap u-boot-linaro-omap3-beagle x-loader-omap
Install these packages without verification [y/N]? y
Get:1 http://ports.ubuntu.com/ maverick/main devio armel 1.2-1build1 [16.9kB]
Get:2 http://ports.ubuntu.com/ maverick/main flash-kernel armel 2.28ubuntu10 [22.0kB]
Get:3 http://ports.ubuntu.com/ maverick/main uboot-mkimage armel 0.4build1 [9938B]
Fetched 48.8kB in 4s (9956B/s)
...

something is wrong in the headless seed i guess. that should install those bits. I am quite sure this wasnt always the case, but didnt track seed changes. or maybe i just never spotted this.

Same is true for other hwpacks like ux500.

should be fixed for release imo. requiring network packages with hwpack install is not acceptable.

Related branches

Alexander Sack (asac) on 2010-11-04
Changed in linaro:
importance: Undecided → Critical
milestone: none → 10.11
status: New → Confirmed
Alexander Sack (asac) wrote :

also see bug 670713 which was uncovered by this requiring net access.

Alexander Sack (asac) wrote :

moving to linaro-image-tools package ... hope thats good to keep on release radar.

affects: linaro → linaro-image-tools
Changed in linaro-image-tools:
milestone: 10.11 → none
Alexander Sack (asac) wrote :

sorry wrong bug :/ ... moving back.

affects: linaro-image-tools → linaro
Changed in linaro:
milestone: none → 10.11
James Westby (james-w) wrote :

The issue is that the hwpacks are built with --no-install-recommends, but are not
installed with that flag. Which do we want?

Thanks,

James

Alexander Sack (asac) wrote :

i think at best hwpacks would be installed without recommends.

In any case, those packages from above should be in the headless seed as they are not about hardware specific code.

James Westby (james-w) on 2010-11-04
affects: linaro → linaro-image-tools
Changed in linaro-image-tools:
milestone: 10.11 → none
Alexander Sack (asac) wrote :

proposed merge for adding those three packages to the headless seed:

https://code.launchpad.net/~asac/linaro-seeds/lp670711/+merge/40107

Changed in linaro-seeds:
importance: Undecided → Critical
status: New → In Progress
James Westby (james-w) wrote :

Alexander and I discussed this on IRC and decided that putting recommends
in the hwpack is the better solution, at least for now. I just landed a change
to linaro-hwpack-create to always do this (it was dependent on the platform
you were running on before).

Marking this as Fix Committed in linaro-image-tools, but there may be other
things we want to do to fix this as well.

Thanks,

James

Changed in linaro-image-tools:
status: Confirmed → Fix Committed
Jamie Bennett (jamiebennett) wrote :

Alexander, what is the status of this bug? Can we also mark it 'Fix Committed' for Linaro Seeds?

Loïc Minier (lool) on 2011-01-22
Changed in linaro-image-tools:
status: Fix Committed → Fix Released
Changed in linaro-seeds:
status: In Progress → Incomplete
Loïc Minier (lool) on 2011-04-04
Changed in linaro-seeds:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers