[regression] 1 test still fail after build-info support merge

Bug #1067786 reported by Milo Casagrande
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Image Tools
Fix Released
High
Milo Casagrande

Bug Description

As from bug 1065826, we are still having one test failing.
The error we have now is:

ERROR: linaro_image_tools.hwpack.tests.test_builder.HardwarePackBuilderTests.test_obeys_include_debs
----------------------------------------------------------------------
Traceback (most recent call last):
  File "linaro_image_tools/hwpack/tests/test_builder.py", line 297, in
test_obeys_include_debs
    builder.build()
  File "linaro_image_tools/hwpack/builder.py", line 294, in build
    assert self.config.spl_package is not None
  File "linaro_image_tools/hwpack/builder.py", line 359, in _extract_build_info
    '\n%s' % stderrdata)
  File "/usr/lib/python2.7/dist-packages/debian/debfile.py", line 208,
in __init__
    ArFile.__init__(self, filename, mode, fileobj)
  File "/usr/lib/python2.7/dist-packages/debian/arfile.py", line 47, in __init__
    self.__index_archive()
  File "/usr/lib/python2.7/dist-packages/debian/arfile.py", line 52,
in __index_archive
    fp = open(self.__fname, "rb")
IOError: [Errno 2] No such file or directory: 'foo_1.1_all.deb'

Related branches

Revision history for this message
Fathi Boudra (fboudra) wrote :

Yes, I think test_obeys_include_debs failure is caused by a faulty code in fetch package.
When include-debs is set to no, we don't download content and the cache is cleared.
I expected the fetched packages empty but it isn't.

Revision history for this message
Fathi Boudra (fboudra) wrote :

I'm referring to the code in hwpack/packages.py line 746:
        if not download_content:
            self.cache.cache.clear()
            return fetched.values()

Revision history for this message
Fathi Boudra (fboudra) wrote :

attached is a patch to work around the issue as it might block the release (test suite failing).

Milo Casagrande (milo)
Changed in linaro-image-tools:
milestone: none → 2012.10
assignee: nobody → Milo Casagrande (milo)
Revision history for this message
Milo Casagrande (milo) wrote :

Hi Fathi,

thanks for looking into this! Attached patch looks good, I'll apply it and push to trunk.

Milo Casagrande (milo)
Changed in linaro-image-tools:
status: Confirmed → Fix Committed
Milo Casagrande (milo)
Changed in linaro-image-tools:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers