[regression] 11 tests failing since build-info support is merged

Bug #1065826 reported by Fathi Boudra
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Image Tools
Fix Released
High
Fathi Boudra

Bug Description

File "/usr/lib/python2.7/dist-packages/debian/arfile.py", line 59, in
__index_archive
    raise ArError, "Unable to find global header"
debian.arfile.ArError: Unable to find global header

The problem arises from the "build-info" extraction part in the
builder() method (file hwpack/build.py, at the very end of the file),
and it is only visible running the tests. That function also calls to
be refactored, since it is getting huge and difficult to go through.

When running the tests, we "fake" some Debian packages, using the
DummyFetchedPackage class (file hwpack/testing.py), that returns
something that is not comparable to a deb file; when the builder()
function is called and it opens the deb file to take out the
build-info stuff, the ArFile class reads the content of the deb file,
and there it breaks, because it is missing basically all the
structure.

Related branches

Fathi Boudra (fboudra)
Changed in linaro-image-tools:
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Fathi Boudra (fboudra)
milestone: none → 2012.10
description: updated
Fathi Boudra (fboudra)
Changed in linaro-image-tools:
status: Triaged → In Progress
Fathi Boudra (fboudra)
Changed in linaro-image-tools:
status: In Progress → Fix Committed
Revision history for this message
Paul Sokolovsky (pfalcon) wrote :

Locally, I still getting one following failure:

======================================================================
ERROR: linaro_image_tools.hwpack.tests.test_builder.HardwarePackBuilderTests.test_obeys_include_debs
----------------------------------------------------------------------
Traceback (most recent call last):
  File "linaro_image_tools/hwpack/tests/test_builder.py", line 297, in test_obeys_include_debs
  File "linaro_image_tools/hwpack/builder.py", line 350, in build
  File "/usr/lib/python2.7/dist-packages/debian/debfile.py", line 208, in __init__
    ArFile.__init__(self, filename, mode, fileobj)
  File "/usr/lib/python2.7/dist-packages/debian/arfile.py", line 47, in __init__
    self.__index_archive()
  File "/usr/lib/python2.7/dist-packages/debian/arfile.py", line 52, in __index_archive
    fp = open(self.__fname, "rb")
IOError: [Errno 2] No such file or directory: 'foo_1.1_all.deb'

Revision history for this message
Fathi Boudra (fboudra) wrote : Re: [Bug 1065826] Re: [regression] 11 tests failing since build-info support is merged

On 15 October 2012 15:37, Paul Sokolovsky <email address hidden> wrote:
> Locally, I still getting one following failure:

Yes, I think test_obeys_include_debs failure is caused by a faulty
code in fetch package.
When include-debs is set to no, we don't download content and the
cache is cleared.
I expected the fetched packages empty but it isn't.

I'd like to treat this issue as a separate bug.

Milo Casagrande (milo)
Changed in linaro-image-tools:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers