pre-build images crawler needs to support more than one top-level directory

Bug #1155165 reported by Marcin Juszkiewicz on 2013-03-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro CI
Fix Released
High
James Tunnicliffe

Bug Description

For https://blueprints.launchpad.net/linaro-oe/+spec/create-toolchain-validation-setup I need a way to build an image with Ubuntu 'quantal' hwpack and openembedded rootfs.

Current version uses "-p" argument to select top-level directory but it is not possible to use more than one.

James Tunnicliffe (dooferlad) wrote :

Can you tell me which script you are talking about and what you are trying to accomplish? We have an API for snapshots and releases that has just been merged. If you are wanting to download a file from those locations we can do the roll out sooner than planned.

On 15.03.2013 11:34, James Tunnicliffe wrote:
> Can you tell me which script you are talking about

http://git.linaro.org/gitweb?p=ci/daily-prebuilt-images.git;a=summary

For
https://ci.linaro.org/jenkins/view/builds-and-baselines/job/openembedded-armv7a-pre-built-images-panda/
job.

> and what you are trying to accomplish?

I need to fetch image from
http://snapshots.linaro.org/openembedded/images/lamp-armv7 and hwpack
from http://snapshots.linaro.org/quantal/hwpacks

> We have an API for snapshots and releases that has just been merged.
> If you are wanting to download a file from those locations we can do
> the roll out sooner than planned.

Great! Where I can check this code?

Marcin Juszkiewicz (hrw) wrote :

ping?

James Tunnicliffe (dooferlad) wrote :

Sorry for not responding sooner - hadn't subscribed myself to the bug.

The API has rolled out. Just sent a mail to linaro-dev about it. Should fit your needs.

Fathi Boudra (fboudra) wrote :

Marcin, could you confirm the API is sufficient for your needs?

Changed in linaro-ci:
assignee: nobody → James Tunnicliffe (dooferlad)
milestone: none → 2013.03
status: New → Fix Committed
importance: Undecided → High
Fathi Boudra (fboudra) on 2013-03-29
Changed in linaro-ci:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Marcin Juszkiewicz (hrw) wrote :

I updated ci/daily-prebuilt-images code to use API and it works and CI job went fine with it.

Now waiting for https://ci.linaro.org/jenkins/job/openembedded-armv7a-lamp/gcc_version=4.7,label=oe_persistent_cloud/6/console to finish so can check my other change. Once it work I will mark as fix released.

Changed in linaro-ci:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
James Tunnicliffe (dooferlad) wrote :

@hrw: Any update on this? The bug status changed a couple of times...

Changed in linaro-ci:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed

Marcin Juszkiewicz (hrw) on 2013-05-22
Changed in linaro-ci:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers