l-m-c is failing in the lab

Bug #1005393 reported by Michael Hudson-Doyle on 2012-05-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro CI
Fix Released
High
Deepti B. Kalakeri

Bug Description

I haven't really looked into this, but it seems that all tests that run linaro-media-create in the lab (which isn't all the many any more, but includes the kernel ci tests) fail to do so correctly.

Changed in lava-lab:
importance: Undecided → Critical
Michael Hudson-Doyle (mwhudson) wrote :

Actually I think this is a problem with the hwpacks ci.linaro.org is generating...

Changed in lava-lab:
importance: Critical → High
Changed in linaro-ci:
assignee: nobody → Deepti B. Kalakeri (deeptik)
Changed in linaro-ci:
importance: Undecided → High
status: New → Triaged
Changed in linaro-ci:
status: Triaged → In Progress
Deepti B. Kalakeri (deeptik) wrote :

The test hwpacks that come out of ci.linaro.org fail to boot as the kernel deb package is being built for armel, while including it in the precise armhf hwpack. Hence the lmc is not able to boot the kernel on lava.

Building the armhf kernel deb package solved the problem.

Here is the link http://validation.linaro.org/lava-server/dashboard/streams/private/team/linaro/ci-linux-linaro-tracking/bundles/9d692d8ba69754e9c8787f0d367021946cefec21/8948bce8-ab18-11e1-9729-68b599be548c/ to the successful boot of the kernel being built on ci* after applying the above fix.

Thanks!!!
Deepti.

Changed in linaro-ci:
milestone: none → 2012.06
Deepti B. Kalakeri (deeptik) wrote :

The hwpack boot problem for panda, vexpress, snowball boards is fixed now.
Beagle board is failing to boot completely with a kernel panic for which I have already sent an email to linaro-kernel.
Origen hwpack boot failure is tracked in the bug 928203. The origen builds require additional configs to be set apart from the ones which are available in the default configs. The investigation on this is in process.

I feel this bug can be closed now as the majority of the boot failures have been fixed and the ones which are still failing are being tracked already in different bugs.

Thanks!!!
Deepti.

Fathi Boudra (fboudra) on 2012-06-05
no longer affects: lava-lab
Changed in linaro-ci:
status: In Progress → Fix Released
Michael Hudson-Doyle (mwhudson) wrote :

Awesome, thanks for digging into this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers