Linaro big.LITTLE Reference

try_rmmod test fails if arm-bl-cpufreq module is already inserted

Reported by Amit Pundir on 2012-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
big.LITTLE Reference Switcher
Fix Released
Undecided
Mathieu Briand

Bug Description

Platform:
Android

Reference Switcher Build:
https://android-build.linaro.org/builds/~linaro-android/vexpress-rtsm-ics-gcc47-armlt-stable-open/#build=49

Integrated Switcher Build:
https://android-build.linaro.org/builds/~linaro-android-restricted/vexpress-rtsm-isw-ics-gcc47-armlt-stable-open/#build=18

Log:
root@android:/data #
root@android:/data # lsmod
root@android:/data # insmod /system/modules/arm-bl-cpufreq.ko
[ 43.385271] arm-bl-cpufreq: cpufreq initialised successfully
[ 43.396826] arm-bl-cpufreq: cpufreq initialised successfully
[ 43.408434] arm-bl-cpufreq: cpufreq initialised successfully
[ 43.420071] arm-bl-cpufreq: cpufreq initialised successfully
[ 43.431700] arm-bl-cpufreq: cpufreq backend driver registered.
root@android:/data # lsmod
arm_bl_cpufreq 7838 0 - Live 0xbf007000
root@android:/data #
root@android:/data # try_rmmod.sh
try_rmmod : try to remove mod in different configurations
Switch to little with success
[ 48.810793] arm-bl-cpufreq: cpufreq backend driver unloaded.
usage: insmod <module.o>
./try_rmmod.sh[61]: cannot create /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed: No such file or directory
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq: No such file or directory
ERROR : $freq
1|root@android:/data #
1|root@android:/data # lsmod
root@android:/data #
root@android:/data # try_rmmod.sh
try_rmmod : try to remove mod in different configurations
[ 53.130230] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.141888] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.153443] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.165091] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.176702] arm-bl-cpufreq: cpufreq backend driver registered.
Switch to little with success
[ 53.420730] arm-bl-cpufreq: cpufreq backend driver unloaded.
[ 53.546007] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.557526] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.569165] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.580798] arm-bl-cpufreq: cpufreq initialised successfully
[ 53.592410] arm-bl-cpufreq: cpufreq backend driver registered.
Switch to big with success
[ 53.750785] arm-bl-cpufreq: cpufreq backend driver unloaded.
SUCCESS!!
root@android:/data #
root@android:/data #

Amit Pundir (pundiramit) wrote :

Observed on both Reference and Integrated switcher builds.

Mathieu Briand (mathieu-briand) wrote :

OK, I see what the problem is, just a dumb copy/paste .I'm working on it.

Mathieu Briand (mathieu-briand) wrote :

It should be fixed now with commit 5df7b64003e8327885cbb18d272ad1676cd7c20b

Changed in linaro-big-little-integrated:
assignee: nobody → Mathieu Briand (mathieu-briand)
Changed in linaro-big-little-reference:
assignee: nobody → Mathieu Briand (mathieu-briand)
status: New → Fix Committed
Changed in linaro-big-little-integrated:
status: New → Fix Committed

On Wed, 23 May 2012, Mathieu Briand wrote:

> It should be fixed now with commit
> 5df7b64003e8327885cbb18d272ad1676cd7c20b

I have no such commit in my tree.

Mathieu Briand (mathieu-briand) wrote :

@Nicolas : people/plars/core.git on linaro-private.git.linaro.org (it is a system test bug, not a bug in the kernel).

Amit Pundir (pundiramit) on 2012-05-24
Changed in linaro-big-little-integrated:
status: Fix Committed → Fix Released
Changed in linaro-big-little-reference:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers