Panda: Youtube video playback fails on Linaro android image

Bug #987771 reported by Abhishek Paliwal on 2012-04-24
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Undecided
Unassigned

Bug Description

Description:
==========
On Build:
https://android-build.linaro.org/builds/~linaro-android/panda-ics-gcc47-tilt-tracking-blob-12.04-release/#build=4

Unable to play youtube videos, checked all resolutions on youtube, 240p ,360p, 480p. 720p, 1080p

Playing 240p only videos result in following error:
--------------------------------------------
E/MediaPlayer( 1922): error (1, -19)
E/AwesomePlayer( 1341): Starting the audio player failed w/ err -19
E/MediaPlayer( 1922): Error (1,-19)
E/MediaPlayer( 1922): pause called in state 0
E/MediaPlayer( 1922): error (-38, 0)
E/MediaPlayer( 1922): Error (-38,0)
-------------------------------------

Playing HD video causes crash:
 " pid: 1341, tid: 1341 >>> /system/bin/mediaserver <<<"

After this browser crash is also observed sometimes.

Reproducible:
===========
Yes, 5/5 time

IMPACT:
========
youtube videos can't be watched.

Steps:
==========
1. Bootup panda build, on serail console setup ethernet interface, "netcfg eth0 dhcp" ; " setprop net.dns1 8.8.8.8"
2. Open youtube.com - search and watch some sd video(240p only)
3. Search and watch some HD video -(720p,1080p)

Issue: None of the videos play, progress bar just goes to end and serial logs shows error messages.

Hardware:
==========
Panda 4460
HDMI out to TV
4GB SD card

Software:
==========
https://android-build.linaro.org/builds/~linaro-android/panda-ics-gcc47-tilt-tracking-blob-12.04-release/#build=4

Logs:
======
logcat messages attached.

Also observed with Panda JellyBean builds:

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=28

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=38

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=40

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=44

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=49

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob-12.09-release/#build=4

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=69

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=75

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=82

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=100

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=106

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=115

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=127

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=161

Amit Khare (amit-khare) wrote :

This problem exists with Panda Jellybean android build too

observed with android jellybean panda build
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=23

Amit Khare (amit-khare) on 2012-10-07
description: updated
Amit Khare (amit-khare) on 2012-10-08
description: updated
Amit Khare (amit-khare) on 2012-10-15
description: updated
description: updated
description: updated
description: updated
description: updated
Soumya Basak (soumya-basak) wrote :
summary: - Panda: Youtube video playback fails
+ Panda: Youtube video playback fails on Linaro android image
description: updated
Fathi Boudra (fboudra) on 2013-06-07
Changed in linaro-android:
assignee: Zach Pfeffer (pfefferz) → nobody
Soumya Basak (soumya-basak) wrote :

Validate with Linaro Android Kitkat Panda 14.01 release builds:
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.01-release/#build=2

Youtube video playback smoothly. The issue is fixed.

Changed in linaro-android:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments