vexpress: Angrybirds display severely trucated

Bug #987155 reported by Tixy (Jon Medhurst) on 2012-04-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Won't Fix
Undecided
Linaro Landing Team: ARM

Bug Description

When launching AngryBirds I just get a screen white screen with a blue band covering the top quarter of the screen which has right-to-left scrolling shapes which look like rocks.

After pressing Ctrl+Esc I can see the bottom part of some scrolling credits appearing in the blue band. It looks like the game is running but with its display shifted up by 3/4 of its heigh so only the bottom 1/4 is showing at the top of the screen.

When the game first starts I get a message about running on compatibility zoom mode, so there may be something wrong with that.

Bug found when running AndrBirds QA test step of build https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open-12.04-release/#build=2

https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk/#build=52

https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk-13.11-release/#build=1

visibility: private → public
description: updated
summary: - vexpress: Angrybirds fails to start
+ vexpress: Angrybirds display severely trucated
Changed in linaro-landing-team-arm:
status: New → Triaged
importance: Undecided → Medium
description: updated
Botao (botao-sun) wrote :

For vexpress board, on image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open/#build=71

The display works well although the performance is poor.

No audio.

Anmar Oueja (anmar) on 2012-11-08
Changed in linaro-landing-team-arm:
status: Triaged → Won't Fix
Milosz Wasilewski (mwasilew) wrote :

ICS is not supported. Closing.

Changed in linaro-android:
status: New → Won't Fix
Tixy (Jon Medhurst) (tixy) wrote :

Same problem occurs on Android 4.2

Ryan Harkin (ryanharkin) wrote :

ARMLT marked this as "won't fix" because it is due to Versatile Express not having accelerated video hardware.

tags: added: angrybirds
Ryan Harkin (ryanharkin) on 2013-10-10
no longer affects: linaro-landing-team-arm
Changed in linaro-android:
assignee: nobody → Linaro Landing Team: ARM (linaro-landing-team-arm)
status: Won't Fix → In Progress
Kanta Vekaria (kanta-vekaria) wrote :

LT will try to reproduce with a more later version of AngryBirds

description: updated
Naresh Kamboju (naresh-kamboju) wrote :

This issue is re-produced on below build while testing 13.10 release
https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk-13.10-release/#build=2

description: updated
Kanta Vekaria (kanta-vekaria) wrote :

Naresh,
Can you confirm that you are using the latest version of Angrybirds to test
this bug/test case?
If so could you send us the version details and latest apk

Naresh Kamboju (naresh-kamboju) wrote :

Angry Birds_2.0.0.apk is installed on lsk android build running on vexpress-tc2 device.
Installation successful but failed to run.
nothing is shown on the screen ( it is completely back) and nothing i could hear.

Android Build:
-------------------
https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk/#build=183

Mark Orvek (mark-orvek) wrote :

This is assigned to the ARM Landing Team. Is that the proper owner of
this bug?

Mark

On Thu, Feb 20, 2014 at 11:38 AM, Naresh Kamboju
<email address hidden>wrote:

> Angry Birds_2.0.0.apk is installed on lsk android build running on
> vexpress-tc2 device.
> Installation successful but failed to run.
> nothing is shown on the screen ( it is completely back) and nothing i
> could hear.
>
> Android Build:
> -------------------
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk/#build=183
>
> ** Attachment added: "Angry Birds_2.0.0.apk"
>
> https://bugs.launchpad.net/linaro-android/+bug/987155/+attachment/3988547/+files/Angry%20Birds_2.0.0.apk
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: ARM, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/987155
>
> Title:
> vexpress: Angrybirds display severely trucated
>
> Status in Linaro Android:
> In Progress
>
> Bug description:
> When launching AngryBirds I just get a screen white screen with a
> blue band covering the top quarter of the screen which has right-to-
> left scrolling shapes which look like rocks.
>
> After pressing Ctrl+Esc I can see the bottom part of some scrolling
> credits appearing in the blue band. It looks like the game is running
> but with its display shifted up by 3/4 of its heigh so only the bottom
> 1/4 is showing at the top of the screen.
>
> When the game first starts I get a message about running on
> compatibility zoom mode, so there may be something wrong with that.
>
> Bug found when running AndrBirds QA test step of build https
> ://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47
> -armlt-tracking-open-12.04-release/#build=2
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-
> lsk/#build=52
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-
> lsk-13.11-release/#build=1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/987155/+subscriptions
>

--
Mark Orvek

<email address hidden>

EVP, Engineering

*M*: +1.408.313.6988 *IRC:* morvek *Skype:* morvek
linaro.org │ Open source software for ARM SoCs

Scott Bambrough (scottb) wrote :
Download full text (4.2 KiB)

It is assigned here as it is TC2 specific, but AFAIK the problem is the
lack of a GPU on VExpress. AFAIK, the Android image would have to have
MESA installed and working and this isn't something the LT is willing to
work on. I thought there was a GWG project for that, but it is only
ARMv8. It is possible as Android-x86 does this.

On Thu, Feb 20, 2014 at 2:33 PM, Mark Orvek <email address hidden> wrote:

> This is assigned to the ARM Landing Team. Is that the proper owner of
> this bug?
>
> Mark
>
>
> On Thu, Feb 20, 2014 at 11:38 AM, Naresh Kamboju
> <email address hidden>wrote:
>
> > Angry Birds_2.0.0.apk is installed on lsk android build running on
> > vexpress-tc2 device.
> > Installation successful but failed to run.
> > nothing is shown on the screen ( it is completely back) and nothing i
> > could hear.
> >
> > Android Build:
> > -------------------
> >
> >
> https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk/#build=183
> >
> > ** Attachment added: "Angry Birds_2.0.0.apk"
> >
> >
> https://bugs.launchpad.net/linaro-android/+bug/987155/+attachment/3988547/+files/Angry%20Birds_2.0.0.apk
> >
> > --
> > You received this bug notification because you are a member of Linaro
> > Landing Team: ARM, which is subscribed to the bug report.
> > https://bugs.launchpad.net/bugs/987155
> >
> > Title:
> > vexpress: Angrybirds display severely trucated
> >
> > Status in Linaro Android:
> > In Progress
> >
> > Bug description:
> > When launching AngryBirds I just get a screen white screen with a
> > blue band covering the top quarter of the screen which has right-to-
> > left scrolling shapes which look like rocks.
> >
> > After pressing Ctrl+Esc I can see the bottom part of some scrolling
> > credits appearing in the blue band. It looks like the game is running
> > but with its display shifted up by 3/4 of its heigh so only the bottom
> > 1/4 is showing at the top of the screen.
> >
> > When the game first starts I get a message about running on
> > compatibility zoom mode, so there may be something wrong with that.
> >
> > Bug found when running AndrBirds QA test step of build https
> > ://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47
> > -armlt-tracking-open-12.04-release/#build=2
> >
> > https://android-build.linaro.org/builds/~linaro-android/vexpress-
> > lsk/#build=52
> >
> > https://android-build.linaro.org/builds/~linaro-android/vexpress-
> > lsk-13.11-release/#build=1
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/linaro-android/+bug/987155/+subscriptions
> >
>
>
> --
> Mark Orvek
>
> <email address hidden>
>
> EVP, Engineering
>
> *M*: +1.408.313.6988 *IRC:* morvek *Skype:* morvek
> linaro.org │ Open source software for ARM SoCs
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: ARM, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/987155
>
> Title:
> vexpress: Angrybirds display severely trucated
>
> Status in Linaro Android:
> In Progress
>
> Bug description:
> When launching AngryBirds I just get a screen white screen with a
> blue band cov...

Read more...

Ryan Harkin (ryanharkin) wrote :
Changed in linaro-android:
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.