Snowball: The Streamline tool in DS-5 causes board lock-up

Bug #961962 reported by Tixy (Jon Medhurst)
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IglooCommunity
Won't Fix
Medium
Anmar Oueja
Linaro Android
Fix Released
Undecided
Unassigned
linaro-landing-team-arm
Fix Released
High
Tixy (Jon Medhurst)

Bug Description

If the Streamline tool in DS-5 [1] is connected to Snowball then the board will lock up, requiring a reboot. This only seems to occur if the screen is static (unchanging), it works OK if the animated wallpaper is running, or you keep wiggling the mouse, or whilst running 0xbench 2D and 3D tests.

I believe this bug is due to the recent Mali driver patches which added support for Streamline and came with the known issue:

"Attempting to read L2 cache counters when the hardware block is powered down could potentially lead to a hang due to a lack of locking. This will be addressed in a future driver update."

So it seems reasonable to surmise the lock-ups may be due to this.

Found in build: https://android-build.linaro.org/builds/~linaro-android/snowball-ics-gcc46-igloo-tracking-blob/#build=18

[1] https://wiki.linaro.org/Platform/DevPlatform/DS5

Changed in linaro-landing-team-arm:
assignee: nobody → Tixy (Jon Medhurst) (tixy)
importance: Undecided → High
status: New → In Progress
Revision history for this message
Tixy (Jon Medhurst) (tixy) wrote :

The lock-up occurs when starting or stopping Streamline data capture.

As it does not occur if the L2 cache counters are not accessed, this issue can be worked around with the attached patch to the Mali drivers.

Anmar Oueja (anmar)
Changed in igloocommunity:
milestone: none → 2012.04
importance: Undecided → Medium
Changed in igloocommunity:
assignee: nobody → NaveenKumar Gaddipati (naveen-gaddipati)
Revision history for this message
Anmar Oueja (anmar) wrote :

AMR is aware of the issue and is working on a fix.

Revision history for this message
Anmar Oueja (anmar) wrote :

Targeting 2012.04 for the ARM LT

Changed in linaro-landing-team-arm:
milestone: none → 2012.04
Revision history for this message
NaveenKumar Gaddipati (naveen-gaddipati) wrote :

The issue present in using Streamline tool attaching to snowball board.
Could you please give us the detailed description usage of Streamline tool.
The issue present in mali driver profiling code.So this is related to Graphics.

Revision history for this message
Anmar Oueja (anmar) wrote :

This issue is now fixed by the ARM LT by removing the offending call. The lock up no longer happens. Keep in mind this is a workaround until a fix from ARM arrives.

Changed in igloocommunity:
assignee: NaveenKumar Gaddipati (naveen-gaddipati) → nobody
Anmar Oueja (anmar)
Changed in igloocommunity:
assignee: nobody → Anmar Oueja (anmar)
status: New → Confirmed
Changed in linaro-landing-team-arm:
status: In Progress → Fix Committed
Revision history for this message
Patrik Klinger (patrik-klinger) wrote :

Anmar, should this get a new status on the igloocommunity thread?

Revision history for this message
Anmar Oueja (anmar) wrote :

I marked it as "won't fix" since it has been fixed with the ARMLT

Changed in igloocommunity:
status: Confirmed → Won't Fix
Revision history for this message
Tixy (Jon Medhurst) (tixy) wrote :

Tested 12.05 release and Streamline shows GPU info OK (without L2 cache stats as that is disabled by te workaround patch for this bug.)

Changed in linaro-landing-team-arm:
status: Fix Committed → Fix Released
Changed in linaro-android:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers