Youtube video does not work in small screen mode(Origen Board)

Bug #947730 reported by Annamalai Lakshmanan on 2012-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Won't Fix
Undecided
Annamalai Lakshmanan

Bug Description

After enabling HW acceleration in Origen Board.
Youtube video does not work in small screen mode, and gives Green Color display.
But, works in full screen mode

Changed in linaro-android:
assignee: nobody → Annamalai Lakshmanan (annamalai-lakshmanan)
Changed in linaro-android:
status: New → Won't Fix
Botao (botao-sun) wrote :

On build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.04-release/#build=2

The preview of those video clips on YouTube website can be displayed, but after click anyone then it can't be played back.

Here is the output of serial console:

root@android:/ # s3c-fimc: FIMC1 3 opened.
s3c-fimc: Invalid control id: 134217748

Botao (botao-sun) wrote :

On build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.04-release/#build=2

After install the vendor package (http://snapshots.linaro.org/android/binaries/origen/20120416/vendor.tar.bz2) manually, the Youtube video can start play, with sound, but the whole screen is green.

So, it still doesn't work.

Botao (botao-sun) wrote :

For Origen, on build:

https://android-build.linaro.org/builds/~linaro-android/origen-hangout-demo-12.05-release/#build=1

Can't play any video both in browser & YouTube app. In browser, the preview picture can be shown, but video can't be played; in app, after click it, then it quits automatically.

Download full text (7.1 KiB)

Unable to play any youtube videos on build:
https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.06-release/#build=1

Logcat:
---------

D/AudioHardware( 2290): AudioHardware pcm playback is exiting standby.
D/AudioHardware( 2290): openPcmOut_l() mPcmOpenCnt: 0
D/wpa_supplicant( 2468): wpa_driver_wext_driver_cmd RSSI len = 248
D/wpa_supplicant( 2468): [REPLY]: symbian rssi -49
D/wpa_supplicant( 2468): wpa_driver_wext_driver_cmd LINKSPEED len = 248
D/wpa_supplicant( 2468): [REPLY]: LinkSpeed 54
D/MediaPlayer( 2945): Couldn't open file on client side, trying server side
I/AwesomePlayer( 2290): setDataSource_l('http://o-o.preferred.bom03s03.v1.lscache4.c.youtube.com/videoplayback?el=home&begin=0&fexp=907217%2C907335%2C921602%2C919306%2C919316%2C912804%2C913542%2C919324%2C912706&dnc=1&itag=22&ip=115.0.0.0&app=youtube_m)
V/ChromiumHTTPDataSource( 2290): connect on behalf of uid 10008
I/ChromiumHTTPDataSource( 2290): connect to http://o-o.preferred.bom03s03.v1.lscache4.c.youtube.com/videoplayback?el=home&begin=0&fexp=907217%2C907335%2C921602%2C919306%2C919316%2C912804%2C913542%2C919324%2C912706&dnc=1&itag=22&ip=115.0.0.0&app=youtub0
I/qtaguid ( 2290): Tagging socket 35 with tag 3f500000000(1013) for uid 10008 failed errno=-2
I/OMXCodec( 2290): [OMX.SEC.AVC.Decoder] AVC profile = 100 (High), level = 31
I/OMXCodec( 2290): [OMX.SEC.AVC.Decoder] video dimensions are 1280 x 720
E/ ( 2290)[ 151.220000] pd-mfc: Power-on latency exceeded, new value 840500 ns
[ 151.225000] s5p-mfc s5p-mfc: start latency exceeded, new value 834 ns
[ 151.235000] s5p-mfc s5p-mfc: state restore latency exceeded, new value 2917 ns
[ 151.240000] s5p-mfc s5p-mfc: stop latency exceeded, new value 1750 ns
[ 151.245000] s5p-mfc s5p-mfc: start latency exceeded, new value 1334 ns
: FIMC Info (/dev/video2): driver="exynos4-fimc" bus_info="" card="exynos4-fimc" fd=0x2a
E/ ( 2290): FB Open OK
E/ ( 2290): New Framebuffer properties: xres=1024, yres=600, bpp=32
E/ ( 2290): New Virtual resolution: vxres=1024 vyres=1200
I/MFC_DEC_APP( 2290): [SsbSipMfcDecOpen] MFC Library Ver 1.00
I/MFC_DEC_APP( 2290): [SsbSipMfcDecOpen] dev name is /dev/video10
E/MFC_DEC_APP( 2290): Trying to Open MFC:/dev/video10
I/MFC_DEC_APP( 2290): [SsbSipMfcDecOpenExt] cacheable buffer
D/AudioHardware( 2290): AudioHardware pcm playback is going to standby.
D/AudioHardware( 2290): closePcmOut_l() mPcmOpenCnt: 1
D/wpa_supplicant( 2468): wpa_driver_wext_driver_cmd RSSI len = 248
D/wpa_supplicant( 2468): [REPLY]: symbian rssi -58
D/wpa_supplicant( 2468): wpa_driver_wext_driver_cmd LINKSPEED len = 248
D/wpa_supplicant( 2468): [REPLY]: LinkSpeed 54
E/ ( 2290): mfc width:1280 height:736 YSize:942080 UVSize:491520 information
E/ ( 2290): mfc crop_top crop_bottom crop_left crop_right : 0, 16, 0, 0
I/OMXCodec( 2290): [OMX.SEC.AVC.Decoder] video dimensions are 1280 x 736
I/OMXCodec( 2290): [OMX.SEC.AVC.Decoder] Crop rect is 1280 x 736 @ (0, 0)
E/ ( 2290):
E/ ( 2290): DEBUG:: ImgSize:942080 bytesperline:1280
E/ ( 2290):
E/ ( 2290): DEBUG:: ImgSize:491520 bytesperline:1280
E/ ( 2290): MFC-FIMC Initial...

Read more...

Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

For Origen board on Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=82

No display but audio works.

Amit Khare (amit-khare) wrote :

observed with origen android build
https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=99

You tube is not playing any video either in small screen or full screen.

Botao (botao-sun) wrote :

This feature is still unavailable on Linaro Origen Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=18

Botao (botao-sun) wrote :

Sorry, it should be:

For Samsung Origen board, observed on Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=25

YouTube video totally can't be played.

Botao (botao-sun) wrote :

For Samsung Origen board, observed on Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=33

YouTube video can't be played.

Botao (botao-sun) wrote :

For Samsung Origen board, observed on Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob-12.08-release/#build=1

YouTube video can't be played.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers