ICS: All arches: No aplay / arecord or equivalent

Reported by warmcat on 2011-12-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Low
vishal

Bug Description

This is with current tilt-android-tracking kernel and build 4 of the Panda ICS rootfs

I can't find any commandline tool to confirm audio. I noticed with GB, Vishal had equivalents for aplay and arecord, which would be useful for us to do smoke tests like we do on Ubuntu (where there is usually smoke, but that's not the point ^^).

I guess this would be useful for all the arches not just us. It's not critical that it uses rest of userspace infrastructure the goal would just be confirm alsa device at kernel and minimal userland level.

vishal (vishalbhoj) wrote :

Andy,

On ICS audio implementation changed from alsa-lib based to tinyalsa based. We don't have audio enabled yet. for time being till we enable them in the builds, you can copy the needed library(libtinyalsa.so) and the tools (tinymix,tinycap,tinyplay) from the attached tarball to test the driver.

warmcat (andy-warmcat) wrote :

Looping Jassi

Thanks Vishal, that'll be a big help in the meanwhile.

vishal (vishalbhoj) on 2011-12-27
Changed in linaro-android:
assignee: nobody → vishal (vishalbhoj)
milestone: none → 12.01
status: New → Confirmed
warmcat (andy-warmcat) wrote :

Vishal, I start to use tinyalsa but it has a big problem.

Currently, card # is hardcoded to 0. So, we can't test HDMI which is card 1.

https://www.gitorious.org/omap-audio/tinyalsa/blobs/master/tinyplay.c#line204

also, version you sent seems older than the one found at the repository linked above.

warmcat (andy-warmcat) wrote :

Okie... after some pondering and trial and error, here's the magic sequence for onboard audio playback confirm, which is working fine on current tilt-android-tracking

tinymix 51 1
tinymix 6 118
tinymix 36 1
tinymix 23 120
tinymix 34 1
tinymix 78 1
tinymix 79 1
tinymix 67 13
tinyplay /system/test48.wav
Playing sample: 2 ch, 48000 hz, 16 bit
...

HDMI card is there and looking in good state, but I can't test it with current tinyplay.

I think all that's needed is hack in a card number switch to change first param of this

    pcm = pcm_open(0, device, flags, config);

in tinyplay sources, maybe similar deal in tinymix if HDMI volume doesn't default to something reasonable.

warmcat (andy-warmcat) wrote :

Here's the line-in magic sequence for record action, this is also working with one restriction (inherited from vanilla right now), it will only deliver 32-bit samples, so you need to request 32-bit samples

tinymix 63 11
tinymix 62 12
tinymix 82 2
tinymix 81 2
tinymix 64 1,1
tinymix 65 4,4
tinycap /cache/file.wav -d 0 -r 48000 -b 32

Zach Pfeffer (pfefferz) on 2012-01-06
Changed in linaro-android:
importance: Undecided → Low
Zach Pfeffer (pfefferz) on 2012-01-23
Changed in linaro-android:
milestone: 12.01 → 12.02
vishal (vishalbhoj) wrote :

tinyplay,tinymix,tinycap are now built part of the image in 12.02 builds

Changed in linaro-android:
status: Confirmed → Fix Committed
Zach Pfeffer (pfefferz) on 2012-02-22
Changed in linaro-android:
status: Fix Committed → Fix Released
Vinayak (bigbhatmaam) wrote :

Hi andy,

I tried the the playback tinymix and tinyplay settings you had given and they worked fine on my Pandaboard Rev A2 (4430), but only one channel was being played out.
The tinymix and tinycap settings started recording, but once the 'wav' file was played out it had only noise. The audio input to my Pandaboard is from a PC Media Player with the volume setting to 50%.

Please confirm if these settings are meant for 4430 or 4460. If it is for 4430, please let me know I am doing something wrong.

I am experimenting with the 236 build of linaro-android/panda-ics-gcc46-tilt-tracking-blob.

thanks and regards,
Vinayak

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments