the image url in lava-job is not correct

Reported by Yongqin Liu on 2011-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Medium
Frans Gifford
Linaro Android Infrastructure
Medium
Frans Gifford
Yongqin Liu (liuyq0307) on 2011-11-28
Changed in linaro-android-infrastructure:
assignee: nobody → Frans Gifford (fgiff)
Frans Gifford (fgiff) wrote :

Probably related to the fact that since ICS, we use TARGET_PRODUCT=full_panda rather than the old TARGET_PRODUCT=panda

Changed in linaro-android:
assignee: nobody → Frans Gifford (fgiff)
milestone: none → 11.12
Changed in linaro-android-infrastructure:
status: New → Confirmed
Changed in linaro-android:
status: New → Triaged
Frans Gifford (fgiff) on 2011-11-28
Changed in linaro-android:
status: Triaged → In Progress
Changed in linaro-android-infrastructure:
status: Confirmed → In Progress
Paul Sokolovsky (pfalcon) wrote :

I'd also like to make processing more data-driven. I.e. avoid ladders of:

if foo == "bar":

in the code, and instead to have:

PRODUCT_MAP = {
"foo": "bar",
}

or

PRODUCT_MAP = {
"foo": ("bar", "baz"),
}

IMHO, this ticket is good chance to do such refactor. But if not, let's spawn another ticket for that.

Frans Gifford (fgiff) wrote :

Great suggestion, I don't like long if/elses either.

Added a PRODUCT_MAP object to map a TARGET_PRODUCT to its corresponding LAVA parameters.

Thanks Frans!

On 28 November 2011 05:50, Frans Gifford <email address hidden> wrote:
> Great suggestion, I don't like long if/elses either.
>
> Added a PRODUCT_MAP object to map a TARGET_PRODUCT to its corresponding
> LAVA parameters.
>
> --
> You received this bug notification because you are a member of Linaro
> Android Team, which is subscribed to Linaro Android.
> Matching subscriptions: all-android-bugs
> https://bugs.launchpad.net/bugs/897114
>
> Title:
>  the image url in lava-job is not correct
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/897114/+subscriptions
>

--
Zach Pfeffer
Android Platform Team Lead, Linaro Platform Teams
Linaro.org | Open source software for ARM SoCs
Follow Linaro: http://www.facebook.com/pages/Linaro
http://twitter.com/#!/linaroorg - http://www.linaro.org/linaro-blog

Frans Gifford (fgiff) on 2011-12-01
Changed in linaro-android:
status: In Progress → Fix Committed
Changed in linaro-android-infrastructure:
status: In Progress → Fix Committed
Changed in linaro-android-infrastructure:
importance: Undecided → Medium
Zach Pfeffer (pfefferz) on 2011-12-02
Changed in linaro-android:
importance: Undecided → Medium
Paul Sokolovsky (pfalcon) wrote :

No issues raised, so assuming fixed.

Changed in linaro-android-infrastructure:
status: Fix Committed → Fix Released
Frans Gifford (fgiff) on 2011-12-07
Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers