DVI out port is not working with staging-panda or tracking-panda

Bug #893000 reported by Abhishek Paliwal on 2011-11-21
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
High
Bernhard Rosenkraenzer
linaro-landing-team-ti
Fix Released
Wishlist
Unassigned

Bug Description

Description:
===========
DVI Out port is not working with Staging Panda build. This is secondary video output port.
(2nd HDMI female port from Ethernet port on device, maked as DVI-D )

Tried connecting :
1. HDMI(on device) to DVI (on monitor) cable - No display on Monitor.
2. HDMI(on device) to HDMI(on monitor) cable - No display on Monitor.

Note: HDMI out works fine for HDMI port(immediaet next to ethernet port on device)

Reproducible:
===========
Yes, 5/5 time

IMPACT:
========
Unable to use secondary video out.

Steps:
==========
1. Connect HDMI-DVI cable to DVI-D port on Panda board.
2. Bootup device.
Issue: No Video out.

Hardware:
==========
Panda Rev A3
USB Mouse connected
HDMI out to TV
8GB SD card

Software:
==========
https://android-build.linaro.org/builds/~linaro-android/staging-panda-11.11-release/#build=4

Logs:
======
Bootup Logs / Logcat / dmesg attached.

Zach Pfeffer (pfefferz) on 2011-12-05
summary: - Panda: DVI out port is not working with Staging-panda release
+ Panda: DVI out port is not working with staging-panda or tracking-panda
summary: - Panda: DVI out port is not working with staging-panda or tracking-panda
+ DVI out port is not working with staging-panda or tracking-panda
Changed in linaro-android:
importance: Undecided → High
warmcat (andy-warmcat) wrote :

Does DVI and HDMI both work on AOSP build? AIUI it's just DVI there, we changed it to favour HDMI when we ported it, since that can support 1080p.

Changed in linaro-landing-team-ti:
importance: Undecided → Wishlist
Anmar Oueja (anmar) wrote :

Tony: Since HDMI works and if HDMI->DVI cable works, then I would mark this bug as low.

Is there any way to enable dvi instead of hdmi? I'm asking because we wanted to attach a 7" touchscreen to the lcd expansion connector, and the signals are the same...

Thanks to Jassi I was able to get dvi to work again. Here are the changes to revert it to the old behaviour:

edit arch/arm/mach-omap2/board-omap4panda.c

--------------
static struct omap_dss_device *omap4_panda_dss_devices[] = {
        &omap4_panda_dvi_device,
        &omap4_panda_hdmi_device,
};

static struct omap_dss_board_info omap4_panda_dss_data = {
        .num_devices = ARRAY_SIZE(omap4_panda_dss_devices),
        .devices = omap4_panda_dss_devices,
        .default_device = &omap4_panda_dvi_device, };
--------------

Taiten Peng (taitenpeng) wrote :

confirmed #13 works,but somehow it turns out the system video output become mirror mode on dvi and hdmi.

I've just committed a change in android.git.linaro.org /kernel/panda.git that adds a config option for switching between the displays.

If you want the DVI port to be the primary output, rebuild the kernel with
CONFIG_MACH_OMAP4_PANDA_DVI_PRIMARY
enabled.

Changed in linaro-android:
assignee: nobody → Bernhard Rosenkraenzer (berolinux)
status: New → Fix Committed
milestone: none → 12.06
warmcat (andy-warmcat) on 2012-06-27
Changed in linaro-landing-team-ti:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers