hdmi display not working with staging-origen manifest

Reported by Amit Pundir on 2011-11-10
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Medium
Amit Pundir

Bug Description

HDMI display not working with Samsung LT's latest origen kernel http://git.linaro.org/landing-teams/working/samsung/kernel.git

Amit Pundir (pundiramit) wrote :
Amit Pundir (pundiramit) on 2011-11-11
Changed in linaro-android:
status: New → Confirmed

This is blocking issue to test Origen board(unless someone has additional LCD display)

Changed in linaro-android:
importance: Undecided → High
Amit Pundir (pundiramit) wrote :

Graphics Allocator(Gralloc) on Android iterates from fb0 to fbX till it doesn't find a valid fb descriptor. Gralloc finds and open a valid Fb descriptor well before trying Origen's hardcoded HDMI fb descriptor(/dev/graphics/fb10). Need to find a generic solution to support both lcd and hdmi displays from gralloc.

Changed in linaro-android:
assignee: nobody → Amit Pundir (pundiramit)
Zach Pfeffer (pfefferz) on 2011-11-16
Changed in linaro-android:
importance: High → Medium

There are additional LCDs in Cambridge if you require one to solve this issue.

Talk to Joey about getting one.

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Zach Pfeffer (pfefferz) wrote :

Lets go with boot args. Amit will add.

Changed in linaro-android:
milestone: none → 11.12

Valid for : ./linaro-image-tools/linaro-android-media-create --mmc /dev/sdb --dev snowball_sd --system system.tar.bz2 --userdata userdata.tar.bz2 --boot boot.tar.bz2 as well

Zach Pfeffer (pfefferz) wrote :

This should now be done on ICS.

Changed in linaro-android:
importance: Medium → High
Angus Ainslie (angus-akkea) wrote :

On Mon, Nov 28, 2011 at 9:24 AM, Zach Pfeffer <email address hidden> wrote:
> This should now be done on ICS.
>

Does ICS allow for dual head support ?

> ** Changed in: linaro-android
>   Importance: Medium => High
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/888644
>
> Title:
>  hdmi display not working with staging-origen manifest
>
> Status in Linaro Android:
>  Confirmed
>
> Bug description:
>  HDMI display not working with Samsung LT's latest origen kernel
>  http://git.linaro.org/landing-teams/working/samsung/kernel.git
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/888644/+subscriptions
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Amit Pundir (pundiramit) wrote :

Dual head support is still not there in ICS as far as I looked into. Framebuffer initialization still happens as gralloc.

Current status is that I can map fb0 to hdmi (at default resolution) through bootargs. Next thing to do is to run it at 1080p.

Changed in linaro-android:
status: Confirmed → In Progress
Zach Pfeffer (pfefferz) on 2011-12-19
Changed in linaro-android:
importance: High → Medium
Amit Pundir (pundiramit) wrote :

Not going to be fixed in 11.12 release.

Current status is that LCD output (fb0) can be mapped to HDMI (at default resolution) through bootargs. Next thing to do is to run it at 1080p.

Zach Pfeffer (pfefferz) on 2011-12-21
Changed in linaro-android:
milestone: 11.12 → 12.01
Zach Pfeffer (pfefferz) wrote :

Please talk to <email address hidden> about adding boot arg edits to linaro-android-media-create.

Amit Pundir (pundiramit) wrote :

The attached kernel patch contains a workaround for this bug. Default display remains LCD. But with an additional bootarg "s5p_tvout_fb.hdmi_lcd_display=1", LCD display can be routed to HDMI @1024x600 resolution.

Zach Pfeffer (pfefferz) on 2012-01-23
Changed in linaro-android:
milestone: 12.01 → 12.02
Sangwook Lee (sangwook) wrote :

Amit's patch was pushed to

git: git://git.linaro.org/landing-teams/working/samsung/kernel.git
branch: android
tag : android-release-2012-01-hdmi

Amit Pundir (pundiramit) wrote :

With an additional bootarg "s5p_tvout_fb.hdmi_lcd_display=1", LCD display can be routed to HDMI @1024x600 resolution.

Changed in linaro-android:
status: In Progress → Fix Released
Changed in linaro-android:
status: Fix Released → Fix Committed
Zach Pfeffer (pfefferz) on 2012-02-22
Changed in linaro-android:
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments