Suspend does not work on Samsung Origen

Reported by Zach Pfeffer on 2011-10-23
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
High
Chengjie HE
linaro-landing-team-samsung
Fix Released
High
Inderpal Singh

Bug Description

On:

https://android-build.linaro.org/builds/~linaro-android/staging-origen-11.10-release/#build=5

I get the failure attached, see the end of the log. I don't see it everytime.

Zach Pfeffer (pfefferz) wrote :
Changed in linaro-android:
importance: Undecided → High
status: New → Confirmed
Changed in linaro-landing-team-samsung:
status: New → Confirmed
Changed in linaro-landing-team-samsung:
status: Confirmed → Fix Committed
Alexander Sack (asac) on 2011-10-27
tags: added: linaro-android origen-staging suspend-resume
Usman Ahmad (usman-ah) on 2011-10-27
Changed in linaro-landing-team-samsung:
milestone: none → 2011.10
importance: Undecided → High
Changed in linaro-android:
status: Confirmed → Fix Committed
Botao Sun (botao-sun) on 2011-10-28
tags: removed: origen-staging
Botao Sun (botao-sun) wrote :

It works on the 11.11 RC1.

Changed in linaro-android:
milestone: none → 11.11
Fathi Boudra (fboudra) wrote :

Set to fix-released according to Botao comment:
http://bugs.launchpad.net/linaro-android/+bug/880423/comments/2

Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
Changed in linaro-android:
status: Fix Committed → Fix Released
Botao Sun (botao-sun) wrote :

It doesn't work on 11.11 RC2: https://android-build.linaro.org/builds/~linaro-android/staging-origen-11.11-release/#build=3

Refer to attachment to get the logcat, kmsg and serial output.

Changed in linaro-android:
status: Fix Released → In Progress
Zach Pfeffer (pfefferz) on 2011-11-25
Changed in linaro-android:
milestone: 11.11 → 11.12
Botao Sun (botao-sun) wrote :

Observed on ICS with 4.0.1 branch, build 56:

https://android-build.linaro.org/builds/~linaro-android/staging-origen/#build=56

System hangs after entered the suspend mode:
###########################################################
root@android:/ # <6>request_suspend_state: sleep (0->3) at 93959877842 (2000-01)
request_suspend_state: sleep (0->3) at 93959877842 (2000-01-01 00:01:32.0514108)
<4>console_early_suspend: Can't set console
console_early_suspend: Can't set console
<6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
done.
<7>PM: Preparing system for mem sleep
Freezing user space processes ... Freezing user space processes ... (elapsed 0..
done.
Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.

<7>PM: Entering mem sleep
Suspending console(s) (use no_console_suspend to debug)
Suspending console(s) (use no_console_suspend to debug)
###########################################################

Botao Sun (botao-sun) wrote :

Also Observed on the latest workable build on 2.3.7 branch, build 53:

https://android-build.linaro.org/builds/~linaro-android/staging-origen/#build=53

System hangs after entered the suspend mode:
###########################################################
# <6>request_suspend_state: sleep (0->3) at 338465536312 (2000-01-01 00:05:36.5)
request_suspend_state: sleep (0->3) at 338465536312 (2000-01-01 00:05:36.564860)
<6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
done.
<7>PM: Preparing system for mem sleep
Freezing user space processes ... Freezing user space processes ... (elapsed 0..
done.
Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.

<7>PM: Entering mem sleep
Suspending console(s) (use no_console_suspend to debug)
Suspending console(s) (use no_console_suspend to debug)
<3>pm_op(): platform_pm_suspend+0x0/0x6c returns -16
<3>PM: Device alarm failed to suspend: error -16
<3>PM: Some devices failed to suspend
<6>PM: resume of devices complete after 0.140 msecs
pm_op(): platform_pm_suspend+0x0/0x6c returns -16
PM: Device alarm failed to suspend: error -16
PM: Some devices failed to suspend
PM: resume of devices complete after 0.140 msecs
<7>PM: Finishing wakeup.
Restarting tasks ... Restarting tasks ... done.
done.
<6>suspend: exit suspend, ret = -16 (2000-01-01 00:05:40.012334303 UTC)
suspend: exit suspend, ret = -16 (2000-01-01 00:05:40.012334303 UTC)
<6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
done.
<7>PM: Preparing system for mem sleep
Freezing user space processes ... Freezing user space processes ... (elapsed 0..
done.
Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.

<7>PM: Entering mem sleep
Suspending console(s) (use no_console_suspend to debug)
Suspending console(s) (use no_console_suspend to debug)
###########################################################

This looks like one of the problems we're trying to solve in Ubuntu.

The wlan driver module needs to be unloaded on suspend and then
reloaded on resume

On Wed, Nov 30, 2011 at 4:12 AM, Botao Sun <email address hidden> wrote:
> Also Observed on the latest workable build on 2.3.7 branch, build 53:
>
> https://android-build.linaro.org/builds/~linaro-android/staging-
> origen/#build=53
>
> System hangs after entered the suspend mode:
> ###########################################################
> # <6>request_suspend_state: sleep (0->3) at 338465536312 (2000-01-01 00:05:36.5)
> request_suspend_state: sleep (0->3) at 338465536312 (2000-01-01 00:05:36.564860)
> <6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
> done.
> <7>PM: Preparing system for mem sleep
> Freezing user space processes ... Freezing user space processes ... (elapsed 0..
> done.
> Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.
>
> <7>PM: Entering mem sleep
> Suspending console(s) (use no_console_suspend to debug)
> Suspending console(s) (use no_console_suspend to debug)
> <3>pm_op(): platform_pm_suspend+0x0/0x6c returns -16
> <3>PM: Device alarm failed to suspend: error -16
> <3>PM: Some devices failed to suspend
> <6>PM: resume of devices complete after 0.140 msecs
> pm_op(): platform_pm_suspend+0x0/0x6c returns -16
> PM: Device alarm failed to suspend: error -16
> PM: Some devices failed to suspend
> PM: resume of devices complete after 0.140 msecs
> <7>PM: Finishing wakeup.
> Restarting tasks ... Restarting tasks ... done.
> done.
> <6>suspend: exit suspend, ret = -16 (2000-01-01 00:05:40.012334303 UTC)
> suspend: exit suspend, ret = -16 (2000-01-01 00:05:40.012334303 UTC)
> <6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
> done.
> <7>PM: Preparing system for mem sleep
> Freezing user space processes ... Freezing user space processes ... (elapsed 0..
> done.
> Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.
>
> <7>PM: Entering mem sleep
> Suspending console(s) (use no_console_suspend to debug)
> Suspending console(s) (use no_console_suspend to debug)
> ###########################################################
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/880423
>
> Title:
>  Suspend does not work on Samsung Origen
>
> Status in Linaro Android:
>  In Progress
> Status in Linaro Samsung Landing Team Project:
>  Fix Released
>
> Bug description:
>  On:
>
>  https://android-build.linaro.org/builds/~linaro-android/staging-
>  origen-11.10-release/#build=5
>
>  I get the failure attached, see the end of the log. I don't see it
>  everytime.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/880423/+subscriptions
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Zach Pfeffer (pfefferz) on 2011-11-30
Changed in linaro-android:
assignee: nobody → Botao Sun (botao-sun)
Botao Sun (botao-sun) wrote :
Download full text (6.6 KiB)

Existing in build 61:

https://android-build.linaro.org/builds/~linaro-android/staging-origen/#build=61

################################################################################
root@android:/system/bin # <6>request_suspend_state: sleep (0->3) at 2391989417)
request_suspend_state: sleep (0->3) at 2391989417943 (2000-01-01 00:39:50.<1532)
4>console_early_suspend: Can't set console
console_early_suspend: Can't set console
<6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
done.
<7>PM: Preparing system for mem sleep
Freezing user space processes ... Freezing user space processes ... <6>active we

active wake lock Power
                      anagerService

<3>Freezing of user space aborted
Freezing of user space aborted

Restarting tasks ... Restarting tasks ... done.
done.
<6>suspend: exit suspend, ret = -16 (2000-01-01 00:39:50.135954982 UTC)
suspend: exit suspend, ret = -16 (2000-01-01 00:39:50.135954982 UTC)
<6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
done.
<7>PM: Preparing system for mem sleep
Freezing user space processes ... Freezing user space processes ... (elapsed 0..
done.
Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.

<7>PM: Entering mem sleep
Suspending console(s) (use no_console_suspend to debug)
Suspending console(s) (use no_console_suspend to debug)
<3>pm_op(): platform_pm_suspend+0x0/0x6c returns -16
<3>PM: Device alarm failed to suspend: error -16
<3>PM: Some devices failed to suspend
<6>PM: resume of devices complete after 0.126 msecs
pm_op(): platform_pm_suspend+0x0/0x6c returns -16
PM: Device alarm failed to suspend: error -16
PM: Some devices failed to suspend
PM: resume of dev...

Read more...

Angus Ainslie (angus-akkea) wrote :
Download full text (4.5 KiB)

Is this with the ath6kl dirver module loaded ?

Do an lsmod before you try the suspend.

On Fri, Dec 2, 2011 at 1:30 AM, Botao Sun <email address hidden> wrote:
> Existing in build 61:
>
> https://android-build.linaro.org/builds/~linaro-android/staging-
> origen/#build=61
>
> ################################################################################
> root@android:/system/bin # <6>request_suspend_state: sleep (0->3) at 2391989417)
> request_suspend_state: sleep (0->3) at 2391989417943 (2000-01-01 00:39:50.<1532)
> 4>console_early_suspend: Can't set console
> console_early_suspend: Can't set console
> <6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
> done.
> <7>PM: Preparing system for mem sleep
> Freezing user space processes ... Freezing user space processes ... <6>active we
>
> active wake lock Power
>                      anagerService
>
> <3>Freezing of user space  aborted
> Freezing of user space  aborted
>
>
> Restarting tasks ... Restarting tasks ... done.
> done.
> <6>suspend: exit suspend, ret = -16 (2000-01-01 00:39:50.135954982 UTC)
> suspend: exit suspend, ret = -16 (2000-01-01 00:39:50.135954982 UTC)
> <6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
> done.
> <7>PM: Preparing system for mem sleep
> Freezing user space processes ... Freezing user space processes ... (elapsed 0..
> done.
> Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.
>
> <7>PM: Entering mem sleep
> Suspending console(s) (use no_console_suspend to debug)
> Suspending console(s) (use no_console_suspend to debug)
> <3>pm_op(): platform_pm_suspend+0x0/0x6c returns -16
> <3>PM: Device alarm failed to suspend: error -16
> <3>PM: Some devices failed to suspend
> <6>PM: resume of devices complete after 0.126 msecs
> pm_op(): platform_pm_suspend+0x0/0x6c returns -16
> PM: Device alarm failed to suspend: error -16
> PM: Some devices failed to suspend
> PM: resume of devices complete aft<r 0.126 msecs
> 7>PM: Finishing wakeup.
> Restarting tasks ... Restarting tasks ... done.
> done.
> <6>suspend: exit suspend, ret = -16 (2000-01-01 00:39:53.481211421 UTC)
> suspend: exit suspend, ret = -16 (2000-01-01 00:39:53.481211421 UTC)
> <6>active wake lock mmc_delayed_work
> active wake lock mm<_delayed_work
> 6>active wake lock alarm_rtc, time left 385
> active wake lock alarm_rtc, time left 385
> <6>PM: Syncing filesystems ... PM: Syncing filesystems ... done.
> done.
> <7>PM: Preparing system for mem sleep
> Freezing user space processes ... Freezing user space processes ... (elapsed 0..
> done.
> Freezing remaining freezable tasks ... Freezing remaining freezable tasks ... (.
>
> <7>PM: Entering mem sleep
> Suspending console(s) (use no_console_suspend to debug)
> Suspending console(s) (use no_console_suspend to debug)
> <3>pm_op(): platform_pm_suspend+0x0/0x6c returns -16
> <3>PM: Device alarm failed to suspend: error -16
> <3>PM: Some devices failed to suspend
> <6>PM: resume of devices complete after 0.122 msecs
> pm_op(): platform_pm_suspend+0x0/0x6c returns -16
> PM: Device alarm failed to suspend: error -16
> PM: Some devices failed to suspend
> PM: resume of devices complete aft<r 0.122 msecs
> 7>PM...

Read more...

Botao Sun (botao-sun) wrote :

No, the output of lsmod is empty:

########################
root@android:/ # lsmod
root@android:/ #
########################

Botao Sun (botao-sun) wrote :
Changed in linaro-android:
status: In Progress → Fix Committed
Fathi Boudra (fboudra) on 2011-12-22
Changed in linaro-android:
status: Fix Committed → Fix Released
Zach Pfeffer (pfefferz) wrote :

Looks like we're broken again on:

https://android-build.linaro.org/builds/~linaro-android/staging-origen-12.01-release/#build=2

Clicking the mouse or the keyboard doesn't wake the unit up.

Changed in linaro-android:
status: Fix Released → New
importance: High → Medium
assignee: Botao Sun (botao-sun) → Amit Pundir (pundiramit)
milestone: 11.12 → 12.02
Zach Pfeffer (pfefferz) on 2012-01-30
Changed in linaro-android:
assignee: Amit Pundir (pundiramit) → Chengjie HE (chengjie-he)
importance: Medium → High
Tushar Behera (tusharbehera) wrote :

On 02/21/2012 08:18 AM, Zach Pfeffer wrote:
> I see https://android-build.linaro.org/builds/~linaro-android/origen-
> ics-gcc46-samsunglt-stable-blob-12.02-release/#build=1 suspend and
> refuse to power back on after pressing various keys.
>
Would you please report the behavior when you plug-in/out a USB device
after pressing some key to resume?

Suspend -> Press a key to resume -> Plug-in/out a USB device

--
Tushar Behera

Zach Pfeffer (pfefferz) on 2012-02-22
Changed in linaro-android:
milestone: 12.02 → 12.03
Chengjie HE (chengjie-he) wrote :

the suspend->resume, now is OK, the reason is too many irqs for uart makes the cpu stale;
new issue is suspend->resume->suspend, still struggling on this tough one

Changed in linaro-android:
status: New → In Progress
Inderpal Singh (ips) wrote :

The (suspend-> resume -> Immediate supend) issue can be fixed with the attached patch.
With this patch the system resumes fine but screen does not get updated. The remaining system works fine.

If I use software rendering there is no issue in screen updation after resume. Everything works just fine.
Hence, hardware rendering (Mali binaries in vendor.tar.bz2) has some issues with respect to suspend/resume.

Inderpal Singh (ips) wrote :

It is fixed. There was no issue as such with Mali binaries. The only thing was that Mali Power Management was not enabled in the kernel. Once enabled suspend/resume works fine even with hardware rendering. The screen does not freeze.

Summary: The following 3 things need to be done to fix the whole issue.

1. Disbale Kernel Low level debugging (CONFIG_DEBUG_LL)
2. Enable Mali Power Management (CONFIG_USING_PMM)
3. Use the patch attached in msg#17

I have tested this fix with kernel at [1].
Jacky, can you please confirm that it fixes the issue.

[1] git://git.linaro.org/landing-teams/working/samsung/kernel.git (branch: android, tag: android-release-2012-02 )

Thanks,
Inder

Tushar Behera (tusharbehera) wrote :

The patches for the above are updated at given location. Please validate.

git://git.linaro.org/landing-teams/working/samsung/kernel.git
(topic/android-mali)

Chengjie HE (chengjie-he) wrote :

with the kernel patches and device/linaro/origen patch, this issue is fixed.

Changed in linaro-android:
status: In Progress → Fix Committed
Usman Ahmad (usman-ah) on 2012-03-22
Changed in linaro-landing-team-samsung:
milestone: 2011.10 → 2012.03
assignee: nobody → Inderpal Singh (ips)
Zach Pfeffer (pfefferz) wrote :

Released in 12.03.

Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers