Origen Ethernet can't pass the "plug out & plug in" test.

Reported by Botao Sun on 2011-10-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Medium
Unassigned
linaro-landing-team-samsung
Fix Released
Medium
Sangwook Lee

Bug Description

With the USB Ethernet adapter - Linksys USB200M v2.1, chip model ASIX AX88772, the Samsung Origen board can't pass the "plug out & plug in" test.

You will get 2 issues if you try to do that:

1. The Ethernet icon on the upper right cornet will be gone.

2. "ping" command can't be executed at all or just can be executed once if you set DNS manually. And even it runs, there is error message in the output which wouldn't appear if you plug in the adapter all the time.

For more details, see below description. If any one who want to know the whole story, feel free to go the bug 863451: https://bugs.launchpad.net/linaro-android/+bug/863451

About the "plug-in and plug-out":

1. If the adapter is plugged in before the board boots up:

Disable and enable can be executed correctly, and "ping" command can be executed correctly.

2. If the adapter is plugged in after the board boots up:

Disable and enable can be executed correctly, but there is no "Ethernet" icon in the upper right corner. "ping" command can't be executed correctly except do a Ethernet "disable and enable" action then execute "setprop net.dns1 192.168.1.1" to set DNS first. But even set DNS manually, "ping" command doesn't always work, see log below:
###########################################################
# ping www.google.com
ping: unknown host www.google.com
# setprop net.dns1 192.168.1.1
# ping www.google.com
PING www.l.google.com (74.125.71.103) 56(84) bytes of data.
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=1 ttl=41 time=238 s
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=2 ttl=41 time=232 s
ping: sendmsg: Network is unreachable
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=4 ttl=41 time=241 s
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=5 ttl=41 time=238 s
ping: sendmsg: Network is unreachable
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=7 ttl=41 time=237 s
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=8 ttl=41 time=238 s
ping: sendmsg: Network is unreachable
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=10 ttl=41 time=237s
64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=11 ttl=41 time=231s
ping: sendmsg: Network is unreachable
^C
--- www.l.google.com ping statistics ---
12 packets transmitted, 8 received, 33% packet loss, time 11006ms
rtt min/avg/max/mdev = 231.590/237.083/241.630/3.237 ms
# ping www.google.com
ping: unknown host www.google.com
# ping www.google.com
ping: unknown host www.google.com

[init.svc.dhcpcd_eth0]: [running]
[dhcp.eth0.result]: [ok]
[dhcp.eth0.pid]: [9361]
[dhcp.eth0.reason]: [BOUND]
[dhcp.eth0.dns1]: [211.147.6.3]
[dhcp.eth0.dns2]: [8.8.8.8]
[dhcp.eth0.dns3]: []
[dhcp.eth0.dns4]: []
[dhcp.eth0.ipaddress]: [192.168.1.9]
[dhcp.eth0.gateway]: [192.168.1.1]
[dhcp.eth0.mask]: [255.255.255.0]
[dhcp.eth0.leasetime]: [86400]
[dhcp.eth0.server]: [192.168.1.1]
[net.dns1]: [192.168.1.1]
###########################################################

That means you can only run "ping" command 1 time after the manually DNS setting, but actually, after set DNS manually, this setting is always there. This is a defect. And there is "ping: sendmsg: Network is unreachable", this doesn't appear in situation 1.

3. If the adapter is plugged in before the board boots up, but after the board enters the Android idle screen, plug it out and plug it in again:

3.1 If the Ethernet status is enabled:
After plug it out and plug it in, although the Ethernet status in setting menu still shows "enabled", the adapter even can't get IP address, of course, the "ping" command can't be executed correctly. At this time, if do the disable and enable action, the adapter can get the IP address and DNS can also be set automatically, but still have "ping: sendmsg: Network is unreachable" which is not shown in situation 1. Another thing is you can run "ping" many times here, not only 1 time like situation 2.

3.2 If the Ethernet status is disabled:
After plug it out and plug it in, then enable the Ethernet, there is no "Ethernet" icon in the upper right corner. The adapter can get the IP address but can't execute "ping" command:

# ping www.google.com
ping: unknown host www.google.com

However, the DNS setting is already there:

[init.svc.dhcpcd_eth0]: [running]
[dhcp.eth0.result]: [ok]
[dhcp.eth0.pid]: [3862]
[dhcp.eth0.reason]: [BOUND]
[dhcp.eth0.dns1]: [211.147.6.3]
[dhcp.eth0.dns2]: [8.8.8.8]
[dhcp.eth0.dns3]: []
[dhcp.eth0.dns4]: []
[dhcp.eth0.ipaddress]: [192.168.1.9]
[dhcp.eth0.gateway]: [192.168.1.1]
[dhcp.eth0.mask]: [255.255.255.0]
[dhcp.eth0.leasetime]: [86400]
[dhcp.eth0.server]: [192.168.1.1]

Even set DNS manually like situation 2, the ping command still can't be executed correctly:

# setprop net.dns1 192.168.1.1
# ping www.google.com
ping: unknown host www.google.com

In this situation, you have to do "disable and enable" Ethernet then set DNS manually, the "ping" command can be executed with "ping: sendmsg: Network is unreachable" message, but multiple times.

Above all are the tests I did in several different situations.

Botao Sun (botao-sun) wrote :
Download full text (4.5 KiB)

It works well on Origen ubuntu whatever how I plug it out and plug it in. I even let the "ping" command continuously running there.

The Origen ubuntu images I used are:
hwpack_linaro-lt-origen_20111017-0_armel_supported.tar.gz
alip-n-tar-20111017-0.tar.gz

#################################################################
root@linaro-alip:~# ping www.google.com
PING www.l.google.com (72.14.203.147) 56(84) bytes of data.
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=1 ttl=48 time=90.2s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=2 ttl=48 time=94.0s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=3 ttl=48 time=92.5s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=4 ttl=48 time=90.4s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=5 ttl=48 time=92.8s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=6 ttl=48 time=92.3s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=7 ttl=48 time=91.4s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=8 ttl=48 time=92.3s
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=22 ttl=48 time=93.s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=23 ttl=48 time=94.s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=24 ttl=48 time=92.s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=25 ttl=48 time=90.s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=26 ttl=48 time=89.s
64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=27 ttl=48 time=92.s
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable ...

Read more...

Changed in linaro-landing-team-samsung:
assignee: nobody → Giridhar BM (giridhar-bm)
importance: Undecided → Medium
status: New → Triaged
Download full text (9.4 KiB)

You should use a hwpack from the 18th or later as that is the release version

On Fri, Oct 21, 2011 at 10:49 AM, Botao Sun <email address hidden> wrote:
> It works well on Origen ubuntu whatever how I plug it out and plug it
> in. I even let the "ping" command continuously running there.
>
> The Origen ubuntu images I used are:
> hwpack_linaro-lt-origen_20111017-0_armel_supported.tar.gz
> alip-n-tar-20111017-0.tar.gz
>
> #################################################################
> root@linaro-alip:~# ping www.google.com
> PING www.l.google.com (72.14.203.147) 56(84) bytes of data.
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=1 ttl=48 time=90.2s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=2 ttl=48 time=94.0s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=3 ttl=48 time=92.5s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=4 ttl=48 time=90.4s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=5 ttl=48 time=92.8s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=6 ttl=48 time=92.3s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=7 ttl=48 time=91.4s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=8 ttl=48 time=92.3s
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=22 ttl=48 time=93.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=23 ttl=48 time=94.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=24 ttl=48 time=92.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=25 ttl=48 time=90.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=26 ttl=48 time=89.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=27 ttl=48 time=92.s
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> ping: sendmsg: Network is unreachable
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=39 ttl=48 time=94.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=40 ttl=48 time=90.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=41 ttl=48 time=92.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=42 ttl=48 time=94.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=43 ttl=48 time=89.s
> 64 bytes from tx-in-f147.1e100.net (72.14.203.147): icmp_req=44 tt...

Read more...

Angus Ainslie (angus-akkea) wrote :
Download full text (6.1 KiB)

On Fri, Oct 21, 2011 at 10:40 AM, Botao Sun <email address hidden> wrote:
> The build I used for this bug is: https://android-
> build.linaro.org/builds/~linaro-android/staging-origen/#build=34
>

I was talking about the ubuntu hwpack you used

The Origen ubuntu images I used are:
hwpack_linaro-lt-origen_20111017-0_armel_supported.tar.gz

> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/879497
>
> Title:
>  Origen Ethernet can't pass the "plug out & plug in" test.
>
> Status in Linaro Android:
>  Confirmed
> Status in Linaro Samsung Landing Team Project:
>  New
>
> Bug description:
>  With the USB Ethernet adapter - Linksys USB200M v2.1, chip model ASIX
>  AX88772, the Samsung Origen board can't pass the "plug out & plug in"
>  test.
>
>  You will get 2 issues if you try to do that:
>
>  1. The Ethernet icon on the upper right cornet will be gone.
>
>  2. "ping" command can't be executed at all or just can be executed
>  once if you set DNS manually. And even it runs, there is error message
>  in the output which wouldn't appear if you plug in the adapter all the
>  time.
>
>  For more details, see below description. If any one who want to know
>  the whole story, feel free to go the bug 863451:
>  https://bugs.launchpad.net/linaro-android/+bug/863451
>
>  About the "plug-in and plug-out":
>
>  1. If the adapter is plugged in before the board boots up:
>
>  Disable and enable can be executed correctly, and "ping" command can
>  be executed correctly.
>
>  2. If the adapter is plugged in after the board boots up:
>
>  Disable and enable can be executed correctly, but there is no "Ethernet" icon in the upper right corner. "ping" command can't be executed correctly except do a Ethernet "disable and enable" action then execute "setprop net.dns1 192.168.1.1" to set DNS first. But even set DNS manually, "ping" command doesn't always work, see log below:
>  ###########################################################
>  # ping www.google.com
>  ping: unknown host www.google.com
>  # setprop net.dns1 192.168.1.1
>  # ping www.google.com
>  PING www.l.google.com (74.125.71.103) 56(84) bytes of data.
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=1 ttl=41 time=238 s
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=2 ttl=41 time=232 s
>  ping: sendmsg: Network is unreachable
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=4 ttl=41 time=241 s
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=5 ttl=41 time=238 s
>  ping: sendmsg: Network is unreachable
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=7 ttl=41 time=237 s
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=8 ttl=41 time=238 s
>  ping: sendmsg: Network is unreachable
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=10 ttl=41 time=237s
>  64 bytes from hx-in-f103.1e100.net (74.125.71.103): icmp_seq=11 ttl=41 time=231s
>  ping: sendmsg: Network is unreachable
>  ^C
>  --- www.l.google.com ping statistics ---
>  12 packets transmitted, 8 received, 33% packet loss, time 11006ms
>  rtt min/avg/max/mdev = 231.590/237.083/2...

Read more...

Botao Sun (botao-sun) wrote :

Tried with "hwpack_linaro-lt-origen_20111019-0_armel_supported.tar.gz" + "alip-n-tar-20111017-0.tar.gz", same output as comment #2, even the Ethernet icon on the upper right corner works well during the "plug out & plug in" process.

Botao Sun (botao-sun) on 2011-10-28
tags: added: ethernet linaro-android
Zach Pfeffer (pfefferz) on 2011-10-31
Changed in linaro-android:
milestone: 11.11 → none
Sangwook Lee (sangwook) on 2012-03-05
Changed in linaro-landing-team-samsung:
assignee: Giridhar BM (giridhar-bm) → Sangwook Lee (sangwook)
Sangwook Lee (sangwook) wrote :

I am attaching the patch to fix USB Ethernet, and this was just pushed

git://git.linaro.org/landing-teams/working/samsung/kernel.git (android)

So Android build will automatically include this patch from now on.

Description for patch:
=======================================================
Enable burst transfer from AHB for EHCI.
This fixes data transfer issue of USB Ethernet with EHCI.
Without this patch, ping works and network utilities such as scp hardly works.

It was tested on Origen board with the following configs.
root@linaro-alip:~# lsusb -t
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=exynos-ohci/3p, 12M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=s5p-ehci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=vend., Driver=MOSCHIP usb-ethernet driver, 480M

Changed in linaro-landing-team-samsung:
status: Triaged → Fix Committed
Changed in linaro-landing-team-samsung:
milestone: none → 2012.03
Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
Zach Pfeffer (pfefferz) on 2012-04-03
Changed in linaro-android:
assignee: Botao Sun (botao-sun) → nobody
Botao Sun (botao-sun) wrote :

Old Samsung Origen board had been removed from Linaro support scope, therefore, the status of this bug should be changed to "Won't Fix".

Changed in linaro-android:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers