Samsung Origen WIFI can't pass the "enable-disable" repeat test.

Reported by Botao Sun on 2011-10-18
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Medium
Amit Pundir

Bug Description

Although Samsung Origen WIFI works, but it's not stable enough. It can't pass the "enable-disable" repeat test.

For example, after you flash the images to SD card, transfer ath6k driver to path "/system/etc/firmware", then boot up the board to enable WIFI from the setting menu. It works at the first time, you can enable the WIFI successfully, then connect to a wireless access point, then surf the Internet.

But once you disable WIFI from the setting menu, you can't enable it once more. When you click the WIFI again, sometimes it shows "enabled", but then goes to "disabled" or "error". I even get the board reboot issue during this process.

The logcat output is in attachment.

Botao Sun (botao-sun) wrote :
Botao Sun (botao-sun) on 2011-10-18
description: updated
Sangwook Lee (sangwook) wrote :

@Botao,

Can I get the kernel log message at the same time that attached logcat was made ?

- # adb shell cat /proc/kmsg

or

- cat /proc/kmsg > /data/some_file.txt

I want to see what happens inside WLAN kernel driver when this is happening.

Botao Sun (botao-sun) wrote :

A possible reason may be the "rmmod" can't be executed properly when disable WIFI from UI, although it works well from the command line.

After last "enable-disable" test, I power off the board then power it on, then the board reboot. But after this, it shows that the wireless connection has been established and I also can see the Google main page. I think the board WIFI last status from a previous "enable-disable" test is "enabled".

The weird thing is this issue won't happen every time. At least once or twice, I execute the "enable-disable" actions successfully. But with the more times I repeat, it's finally failed. And I also find there are 2 entrance points to enable WIFI from UI, 1 is in the "Wireless & Networks" and another one is in the "Wi-Fi Settings". I got 1 or 2 times success to do the "enable-disable" from "Wi-Fi Settings", but all failed from "Wireless & Networks". It should be the same in logical to enable and disable WIFI from both interfaces, isn't it?

You can find the log in attachment.

Sangwook Lee (sangwook) wrote :

1) According to kernel log, "rmmod " has no problem, because it always show successful message :"card 0001 removed". The kernel log message looks fine to me.

2) please make sure that "Wireless & Network" is using the same API to "Wi-Fi Settings"

My another suggestion is going to test new driver ath6k, which is going to be loaded into Android platform. The new driver has the choice kernel menu ( polling based or interrupt based driver). we can choose the best one according to the experiments.

Zach Pfeffer (pfefferz) on 2011-11-25
Changed in linaro-android:
milestone: 11.11 → 11.12
Zach Pfeffer (pfefferz) on 2011-12-21
Changed in linaro-android:
assignee: Botao Sun (botao-sun) → Zach Pfeffer (pfefferz)
milestone: 11.12 → 12.01
Zach Pfeffer (pfefferz) on 2012-01-09
Changed in linaro-android:
assignee: Zach Pfeffer (pfefferz) → Amit Pundir (pundiramit)
Amit Pundir (pundiramit) wrote :

Committed Wlan support for Origen on ICS 4.0.3 branch http://review.android.git.linaro.org/#change,1395

Changed in linaro-android:
status: Confirmed → In Progress
Amit Pundir (pundiramit) on 2012-01-19
Changed in linaro-android:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers