Unable to play Angrybirds game on ICS, App opens but does not show proper game menu.

Reported by Abhishek Paliwal on 2011-10-12
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
IglooCommunity
Wishlist
Tony Mansson
Linaro Android
High
vishal
Linaro ST-Ericsson Landing Team Project
New
Wishlist
Mathieu Poirier
linaro-landing-team-arm
Won't Fix
Wishlist
Unassigned

Bug Description

Description:
==========
Unable to play Angrybirds game, Application opens but does not show proper menu on opening.
Opening second time - app closes immediately upon opening. Logcat attached.

-------Logs for 2nd iteration-------------------
I/KA3D ( 2043): Exiting because nativeUpdate returned false
D/FlurryAgent( 2043): Ending session
E/FlurryAgent( 2043):
E/FlurryAgent( 2043): java.io.FileNotFoundException: /data/data/com.rovio.angrybirds/files/.flurryagent.16b6d8c5 (Read-only file system)
E/FlurryAgent( 2043): at org.apache.harmony.luni.platform.OSFileSystem.open(Native Method)
E/FlurryAgent( 2043): at dalvik.system.BlockGuard$WrappedFileSystem.open(BlockGuard.java:232)
E/FlurryAgent( 2043): at java.io.FileOutputStream.<init>(FileOutputStream.java:94)
E/FlurryAgent( 2043): at java.io.FileOutputStream.<init>(FileOutputStream.java:66)
E/FlurryAgent( 2043): at com.flurry.android.FlurryAgent.g(SourceFile:985)
E/FlurryAgent( 2043): at com.flurry.android.FlurryAgent.b(SourceFile:459)
E/FlurryAgent( 2043): at com.flurry.android.FlurryAgent.onEndSession(SourceFile:186)
E/FlurryAgent( 2043): at com.rovio.ka3d.MyRenderer.nativePause(Native Method)
E/FlurryAgent( 2043): at com.rovio.ka3d.MyRenderer.onPause(MyRenderer.java:119)
E/FlurryAgent( 2043): at com.rovio.ka3d.GLSurfaceView$GLThread.guardedRun(GLSurfaceView.java:1187)
E/FlurryAgent( 2043): at com.rovio.ka3d.GLSurfaceView$GLThread.run(GLSurfaceView.java:1121)
I/ActivityManager( 1521): Process com.rovio.angrybirds (pid 2043) has died.
I/WindowManager( 1521): WIN DEATH: Window{40920230 SurfaceView paused=false}
I/WindowManager( 1521): WIN DEATH: Window{4091f1c8 com.rovio.angrybirds/com.rovio.ka3d.App paused=true}
D/Zygote ( 1468): Process 2043 terminated by signal (11)
W/InputManagerService( 1521): Got RemoteException sending setActive(false) notification to pid 2043 uid 10028
-------Logs-------------------

Refer to attachments for screenshot.
Apk file attached. installed apk file using "adb install abirds.apk" from host machine

Reproducible:
===========
Yes, 5/5

IMPACT:
========
Unable to play popular android game. Not a good user experience.

Steps:
==========
Precondition:
1. Copy the attached abirds.apk file on host machine.
2. Install apk file, from host machine using "adb install abirds.apk" command.
3. Open installed app
Issue: Display does not show proper start screen for the app.
It only shows a portion of expected screen, no options present to select "Play" key

Expected Behavior: Should be able to start/play this game.

Hardware:
==========
Snowball: V5
SD card: 16 GB class 10
USB - mini B cable connected to OTG port
Ethernet cable connected.
HDMI-HDMI connection to Acer Monitor.
USB serial logging.

Software:
==========
https://android-build.linaro.org/builds/~linaro-android/staging-snowball-11.10-release/
build 1

Logs:
======
1.Logcat,dmesg attached.
2. apk file
3. screenshots attached.

vishal (vishalbhoj) wrote :

I have seen this before.Its because of software openGL in android.It behaves the same on emulator also.

Anmar Oueja (anmar) on 2011-10-12
Changed in linaro-landing-team-ste:
importance: Undecided → Wishlist
Zach Pfeffer (pfefferz) wrote :

Was this Angry Birds or Angry Birds Rio

Its Angry Birds (Not rio)

Lee Jones (lag) on 2011-10-17
Changed in linaro-landing-team-ste:
assignee: nobody → Mathieu Poirier (mathieu.poirier)

Able to play Rio but not Angry birds with this build:
https://android-build.linaro.org/builds/~linaro-android/staging-snowball-11.10-release/#build=7

Angry birds Rio attached.

Frans Gifford (fgiff) on 2011-10-27
tags: added: linaro-android
Frans Gifford (fgiff) on 2011-10-27
tags: added: snowball-landing snowball-staging
tags: removed: snowball-landing
Zach Pfeffer (pfefferz) wrote :

This doesn't seem to be a per target issue. Changing the headline.

summary: - Snowball: Unable to play Angrybirds game, App opens but does not show
+ Unable to play Angrybirds game on ICS, App opens but does not show
proper game menu.
Benjamin Zores (gxben) wrote :

Had the same behaviour on Panda with Google release.
Forcing ro.opengles.version system property to 131072 makes it work.

Patrik Ryd (patrik-ryd) wrote :
Changed in linaro-landing-team-arm:
importance: Undecided → Wishlist
status: New → Triaged
Anmar Oueja (anmar) on 2012-01-05
Changed in igloocommunity:
importance: Undecided → Wishlist
Zach Pfeffer (pfefferz) wrote :
Changed in linaro-android:
importance: Medium → High
assignee: nobody → vishal (vishalbhoj)
milestone: none → 12.02
vishal (vishalbhoj) on 2012-02-20
Changed in linaro-android:
status: New → Fix Committed
Tony Mansson (tony-mansson) wrote :

Fix confirmed in https://android-build.linaro.org/builds/~linaro-android/snowball-ics-gcc46-igloo-stable-blob-12.02-release/#build=1

Angry Birds Rio plays well in this build. Regrettably without sound but that's another bug.

Thomas Espersson (espersson) wrote :

updated status for Igloo community project, tested on by Tony Mansson.

Changed in igloocommunity:
milestone: none → 2012.02
status: New → Fix Committed
assignee: nobody → Tony Mansson (tony-mansson)
Zach Pfeffer (pfefferz) on 2012-02-22
Changed in linaro-android:
status: Fix Committed → Fix Released
Changed in igloocommunity:
status: Fix Committed → Fix Released
Anmar Oueja (anmar) on 2012-11-08
Changed in linaro-landing-team-arm:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers