Snowball: Turning ON WiFi gives "Error" message. Unable to use WLAN feature.

Reported by Abhishek Paliwal on 2011-09-27
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
IglooCommunity
Medium
Mathieu Poirier
Linaro Android
High
Amit Pundir
Linaro Ubuntu
Undecided
Unassigned

Bug Description

Description:
==========
Turn ON WiFi (from Settings->Wireless and Networks->WiFi)
WiFi turn ON Fails always - UI reports "Error" message

Serial Logs snippet:
#"E/WifiService( 1518): Failed to load Wi-Fi driver."

Reproducible:
===========
Yes (5/5 times)

Serial Logs:
=========
D/AndroidRuntime( 2063):
D/AndroidRuntime( 2063): >>>>>> AndroidRuntime START com.android.internal.os.RuntimeInit <<<<<<
D/AndroidRuntime( 2063): CheckJNI is ON
D/dalvikvm( 2063): creating instr width table
I/ethernet( 2063): Loading ethernet jni class
D/AndroidRuntime( 2063): Calling main entry com.android.commands.input.Input
I/SendKeyEvent( 2063): 23
--------- beginning of /dev/log/system
E/WifiService( 1518): Failed to load Wi-Fi driver.
D/AndroidRuntime( 2063): Shutting down VM
I/AndroidRuntime( 2063): NOTE: attach of thread 'Binder Thread #3' failed
D/dalvikvm( 2063): GC_CONCURRENT freed 98K, 72% free 289K/1024K, external 0K/0K, paused 0ms+0ms
D/jdwp ( 2063): adbd disconnected
#

Steps:
==========
1. Bootup DUT
2. Set Settings->Wireless and Networks->WiFi , Turn ON WiFi
Observation: UI shows "Error" message
Expected: WiFi should turn ON

Hardware:
==========
Snowball: V5
HDMI Out to TV - via HDMI cable
USB-Serial Logging

Software:
==========
https://android-build.linaro.org/builds/~linaro-android/staging-snowball-11.09-release/
build 1

Fathi Boudra (fboudra) on 2011-09-27
tags: removed: 11.09 android-linaro wifi wlan
affects: linaro → linaro-android
Changed in linaro-android:
importance: Undecided → Medium
Zach Pfeffer (pfefferz) on 2011-10-03
Changed in linaro-android:
assignee: nobody → Mathieu Poirier (mathieu.poirier)

Wifi has not been connected to userspace on the snowball. Wifi has not been tested yet on the july-ALK3.0 and On V3 boards, this is not possible because of a HW problem.

Changed in linaro-landing-team-ste:
status: New → Confirmed

Setting target for 11.11 since V5 boards should arrive soon.

Changed in linaro-android:
milestone: none → 11.10
milestone: 11.10 → 11.11

Same issue is observed with iMX53 Hardware(Rev G) with build:
https://android-build.linaro.org/builds/~linaro-android/stage-imx53-11.10-release/

Logcat message says: Wifi driver loading failed.
------------Logs----------------
I/ActivityManager( 70): Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.settings/.Settings } from pid 159
D/dalvikvm( 594): GC_CONCURRENT freed 117K, 47% free 3149K/5831K, external 1565K/2010K, paused 3ms+4ms
I/ActivityManager( 70): Displayed com.android.settings/.Settings: +1s393ms
I/ActivityManager( 70): Starting: Intent { act=android.intent.action.MAIN cmp=com.android.settings/.WirelessSettings } from pid 594
V/NFC ( 594): this device does not have NFC support
I/ActivityManager( 70): Displayed com.android.settings/.WirelessSettings: +725ms
D/dhcpcd ( 110): sending DHCP_DISCOVER with xid 0xd3c514bb, next in 15.86 seconds
#
# E/WifiService( 70): Failed to load Wi-Fi driver.
------------Logs----------------

summary: - Snowball: Turning ON WiFi gives "Error" message. Unable to use WLAN
- feature.
+ iMX53/Snowball: Turning ON WiFi gives "Error" message. Unable to use
+ WLAN feature.
Fathi Boudra (fboudra) on 2011-10-11
tags: added: imx53

iMX53 doesn't have wlan hardware, so this is expected - unless you're using a USB wlan stick or something (which we AFAIK don't support for now)

Lee Jones (lag) on 2011-10-17
Changed in linaro-landing-team-ste:
importance: Undecided → Medium
assignee: nobody → Mathieu Poirier (mathieu.poirier)
Changed in linaro-android:
status: New → Confirmed
Anmar Oueja (anmar) on 2011-10-17
Changed in linaro-android:
assignee: Mathieu Poirier (mathieu.poirier) → Abhishek Paliwal (abhishek-paliwal)
Fathi Boudra (fboudra) wrote :

Set the bug to invalid for FSL LT as i.MX53 doesn't have wlan.
@Abhishek: QA test should be set to N/A for the boards that doesn't have the hardware out of the box.

Changed in linaro-android:
assignee: Abhishek Paliwal (abhishek-paliwal) → Mathieu Poirier (mathieu.poirier)
Changed in linaro-landing-team-freescale:
status: New → Invalid
tags: added: linaro-ubuntu lt-snowball wifi
Frans Gifford (fgiff) on 2011-10-27
tags: added: linaro-android
Frans Gifford (fgiff) on 2011-10-27
tags: added: quickstart-staging
tags: added: snowball-landing snowball-staging
summary: - iMX53/Snowball: Turning ON WiFi gives "Error" message. Unable to use
- WLAN feature.
+ Snowball: Turning ON WiFi gives "Error" message. Unable to use WLAN
+ feature.
Anmar Oueja (anmar) on 2011-11-23
Changed in linaro-landing-team-ste:
milestone: none → 2011.12

"WiFI settings" UI option is not available under Settings->Wireless and networks in ICS release:
https://android-build.linaro.org/builds/~linaro-android/staging-snowball-11.12-release/#build=1

Zach Pfeffer (pfefferz) on 2011-11-25
Changed in linaro-android:
milestone: 11.11 → 11.12

WiFI still not working on Snowball ICS releases, tested on:
https://android-build.linaro.org/builds/~linaro-android/staging-snowball/#build=90

Zach Pfeffer (pfefferz) on 2011-12-16
Changed in linaro-android:
assignee: Mathieu Poirier (mathieu.poirier) → Amit Pundir (pundiramit)
Patrik Ryd (patrik-ryd) wrote :
Zach Pfeffer (pfefferz) on 2011-12-19
Changed in linaro-android:
milestone: 11.12 → 12.01
Riku Voipio (riku-voipio) wrote :

Wifi sees my networks but with poor signal quality, and is unable to associate. perhaps an antenna is needed?

On 20 December 2011 12:00, Riku Voipio <email address hidden> wrote:
> Wifi sees my networks but with poor signal quality, and is unable to
> associate. perhaps an antenna is needed?

Chances are it is the antenna. You are talking about Ubuntu.. not
Android ... right?

anmar

Amit Pundir (pundiramit) wrote :

Linaro Android tree (stable-android-ux500-3.0-mali-v9) is not in sync with igloo's tree (stable-ubuntu-ux500-3.0). Some critical patches, which detect wlan/bt chip revision and do platform initialization are missing.

This is interesting Amit. The androidization process was hard on the BT code and I wouldn't be surprised that some got munged in the process. I you find missing patches apply them - otherwise I'll look into it upon my return.

Amit Pundir (pundiramit) wrote :

I have got WiFi working from command line on ICS using wireless-tools but I don't have a mini-A USB adapter so can't test/fix it from UI.

Changed in linaro-android:
status: Confirmed → In Progress
Amit Pundir (pundiramit) wrote :

Now got WiFi working on ICS from command line through wpa_supplicant.

It is a bit tricky. Android makes use of SIOCSIWPRIV private ioctls which are not implemented by cw1200 driver. So, I'm not using wpa_supplicant_8 that got shipped with ICS.

There is a workaround available for wpa_supplicant_6 shipped with Gingerbread which implements these private ioctls locally https://gitorious.org/picopc-android-gingerbread/external-wpa_supplicant_6/commit/5f5c50d722eedaedd75c1698b79f464310ce6478?format=patch. I tested that and it works fine for us. For the time being we can stick to this until we patch wpa_supplicant_8 with private ioctl support.

Amit Pundir (pundiramit) wrote :

Got WiFi working on ICS from GUI.

It is not a release material yet. Still got some major issues:
1. hciattach which fails to power up BT/WLAN chip like 3/5 times.
2. Wireless settings Activity/Window is missing. It doesn't come up. logcat shows some gles(mali) failures while rendering Settings window.
3. Frequent connection drops. Which could probably be because of Station Antenna or AP issues.

Anmar Oueja (anmar) wrote :

igloocommunity-maintainers team: Anybody can help Amit P. fix up his issues in comment #23?

Changed in igloocommunity:
milestone: none → 2012.01
Anmar Oueja (anmar) on 2012-01-05
Changed in igloocommunity:
status: New → Confirmed
importance: Undecided → Medium
no longer affects: linaro-landing-team-ste
Zach Pfeffer (pfefferz) on 2012-01-06
Changed in linaro-android:
importance: Medium → High
Amit Pundir (pundiramit) on 2012-01-13
Changed in linaro-android:
status: In Progress → Fix Committed
Amit Pundir (pundiramit) wrote :

http://review.android.git.linaro.org/#change,1378

wlan/bt drivers fail to power-up the chip sometimes(1/5 times roughly), so we can't enable wlan in that case. We can take that up in the form of another bug.

Also I see frequent re-connections happening at my end (because of poor connection status in ICS, though router is just next to the board) but that may also happening because I don't have antenna attached to snowball as Mathieu pointed out to me once.

Amit Pundir (pundiramit) on 2012-01-16
Changed in linaro-android:
status: Fix Committed → Fix Released
Amit Pundir (pundiramit) on 2012-01-17
Changed in linaro-android:
status: Fix Released → In Progress
Changed in linaro-android:
milestone: 12.01 → 12.02
Amit Pundir (pundiramit) wrote :

Marking this bug closed/fixed, since we integrated wlan in landing-snowball which solves this particular bug.

There is one major bug left in wlan bringup on ICS but that I'm going to take up separately here https://bugs.launchpad.net/linaro-android/+bug/918643

Changed in linaro-android:
status: In Progress → Fix Released
milestone: 12.02 → 12.01
Anmar Oueja (anmar) wrote :

Mathieu: Please test in the 2012.01 rc build and update the bug accordingly.

Changed in igloocommunity:
assignee: nobody → Mathieu Poirier (mathieu.poirier)
Changed in igloocommunity:
status: Confirmed → Fix Released
Paul Larson (pwlars) wrote :

I don't think this is really valid in ubuntu, or at least not any more? I have wireless enabled by default with snowball on ubuntu, though there are other issues with it, it can be made to work. please reopen if there's something I'm missing here

Changed in linaro-ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers