Colors look inverted on the LCD in build 2 of stage-origen-11.09-release

Bug #845793 reported by Zach Pfeffer on 2011-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
Botao Sun
linaro-landing-team-samsung
Fix Released
Medium
Angus Ainslie
Zach Pfeffer (pfefferz) on 2011-09-09
Changed in linaro-android:
assignee: nobody → Botao Sun (botao-sun)
importance: Undecided → Medium
Botao Sun (botao-sun) wrote :

What do you mean "inverted"? I take a screen shot of 11.09 build 2, refer to attachment.

It looks kind of like a BGR RGB encoding problem

On Fri, Sep 9, 2011 at 8:33 PM, Botao Sun <email address hidden> wrote:
> What do you mean "inverted"? I take a screen shot of 11.09 build 2,
> refer to attachment.
>
> ** Attachment added: "11.09 build 2 screen shot"
>   https://bugs.launchpad.net/linaro-android/+bug/845793/+attachment/2379931/+files/11.09_Build_2_Screen_Shot.jpg
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: Samsung, which is subscribed to linaro-landing-team-
> samsung.
> https://bugs.launchpad.net/bugs/845793
>
> Title:
>  Colors look inverted on the LCD in build 2 of stage-
>  origen-11.09-release
>
> Status in Linaro Android:
>  New
> Status in Linaro Samsung Landing Team Project:
>  New
>
> Bug description:
>  In
>
>  https://android-build.linaro.org/builds/~linaro-android/stage-
>  origen-11.09-release/#build=2
>
>  The colors come up inverted.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/845793/+subscriptions
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Zach Pfeffer (pfefferz) wrote :

Here's a shot of the correct colors.

Angus Ainslie (angus-akkea) wrote :

Thanks Zach

@Botao can you do a test with pure red, green and blue colours and see
if they are just mapped wrong ?

On Mon, Sep 12, 2011 at 9:48 AM, Zach Pfeffer <email address hidden> wrote:
> Here's a shot of the correct colors.
>
> ** Attachment added: "Panda_Showing_Correct_Colors.jpg"
>   https://bugs.launchpad.net/linaro-android/+bug/845793/+attachment/2391853/+files/Panda_Showing_Correct_Colors.jpg
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: Samsung, which is subscribed to linaro-landing-team-
> samsung.
> https://bugs.launchpad.net/bugs/845793
>
> Title:
>  Colors look inverted on the LCD in build 2 of stage-
>  origen-11.09-release
>
> Status in Linaro Android:
>  New
> Status in Linaro Samsung Landing Team Project:
>  New
>
> Bug description:
>  In
>
>  https://android-build.linaro.org/builds/~linaro-android/stage-
>  origen-11.09-release/#build=2
>
>  The colors come up inverted.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/845793/+subscriptions
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Botao Sun (botao-sun) wrote :

The blue and red are inverted, refer to attachment.

Changed in linaro-android:
status: New → Confirmed
milestone: none → 11.09
Botao Sun (botao-sun) wrote :

Vishal and I are working on this and we think we have a patch now:

In file hardware/libhardware/modules/gralloc/framebuffer.cpp, do the change as following:

@@ -355,7 +358,7 @@ int fb_device_open(hw_module_t const* module, const char* name,
         if (status >= 0) {
             int stride = m->finfo.line_length / (m->info.bits_per_pixel >> 3);
             int format = (m->info.bits_per_pixel == 32)
- ? HAL_PIXEL_FORMAT_RGBX_8888
+ ? HAL_PIXEL_FORMAT_BGRA_8888
                          : HAL_PIXEL_FORMAT_RGB_565;

I have tested it and the color has backed to normal.

This issue also exist in the Panda build as Vishal mentioned.

Attachment is that library file we generated, you can copy it to /system/lib/hw path of Origen build to make a test.

Also, Vishal found this bug: https://bugs.launchpad.net/linaro-android/+bug/803634

Botao Sun (botao-sun) on 2011-09-15
Changed in linaro-android:
status: Confirmed → Fix Committed
Usman Ahmad (usman-ah) on 2011-09-16
Changed in linaro-landing-team-samsung:
assignee: nobody → Angus Ainslie (angus-akkea)
importance: Undecided → Medium
milestone: none → 2011.09
Changed in linaro-landing-team-samsung:
status: New → Fix Committed
Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers