Toolchain build ...4.6-2011.07-0-8-2011-07-25_12-42-06-linux-x86.tar.bz2 is gone

Reported by Zach Pfeffer on 2011-08-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Critical
Bernhard Rosenkraenzer

Bug Description

The official toolchain build got removed automatically.

Original email thread:

On Fri, 5 Aug 2011 17:12:50 +0200
Alexander Sack <email address hidden> wrote:

> On Fri, Aug 5, 2011 at 4:13 PM, Paul Sokolovsky
> <email address hidden> wrote:
> > On Fri, 5 Aug 2011 15:54:22 +0200
> > Alexander Sack <email address hidden> wrote:
> >
> >> ok. seems it really happened.
> >>
> >> https://android-build.linaro.org/jenkins/job/linaro-android_toolchain-4.6-2011.07/8/artifact/build/out/android-toolchain-eabi-linaro-4.6-2011.07-0-8-2011-07-25_12-42-06-linux-x86.tar.bz2
> >>
> >> doesnt exist anymore even though its used as our official download
> >> url for release.
> >>
> >> Please figure out what changes landed after that official build,
> >> revert everything to the release state, respin, and ask paul to put
> >> the original binary manually back in place so the above URL becomes
> >> valid again?
> >
> > Well, it's built from the release tarball and the same patch, both
> > stay the same, so end result of the rebuild is the same, just at
> > different URL (build #12). I've updated daily jobs to use that, and
> > personal jobs should be updated by developers as needed.
>
> I dont think that build is the same. bero added changes somewhere etc.
> otherwise i doubt he would have respun the built. Please check with
> him.

I see, that's indeed the case. So we apparently need to branch/tag
release builds for toolchain just the same as for the platform. In the
meantime, we with Bernhard are working on resolving this and bringing
original 11.07 build back up.

Zach Pfeffer (pfefferz) wrote :

Once you guys get the original build going again and test it I'll cut a gcc release branch.

Changed in linaro-android:
assignee: nobody → Bernhard Rosenkraenzer (berolinux)
status: New → Confirmed
importance: Undecided → Critical
milestone: none → 11.08
Zach Pfeffer (pfefferz) wrote :

We really need Git so we can just rebuild the commits associated with the last released build.

Changed in linaro-android:
status: Confirmed → Fix Committed
Alexander Sack (asac) wrote :

paul resurrected the build using the announced url. Final step for completing this bug is to validate it with our 11.07 release build by building a build and checking that it boots still.

Zach Pfeffer (pfefferz) on 2011-08-25
Changed in linaro-android:
status: Fix Committed → Fix Released
Paul Sokolovsky (pfalcon) wrote :

Booted above image, no HDMI monitor here, but serial bootlog and console seems to be ok.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers