Pandroid build just sits in fastboot

Bug #811657 reported by Zach Pfeffer on 2011-07-16
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
Patrik Ryd

Bug Description

When https://android-build.linaro.org/builds/~patrik-ryd/pandroid/#build=41 boots up it just sits and waits here:

Texas Instruments X-Loader 1.41 (May 9 2011 - 19:41:49)
mmc read: Invalid size
Starting OS Bootloader from MMC/SD1 ...

U-Boot 1.1.4-L27.13.1^0-dirty (May 9 2011 - 19:42:26)

Load address: 0x80e80000
DRAM: 1024 MB
Flash: 0 kB
Using default environment

In: serial
Out: serial
Err: serial

efi partition table:
efi partition table not found
Net: KS8851SNL
Hit any key to stop autoboot: 0
booti: cannot find 'boot' partition
Device Serial Number: 5E7C000300000000
Fastboot entered...

Zach Pfeffer (pfefferz) on 2011-07-16
Changed in linaro-android:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Patrik Ryd (patrik-ryd)
milestone: none → 11.07
Alexander Sack (asac) wrote :

whats going on with this one? any chance that this gets resolved in time?

There is nothing wrong with this bootup. You simple need to rebuild u-boot with proper bootargs instead of using fastboot. Simply change out BOOTARG from omap4430panda.h.

BTW: Mainline needs to add support for fastboot in later releases.

~orbarron

________________________________________
From: <email address hidden> [<email address hidden>] on behalf of Alexander Sack [<email address hidden>]
Sent: Sunday, July 24, 2011 5:45 PM
To: Barron, Omar
Subject: [Bug 811657] Re: Pandroid build just sits in fastboot

whats going on with this one? any chance that this gets resolved in
time?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/811657

Title:
  Pandroid build just sits in fastboot

Status in Linaro Android:
  Confirmed

Bug description:
  When https://android-build.linaro.org/builds/~patrik-
  ryd/pandroid/#build=41 boots up it just sits and waits here:

  Texas Instruments X-Loader 1.41 (May 9 2011 - 19:41:49)
  mmc read: Invalid size
  Starting OS Bootloader from MMC/SD1 ...

  U-Boot 1.1.4-L27.13.1^0-dirty (May 9 2011 - 19:42:26)

  Load address: 0x80e80000
  DRAM: 1024 MB
  Flash: 0 kB
  Using default environment

  In: serial
  Out: serial
  Err: serial

  efi partition table:
  efi partition table not found
  Net: KS8851SNL
  Hit any key to stop autoboot: 0
  booti: cannot find 'boot' partition
  Device Serial Number: 5E7C000300000000
  Fastboot entered...

To manage notifications about this bug go to:
https://bugs.launchpad.net/linaro-android/+bug/811657/+subscriptions

Zach Pfeffer (pfefferz) wrote :

I've talked to John Rigby about this one. Patrik's gone, I have a solution though. Our first LEB was based on the Pandroid kernel, so it would probably be a good reference point. We can always recreate the build using the original Pandroid instructions too.

Zach Pfeffer (pfefferz) wrote :

Omar, if you don't mind me asking, when you say "Simply change out BOOTARG from omap4430panda.h." change it out for what?

omar barron (orbarron) wrote :

ok let me give you some background...

Pandroid can boot two different ways.

1. Fastboot ~7 partition setup -- not usually tested or used for panda at this time but is known to work
2. SD boot with 2-3 partitions -- current setup

In the latest releases we are still using 2-3 partitions on SD card. So we do not use fastboot at this time. However the bootloader we use is using fastboot on startup. In order to bypass this you can either increase your BOOTDELAY and hit enter during start up and paste your bootargs or you can rebuild the booloader with proper BOOTARGS and CONFIG_BOOTCOMMAND, bypassing fastboot.

In our case we use the following bootags/bootcmd for panda on GB release:
setenv bootargs 'console=ttyO2,115200n8 androidboot.console=ttyO2 mem=456M@0x80000000 mem=512M@0xA0000000 root=/dev/mmcblk0p2 rw rootdelay=2 init=/init vram="32M" omapfb.vram=0:16M omapdss.def_disp=hdmi consoleblank=0'
setenv bootcmd 'mmcinit 0;fatload mmc 0 0x80000000 uImage; bootm 0x80000000'

here is an example of what needs to be done (thanks to Dave Anders):

#if defined(CONFIG_FASTBOOT)
#define CONFIG_BOOTARGS "console=ttyO2,115200n8 mem=512M" \
        " init=/init vram=32M omapfb.vram=0:16M androidboot.console=ttyO2"
#define CONFIG_BOOTCOMMAND "booti mmc0"
#else
#define CONFIG_BOOTARGS "console=ttyO2,115200n8 androidboot.console=ttyO2 mem=456M@0x80000000 \
mem=512M@0xA0000000 root=/dev/mmcblk0p2 rw rootdelay=2 init=/init vram="32M" \
omapfb.vram=0:16M omapdss.def_disp=hdmi consoleblank=0'
#define CONFIG_BOOTCOMMAND "fatload mmc 0 0x80000000 uImage; bootm 0x80000000"
#endif

Links:
http://www.omappedia.org/wiki/Android_eMMC_Booting
http://android-dls.com/wiki/index.php?title=Fastboot
http://www.omappedia.org/wiki/PandaBoard_L27.12.1-P2_Release_Notes#Building_u-boot

hope this helps...

~orbarron

________________________________________
From: <email address hidden> [<email address hidden>] on behalf of Zach Pfeffer [<email address hidden>]
Sent: Sunday, July 24, 2011 11:47 PM
To: Barron, Omar
Subject: [Bug 811657] Re: Pandroid build just sits in fastboot

Omar, if you don't mind me asking, when you say "Simply change out
BOOTARG from omap4430panda.h." change it out for what?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/811657

Title:
  Pandroid build just sits in fastboot

Status in Linaro Android:
  Confirmed

Bug description:
  When https://android-build.linaro.org/builds/~patrik-
  ryd/pandroid/#build=41 boots up it just sits and waits here:

  Texas Instruments X-Loader 1.41 (May 9 2011 - 19:41:49)
  mmc read: Invalid size
  Starting OS Bootloader from MMC/SD1 ...

  U-Boot 1.1.4-L27.13.1^0-dirty (May 9 2011 - 19:42:26)

  Load address: 0x80e80000
  DRAM: 1024 MB
  Flash: 0 kB
  Using default environment

  In: serial
  Out: serial
  Err: serial

  efi partition table:
  efi partition table not found
  Net: KS8851SNL
  Hit any key to stop autoboot: 0
  booti: cannot find 'boot' partition
  Device Serial Number: 5E7C000300000000
  Fastboot entered...

To manage notifications about this bug go to:
https://bugs.launchpad.net/linaro-android/+bug/811657/+subscriptions

Alexander Sack (asac) wrote :

this isnt critical or high because we dont release pandroid as artifact. setting to medium and move milestone because this doesnt get on release notes.

Changed in linaro-android:
importance: Critical → Medium
milestone: 11.07 → 11.08
Zach Pfeffer (pfefferz) wrote :

Cool, thanks Omar. That's perfect. I had forgotten the bootargs step.

Patrik Ryd (patrik-ryd) wrote :

First lines from from boot from a local build. Different version of u-boot!!!

Texas Instruments X-Loader 1.41 (May 9 2011 - 19:41:49)
mmc read: Invalid size
Starting OS Bootloader from MMC/SD1 ...

U-Boot 1.1.4-gb3419477 (Jul 28 2011 - 16:39:13)

Load address: 0x80e80000
DRAM: 1024 MB
Flash: 0 kB
Using default environment

In: serial
Out: serial
Err: serial
Net: KS8851SNL
Hit any key to stop autoboot: 0
mmc read: Invalid size

3341896 bytes read
mmc read: Invalid size

169584 bytes read
## Booting image at 80200000 ...
   Image Name: Linux-2.6.35.7-03707-gb238e8e
   Image Type: ARM Linux Kernel Image (uncompressed)
   Data Size: 3341832 Bytes = 3.2 MB
   Load Address: 80008000
   Entry Point: 80008000
   Verifying Checksum ... OK
OK
## Loading Ramdisk Image at 81600000 ...
   Image Name: Android Ramdisk Image
   Image Type: ARM Linux RAMDisk Image (gzip compressed)
   Data Size: 169520 Bytes = 165.5 kB
   Load Address: 00000000
   Entry Point: 00000000
   Verifying Checksum ... OK
I2C read: I/O error
Blaze/SDP Board.

Starting kernel ...

Uncompressing Linux...

Patrik Ryd (patrik-ryd) wrote :

local build has git://git.linaro.org/android/boot/u-boot-pandroid.git as remote (is on the dev_pandroid branch) and has the commit b341947762c964d58e785c8cd6e4dea407e78f55 as the last commit.

The server build has the following line in the pinned manifest
<project name="android/boot/u-boot-pandroid" path="u-boot" remote="linaro" revision="b341947762c964d58e785c8cd6e4dea407e78f55"/>

Patrik Ryd (patrik-ryd) wrote :

I will probably need some help from pfalcon on this one to figure out why the u-boot in the boot tarball does not match the version in the pinned manifest.

Fathi Boudra (fboudra) on 2011-08-31
Changed in linaro-android:
milestone: 11.08 → 11.09
Patrik Ryd (patrik-ryd) wrote :

Both the server builds and the local build uses commit b341947762c964d58e785c8cd6e4dea407e78f55 in the u-boot git.

The server build log starts with:
U-Boot 1.1.4-L27.13.1^0-dirty (May 9 2011 - 19:42:26)

The local build log starts with:
U-Boot 1.1.4-gb3419477 (Jul 29 2011 - 14:31:56)

Even though the two builds use the same version of u-boot (according to git and pinned manifest), the boot tar ball contains different version.

Patrik Ryd (patrik-ryd) wrote :

Will replace MLO and u-boot with the one from the panda LEB and see if the problem goes away.

Patrik Ryd (patrik-ryd) wrote :

Found a difference between the local and server build. The local build had removed the binary u-boot.bin from device/ti/pandaboard/boot. :) Will try to push that change first.

Patrik Ryd (patrik-ryd) wrote :
Changed in linaro-android:
status: Confirmed → Fix Committed
Zach Pfeffer (pfefferz) wrote :

Did this change go through Gerrit?

Patrik Ryd (patrik-ryd) wrote :

yes, but I was the only reviewer. :)

There were a lot of other small patches to move the pandroid build to the
new gits and some patches that I later reverted that I pushed up through
gerrit and reviewed and approved myself when I was debugging the server
build.

On 20 September 2011 17:01, Zach Pfeffer <email address hidden> wrote:

> Did this change go through Gerrit?
>
> --
> You received this bug notification because you are a member of Linaro
> Android Team, which is subscribed to Linaro Android.
> Matching subscriptions: all-android-bugs
> https://bugs.launchpad.net/bugs/811657
>
> Title:
> Pandroid build just sits in fastboot
>
> Status in Linaro Android:
> Fix Committed
>
> Bug description:
> When https://android-build.linaro.org/builds/~patrik-
> ryd/pandroid/#build=41 boots up it just sits and waits here:
>
> Texas Instruments X-Loader 1.41 (May 9 2011 - 19:41:49)
> mmc read: Invalid size
> Starting OS Bootloader from MMC/SD1 ...
>
>
> U-Boot 1.1.4-L27.13.1^0-dirty (May 9 2011 - 19:42:26)
>
> Load address: 0x80e80000
> DRAM: 1024 MB
> Flash: 0 kB
> Using default environment
>
> In: serial
> Out: serial
> Err: serial
>
> efi partition table:
> efi partition table not found
> Net: KS8851SNL
> Hit any key to stop autoboot: 0
> booti: cannot find 'boot' partition
> Device Serial Number: 5E7C000300000000
> Fastboot entered...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/811657/+subscriptions
>

Zach Pfeffer (pfefferz) wrote :

Okay. Try to push everything through Gerrit if you can.

Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers