Contacts, Music and Phone Android apps crash on 11.06 Panda LEB RC

Bug #772528 reported by Patrik Ryd on 2011-04-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
Unassigned

Bug Description

The Music application can not be started on the build for the pandaboard

Patrik Ryd (patrik-ryd) on 2011-04-28
tags: added: linaro-android-11.04-release
Paul Sokolovsky (pfalcon) wrote :

Specifically, it's being force-closed with exception of some resource ID not being found.

Changed in linaro-android:
status: New → Confirmed
tags: added: linaro-android-11.06
Jim Huang (jserv) wrote :

We fixed the problem in 0xdroid. It is feasible to pick the fixes back to Linaro.

Changed in linaro-android:
assignee: nobody → Jim Huang (jserv)
Patrik Ryd (patrik-ryd) wrote :

The best solution is if 0xlab can hand over copyright to linaro and we can see it as any other linaro patch. Otherwise we can add it and modify the commit message to clearly state that it is not a linaro patch and it should not be contributed to AOSP.

I think we have one patch already from 0xlab (something about forced update on buffers) and we have a couple in the second category (mouse patch, ...)

Jim Huang (jserv) wrote :

Yes, the copyright owner of that fix will be transfered to Linaro.

Paul Sokolovsky (pfalcon) wrote :
Download full text (7.2 KiB)

Ok I updated bug heading and here's a list of apps which crash:

* Contacts
* Music
* Phone (seems due to Contacts)

Stack traces below:

E/AndroidRuntime( 1452): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.android.contacts/com.android.contacts.DialtactsActivity}: android.content.res.Resources$NotFoundException: Resource ID #0x7f03000e
E/AndroidRuntime( 1452): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1647)
E/AndroidRuntime( 1452): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1663)
E/AndroidRuntime( 1452): at android.app.ActivityThread.access$1500(ActivityThread.java:117)
E/AndroidRuntime( 1452): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:931)
E/AndroidRuntime( 1452): at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime( 1452): at android.os.Looper.loop(Looper.java:130)
E/AndroidRuntime( 1452): at android.app.ActivityThread.main(ActivityThread.java:3683)
E/AndroidRuntime( 1452): at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime( 1452): at java.lang.reflect.Method.invoke(Method.java:507)
E/AndroidRuntime( 1452): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
E/AndroidRuntime( 1452): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
E/AndroidRuntime( 1452): at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime( 1452): Caused by: android.content.res.Resources$NotFoundException: Resource ID #0x7f03000e
E/AndroidRuntime( 1452): at android.content.res.Resources.getValue(Resources.java:892)
E/AndroidRuntime( 1452): at android.content.res.Resources.loadXmlResourceParser(Resources.java:1869)
E/AndroidRuntime( 1452): at android.content.res.Resources.getLayout(Resources.java:731)
E/AndroidRuntime( 1452): at android.view.LayoutInflater.inflate(LayoutInflater.java:318)
E/AndroidRuntime( 1452): at android.view.LayoutInflater.inflate(LayoutInflater.java:276)
E/AndroidRuntime( 1452): at com.android.internal.policy.impl.PhoneWindow.setContentView(PhoneWindow.java:207)
E/AndroidRuntime( 1452): at android.app.Activity.setContentView(Activity.java:1657)
E/AndroidRuntime( 1452): at com.android.contacts.DialtactsActivity.onCreate(DialtactsActivity.java:69)
E/AndroidRuntime( 1452): at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1047)
E/AndroidRuntime( 1452): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1611)
E/AndroidRuntime( 1452): ... 11 more

E/AndroidRuntime( 1484): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.android.music/com.android.music.ArtistAlbumBrowserActivity}: android.content.res.Resources$NotFoundException: Resource ID #0x7f030009
E/AndroidRuntime( 1484): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1647)
E/AndroidRuntime( 1484): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1663)
E/AndroidRuntime( 1484): at android.app.ActivityThread.access$1500(ActivityThread.java:117)
E/AndroidRuntime( 1484): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:931)
E/AndroidRuntime( 1484)...

Read more...

Jim Huang (jserv) wrote :

Fixed in GIT (branch: linaro_android_2.3.4)

Changed in linaro-android:
status: Confirmed → Fix Released
summary: - Music player crashes on Panda
+ Few apps crash due to missing non-finger resources (upstream bug)
Alexander Sack (asac) wrote :

gents please get someone ack a patch before committing. especially when we are close to release and dont have gerrit.

paul, please provide more details what crashes etc. maybe paste a new log

jim, please give more info what you did to try to fix it. also discuss patches up front if possible.

Paul Sokolovsky (pfalcon) wrote :

Nothing changed, stack traces are the same.

Also, it's probably worth to set status to "Fix Committed" when fix is committed and wait for somebody test/validate it before setting as Fix Released. Cannot reopen this bug myself now.

Changed in linaro-android:
assignee: Jim Huang (jserv) → Paul Sokolovsky (pfalcon)
assignee: Paul Sokolovsky (pfalcon) → nobody
Alexander Sack (asac) wrote :

seems this is not understood yet. lets look at this again early in 11.07 cycle (early means: within 2 weeks).

Changed in linaro-android:
status: Fix Released → Confirmed
Alexander Sack (asac) wrote :

reopened bug as paul is still seeing it.

Paul Sokolovsky (pfalcon) wrote :

Sorry, assignments flips due to me trying to find way to reopen it. Cannot assign it back to Jim either.

Jim Huang (jserv) wrote :

Kernel should support uinput in order to make this patch functioned.

Zach Pfeffer (pfefferz) wrote :

I tested running

* Contacts
* Music
* Phone (seems due to Contacts)

with:

https://android-build.linaro.org/builds/~linaro-android/leb-panda-11.06-release/#build=3

and saw the crashes mentioned. Attaching the log cat.

Zach Pfeffer (pfefferz) wrote :
Changed in linaro-android:
importance: Undecided → Medium
summary: - Few apps crash due to missing non-finger resources (upstream bug)
+ Contacts, Music and Phone Android apps crash on 11.06 Panda LEB RC
Jim Huang (jserv) wrote :

Thanks for the log. The problem was as following:
--
[ 6.091674] init: cannot find '/system/bin/faketsd', disabling 'faketsd'
--

I just git push a fix ib linaro_android_2.3.4 branch to install 'faketsd' well.

Zach Pfeffer (pfefferz) wrote :

Thanks Jim. We should pick that up on the next build. Would you test the next build?

Jim Huang (jserv) wrote :

Can we enable CONFIG_INPUT_UINPUT=y in arch/arm/configs/android_omap[34]_defconfig in order to make faketsd work?

Fathi Boudra (fboudra) on 2011-10-05
tags: added: linaro-android
removed: linaro-android-11.04-release linaro-android-11.06
vishal (vishalbhoj) wrote :

This has been fixed on 11.09 release.

Changed in linaro-android:
status: Confirmed → Fix Released
Fathi Boudra (fboudra) on 2011-10-05
Changed in linaro-android:
milestone: none → 11.09
tags: added: panda
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers