The permission of init, adbd and shell scripts is not executable in root.tar.bz2

Bug #731780 reported by Jeremy Chang on 2011-03-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Critical
Patrik Ryd

Bug Description

After untar the dailybuild root.tar.bz2 , the executable permission of the init, adbd, and the files that should be executable is gone.

Jim Huang (jserv) on 2011-03-09
Changed in linaro-android:
assignee: nobody → Patrik Ryd (patrik-ryd)
Jamie Bennett (jamiebennett) wrote :

Permissions can be set manually so changing to Medium but this needs investigating further.

Alexander Sack (asac) wrote :

this is really a blocker. The images are broken as in they dont work!!

Setting permissions manually is same like saying a not booting ubuntu image is medium because you can fix it manually ;).

Changed in linaro-android:
importance: Undecided → Critical
milestone: none → linaro-11.04
status: New → Confirmed
Patrik Ryd (patrik-ryd) wrote :

The problem is the ${f} on line 32 in mktarball.sh "new_info=`${fs_get_stats} ${curr_perms} ${is_dir} ${f}`".

${f} contains the name for the directory. For init it is "root/init", but should only be 'init' and so on.

Patrik Ryd (patrik-ryd) wrote :

Sent patch for review to <email address hidden>.

Patrik Ryd (patrik-ryd) on 2011-03-14
Changed in linaro-android:
status: Confirmed → Fix Committed
Patrik Ryd (patrik-ryd) wrote :

Problem reported on a daily builds and solution has been built in a daily build so I consider this released.

Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers