boot failed on Linaro Android kitkat Samsung Arndale daily builds on Lava Dashboard- Android kitkat.

Bug #1266494 reported by Soumya Basak on 2014-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Dispatcher
Fix Released
High
Tyler Baker
Linaro Android
Fix Released
Undecided
Unassigned

Bug Description

observed on Lava Dashboard Linaro Android 4.4 Samsung Arndale builds:

https://validation.linaro.org/dashboard/image-reports/linaro-android_linux-linaro-arndale

with builds: https://android-build.linaro.org/jenkins/job/linaro-android_linux-linaro-arndale/306/
job_id: https://validation.linaro.org/scheduler/job/94085

error observed from the log file:
https://validation.linaro.org/scheduler/job/94085/log_file#L_17_1008

https://validation.linaro.org/scheduler/job/94085/log_file#L_18_0

ErrorMessage: Failed to boot test image.
 Lava failed at action boot_linaro_android_image with error:Failed to boot test image.

Traceback (most recent call last):
  File "/srv/lava/.cache/git-cache/exports/lava-dispatcher/2013-12-05-f957fd5/lava_dispatcher/job.py", line 270, in run
  action.run(**params)
  File "/srv/lava/.cache/git-cache/exports/lava-dispatcher/2013-12-05-f957fd5/lava_dispatcher/actions/boot_control.py", line 84, in run
  raise CriticalError("Failed to boot test image.")
 CriticalError: Failed to boot test image.

seems their is an adb issue with board nothing with builds.

The issue reproduced with Builds:

https://android-build.linaro.org/jenkins/job/linaro-android_linux-linaro-arndale/333/
https://validation.linaro.org/scheduler/job/98794
complete_log: https://validation.linaro.org/scheduler/job/98794/log_file

https://android-build.linaro.org/jenkins/job/linaro-android_linux-linaro-arndale/352/
result_bundles: https://validation.linaro.org/dashboard/streams/private/team/linaro/android-daily/bundles/476a44ef07437b49df0c6ee8a19e557d80bef990/5813fc5c-954d-11e3-8364-2c59e59a6295/

https://validation.linaro.org/dashboard/streams/private/team/linaro/android-daily/bundles/64823142cb0e66972fafe0b16e75f0ff16eb4689/

description: updated
Soumya Basak (soumya-basak) wrote :

error observed from the log file:

https://validation.linaro.org/scheduler/job/98794/log_file#L_17_724

 [ 5.760000] init: could not import file '/init.partitions.rc' from '/init.rc'
 4init (1): /proc/1/oom_adj is deprecated, please use /proc/1/oom_score_adj instead.
 [ 5.780000] init (1): /proc/1/oom_adj is deprecated, please use /proc/1/oom_score_adj instead.
 init: /dev/hw_random not found
 [ 5.930000] init: /dev/hw_random not found
 init: cannot open '/initlogo.rle'
 [ 5.940000] init: cannot open '/initlogo.rle'
 6EXT4-fs (mmcblk1p6): mounted filesystem with ordered data mode. Opts: (null)
 [ 5.990000] EXT4-fs (mmcblk1p6): mounted filesystem with ordered data mode. Opts: (null)
 3EXT4-fs (mmcblk1p7): VFS: Can't find ext4 filesystem
 [ 6.000000] EXT4-fs (mmcblk1p7): VFS: Can't find ext4 filesystem
 fs_mgr: Cannot mount filesystem on /dev/block/mmcblk1p7 at /data
 [ 6.020000] fs_mgr: Cannot mount filesystem on /dev/block/mmcblk1p7 at /data
 init: fs_mgr_mount_all returned an error
 [ 6.030000] init: fs_mgr_mount_all returned an error
 init: /dev/hw_random not found
 [ 6.030000] init: /dev/hw_random not found

vishal (vishalbhoj) on 2014-01-24
Changed in linaro-android:
assignee: nobody → Pranav Tipnis (pranav-tipnis)
Soumya Basak (soumya-basak) wrote :

boot test locally with the latest builds:

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=334

board works fine.

but the similar kind of issue reproduced from the log:

[ 5.910000] s5p-tv (hdmi_drv): unplugged
4init (1): /proc/1/oom_adj is deprecated, please use /proc/1/oom_score_adj instead.
/initlogo.rle[ 5.930000] init (1): /proc/1/oom_adj is deprecated, please use /proc/1/oom_score_adj instead.
init: /dev/hw_random not found
[ 6.080000] init: /dev/hw_random not found
init: cannot open '/initlogo.rle'
[ 6.090000] init: cannot open '/initlogo.rle'
6EXT4-fs (mmcblk1p3): mounted filesystem with ordered data mode. Opts: (null)
[ 6.160000] EXT4-fs (mmcblk1p3): mounted filesystem with ordered data mode. Opts: (null)
4EXT4-fs (mmcblk1p5): Ignoring removed nomblk_io_submit option
[ 6.190000] EXT4-fs (mmcblk1p5): Ignoring removed nomblk_io_submit option
6EXT4-fs (mmcblk1p5): mounted filesystem with ordered data mode. Opts: nomblk_io_submit,errors=panic
[ 6.340000] EXT4-fs (mmcblk1p5): mounted filesystem with ordered data mode. Opts: nomblk_io_submit,errors=panic
4EXT4-fs (mmcblk1p6): Ignoring removed nomblk_io_submit option
[ 6.360000] EXT4-fs (mmcblk1p6): Ignoring removed nomblk_io_submit option
6EXT4-fs (mmcblk1p6): mounted filesystem with ordered data mode. Opts: nomblk_io_submit,errors=panic
[ 6.400000] EXT4-fs (mmcblk1p6): mounted filesystem with ordered data mode. Opts: nomblk_io_submit,errors=panic
init: /dev/hw_random not found
[ 6.480000] init: /dev/hw_random not found

Please find the boot_log and logcat report.

Soumya Basak (soumya-basak) wrote :

boot test locally with the latest builds:

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=334

Boot test locally fine. manually validate test cases OK.

summary: - boot failed on Linaro Android 4.4 Samsung Arndale daily builds on Lava
- Dashboard
+ boot failed on Linaro Android kitkat Samsung Arndale daily builds on
+ Lava Dashboard
description: updated
summary: boot failed on Linaro Android kitkat Samsung Arndale daily builds on
- Lava Dashboard
+ Lava Dashboard- Android kitkat.
Soumya Basak (soumya-basak) wrote :

with Linaro Android Kitkat Arndale builds:

https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.02-release/#build=1

with job submission: https://validation.linaro.org/scheduler/job/114831

boot test failed with the builds.

the issue observed from log report:

09:13:56 AM ERROR: boot_linaro_android_image failed: Could not get the Android test image booted properly
09:13:56 AM INFO: CriticalError
09:13:56 AM WARNING: [ACTION-E] boot_linaro_android_image is finished with error (Failed to boot test image.).

Changed in linaro-android:
status: New → Confirmed
status: Confirmed → New
description: updated
vishal (vishalbhoj) wrote :

The failure is due to wrong bootargs being passed by LAVA while booting the kernel:
console=tty0 console=ttySAC2,115200n8 drm_kms_helper.edid_firmware=edid-1920x1080.fw root=UUID=cba9023b-4606-4489-9e22-d5caa4cb6414 rootwait ro mac=02:74:0c:d6:16:33

The actual bootargs should be:
console=tty0 console=ttySAC2,115200n8 androidboot.hardware=exynos5250-arndale rootwait ro rootdelay=3 init=/init androidboot.console=ttySAC2 fbdev=/dev/graphics/fb2 console=ttySAC2 root=/dev/mmcblk1p2 mac=02:74:ac:95:16:33

Someone from the LAVA team should address this issue.

affects: lava-server → lava-dispatcher
Tyler Baker (tyler-baker) wrote :

I have the board booting by overriding the boot commands:

https://validation.linaro.org/scheduler/job/119734/definition

Are the "root=/dev/mmcblk1p2 mac=02:74:ac:95:16:33" really needed? Please let me know and I will update the configuration on validation.linaro.org.

vishal (vishalbhoj) wrote :

Those can be ignored.

Tyler Baker (tyler-baker) wrote :
Changed in lava-dispatcher:
status: New → Fix Released
importance: Undecided → High
assignee: nobody → Tyler Baker (tyler-baker)
Fathi Boudra (fboudra) on 2014-04-10
Changed in linaro-android:
status: New → Fix Released
assignee: Pranav Tipnis (pranav-tipnis) → nobody
milestone: none → 14.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers