Samsung Arndale Android couldn't be woken up once entered suspend mode.

Bug #1185747 reported by Soumya Basak on 2013-05-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Android
Won't Fix
Low
Saumya Ranjan Kuanr
linaro-landing-team-samsung
New
Undecided
Unassigned

Bug Description

observed on Arndale builds with Linaro android 13.05 release builds

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale-13.05-release/

the system can boot to console, it can stay there for a few second and go to Suspend State.

log:

root@android:/ # 6PM: suspend entry 1970-01-01 00:00:43.735190353 UTC
[ 43.740000] PM: suspend entry 1970-01-01 00:00:43.735190353 UTC
6PM: Syncing filesystems ... [ 43.750000] PM: Syncing filesystems ... done.
done.
6mmc0: card 0001 removed
[ 43.810000] mmc0: card 0001 removed
6mmc1: card e624 removed
[ 43.820000] mmc1: card e624 removed
Freezing user space processes ... [ 43.870000] Freezing user space processes ... (elapsed 0.01 seconds) (elapsed 0.01 seconds) one.done.

Freezing remaining freezable tasks ... [ 43.900000] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) (elapsed 0.01 seconds) one.
done.

Suspending console(s) (use no_console_suspend to debug)
[ 43.930000] Suspending console(s) (use no_console_suspend to debug)

Serial console is dead, No power over usb port.

###########################################
This issue is observed on following images:
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale-13.06-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=163
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=170
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.08-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.09-release/#build=11
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=226
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.10-release/#build=4
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=277
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.12-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.01-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=356
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.02-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=386
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=415
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.04-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=447
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.05-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=473
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.06-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=502
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.07-release/#build=1

summary: - suspend resume test not working on Linaro android arndale builds
+ suspend-resume test not working on Linaro android arndale builds

One can run disablesuspend.sh after the board has booted up. That should block the board from going into suspend.

Changed in linaro-android:
status: New → Fix Released
vishal (vishalbhoj) on 2013-05-30
Changed in linaro-android:
status: Fix Released → Confirmed
vishal (vishalbhoj) on 2013-05-30
Changed in linaro-android:
assignee: nobody → Saumya Ranjan Kuanr (soumyakuanr)
vishal (vishalbhoj) on 2013-06-10
Changed in linaro-android:
importance: Undecided → Low
description: updated
Soumya Basak (soumya-basak) wrote :

the issue observed with the builds

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale-13.07-release/#build=2

after changed the display settings to 15 Seconds, the target is enter into suspend state,

the target doesn't wake-ups on Mouse click or Keyboard key pressed.

description: updated
description: updated
description: updated
Soumya Basak (soumya-basak) wrote :
Download full text (5.4 KiB)

on image

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=195

Kernel panic occour when the device enter into suspend state:

error from the log:

root@arndale:/ # 6PM: suspend entry 1970-01-01 00:42:55.897251393 UTC
[ 2575.890000] PM: suspend entry 1970-01-01 00:42:55.897251393 UTC
6PM: Syncing filesystems ... [ 2575.900000] PM: Syncing filesystems ... done.
done.
6mmc0: card 0001 removed
[ 2575.950000] mmc0: card 0001 removed
6mmc1: card e624 removed
[ 2575.970000] mmc1: card e624 removed
2EXT4-fs error (device mmcblk1p6): ext4_find_entry:1300: inode #238: comm Error dump: sys: reading directory lblock 0
[ 2576.100000] EXT4-fs error (device mmcblk1p6): ext4_find_entry:1300: inode #238: comm Error dump: sys: reading directory lblock 0
3Aborting journal on device mmcblk1p6-8.
[ 2576.110000] Aborting journal on device mmcblk1p6-8.
3Buffer I/O error on device mmcblk1p6, logical block 139265
[ 2576.120000] Buffer I/O error on device mmcblk1p6, logical block 139265
4lost page write due to I/O error on mmcblk1p6
[ 2576.130000] lost page write due to I/O error on mmcblk1p6
3JBD2: Error -5 detected when updating journal superblock for mmcblk1p6-8.
[ 2576.140000] JBD2: Error -5 detected when updating journal superblock for mmcblk1p6-8.
0Kernel panic - not syncing: EXT4-fs (device mmcblk1p6): panic forced after error

[ 2576.160000] Kernel panic - not syncing: EXT4-fs (device mmcblk1p6): panic forced after error
[ 2576.160000]
[<c00148fc>] (unwind_backtrace+0x0/0xf4) from [<c03c993c>] (panic+0xa4/0x1ec)
[ 2576.180000] [<c00148fc>] (unwind_backtrace+0x0/0xf4) from [<c03c993c>] (panic+0xa4/0x1ec)
[<c03c993c>] (panic+0xa4/0x1ec) from [<c01428a8>] (ext4_handle_error.part.45+0x60/0x98)
[ 2576.190000] [<c03c993c>] (panic+0xa4/0x1ec) from [<c01428a8>] (ext4_handle_error.part.45+0x60/0x98)
[<c01428a8>] (ext4_handle_error.part.45+0x60/0x98) from [<c0142adc>] (ext4_error_inode+0xc8/0x108)
[ 2576.210000] [<c01428a8>] (ext4_handle_error.part.45+0x60/0x98) from [<c0142adc>] (ext4_error_inode+0xc8/0x108)
[<c0142adc>] (ext4_error_inode+0xc8/0x108) from [<c013db94>] (ext4_find_entry+0x32c/0x5c4)
[ 2576.230000] [<c0142adc>] (ext4_error_inode+0xc8/0x108) from [<c013db94>] (ext4_find_entry+0x32c/0x5c4)
[<c013db94>] (ext4_find_entry+0x32c/0x5c4) from [<c013de64>] (ext4_lookup+0x38/0x168)
[ 2576.240000] [<c013db94>] (ext4_find_entry+0x32c/0x5c4) from [<c013de64>] (ext4_lookup+0x38/0x168)
[<c013de64>] (ext4_lookup+0x38/0x168) from [<c00bd448>] (lookup_real+0x20/0x4c)
[ 2576.260000] [<c013de64>] (ext4_lookup+0x38/0x168) from [<c00bd448>] (lookup_real+0x20/0x4c)
[<c00bd448>] (lookup_real+0x20/0x4c) from [<c00c12ac>] (do_last.isra.55+0x758/0xbe8)
[ 2576.280000] [<c00bd448>] (lookup_real+0x20/0x4c) from [<c00c12ac>] (do_last.isra.55+0x758/0xbe8)
[<c00c12ac>] (do_last.isra.55+0x758/0xbe8) from [<c00c17e8>] (path_openat.isra.56+0xac/0x474)
[ 2576.290000] [<c00c12ac>] (do_last.isra.55+0x758/0xbe8) from [<c00c17e8>] (path_openat.isra.56+0xac/0x474)
[<c00c17e8>] (path_openat.isra.56+0xac/0x474) from [<c00c27b4>] (do_filp_open+0x2c/0x80)
[ 2576.310000] [<c00c17e8>] (path_openat.isra.56+0xac/0x474) from [<c00c27b4>] (do_filp_open+0x2c/0x...

Read more...

description: updated
description: updated
description: updated
Soumya Basak (soumya-basak) wrote :

the issue reproduced with Linaro Android 4.4 Samsung Arndale 13.11 release build:

https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.11-release/#build=2

once the device is enter into suspend state, it never wake ups.

logcat attached for reference.

description: updated
Soumya Basak (soumya-basak) wrote :
description: updated
description: updated
summary: - suspend-resume test not working on Linaro android arndale builds
+ suspend-resume test not working with Arndale on Linaro android kitkat
+ builds
description: updated
summary: - suspend-resume test not working with Arndale on Linaro android kitkat
+ suspend-resume test not working on Arndale with Linaro android kitkat
builds
description: updated
tags: added: android-kitkat
Botao (botao-sun) on 2014-03-21
description: updated
summary: - suspend-resume test not working on Arndale with Linaro android kitkat
- builds
+ Samsung Arndale Android couldn't be woken up once entered suspend mode.
Botao (botao-sun) wrote :

On Samsung Arndale board with Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.03-release/#build=1

Problem as described in comment #3 still exists.

description: updated
description: updated
Botao (botao-sun) wrote :

On Samsung Arndale board with Linaro Android build #447:

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=447

The board can't enter the suspend mode after time interval reached, with following error shows in serial console. However, the board is still alive after that.

root@arndale:/ # 4------------[ cut here ]------------
[ 687.170000] ------------[ cut here ]------------
4WARNING: at /mnt/jenkins/workspace/linaro-android_linux-linaro-arndale/build/kernel/linaro/arndale/mm/page_alloc.c:2387 __alloc_pages_nodema)
[ 687.190000] WARNING: at /mnt/jenkins/workspace/linaro-android_linux-linaro-arndale/build/kernel/linaro/arndale/mm/page_alloc.c:2387 __allo)
dModules linked in:[ 687.210000] Mo
                                     ules linked in:
[<c001483c>] (unwind_backtrace+0x0/0xf4) from [<c001efa0>] (warn_slowpath_common+0x54/0x6c)
[ 687.220000] [<c001483c>] (unwind_backtrace+0x0/0xf4) from [<c001efa0>] (warn_slowpath_common+0x54/0x6c)
[<c001efa0>] (warn_slowpath_common+0x54/0x6c) from [<c001f054>] (warn_slowpath_null+0x1c/0x24)
[ 687.250000] [<c001efa0>] (warn_slowpath_common+0x54/0x6c) from [<c001f054>] (warn_slowpath_null+0x1c/0x24)
[<c001f054>] (warn_slowpath_null+0x1c/0x24) from [<c0078888>] (__alloc_pages_nodemask+0x1dc/0x874)
[ 687.300000] [<c001f054>] (warn_slowpath_null+0x1c/0x24) from [<c0078888>] (__alloc_pages_nodemask+0x1dc/0x874)
[<c0078888>] (__alloc_pages_nodemask+0x1dc/0x874) from [<c0078f30>] (__get_free_pages+0x10/0x24)
[ 687.340000] [<c0078888>] (__alloc_pages_nodemask+0x1dc/0x874) from [<c0078f30>] (__get_free_pages+0x10/0x24)
[<c0078f30>] (__get_free_pages+0x10/0x24) from [<c00d303c>] (seq_read+0x238/0x48c)
[ 687.360000] [<c0078f30>] (__get_free_pages+0x10/0x24) from [<c00d303c>] (seq_read+0x238/0x48c)
[<c00d303c>] (seq_read+0x238/0x48c) from [<c00b5098>] (vfs_read+0x98/0x144)
[ 687.380000] [<c00d303c>] (seq_read+0x238/0x48c) from [<c00b5098>] (vfs_read+0x98/0x144)
[<c00b5098>] (vfs_read+0x98/0x144) from [<c00b53cc>] (sys_read+0x3c/0x78)
[ 687.390000] [<c00b5098>] (vfs_read+0x98/0x144) from [<c00b53cc>] (sys_read+0x3c/0x78)
[<c00b53cc>] (sys_read+0x3c/0x78) from [<c000dec0>] (ret_fast_syscall+0x0/0x30)
[ 687.400000] [<c00b53cc>] (sys_read+0x3c/0x78) from [<c000dec0>] (ret_fast_syscall+0x0/0x30)
4---[ end trace 3939078399d7c43e ]---
[ 687.410000] ---[ end trace 3939078399d7c43e ]---

Botao (botao-sun) wrote :

Please ignore comment #7. The board couldn't enter the suspend mode because I set stay awake in development options. Now after disable that, the board can enter the suspend mode but can't be woken up, leaving a dead serial console, same as comment #3.

description: updated
Botao (botao-sun) wrote :

There is a worse side effect for this failure, which is once the test failed, the board won't be booted up again, no output in serial console.

So the SD card has to be re-flashed in this situation, in order to bring the board up again.

Botao (botao-sun) wrote :

On Samsung Arndale board with Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-14.05-release/#build=1

For the description in comment #9, now SD card re-flash is not required after Kernel crashed.

description: updated
Botao (botao-sun) on 2014-06-19
description: updated
Botao (botao-sun) on 2014-06-24
description: updated
Botao (botao-sun) on 2014-07-22
description: updated
Botao (botao-sun) on 2014-07-30
description: updated
Milosz Wasilewski (mwasilew) wrote :

Arndale is not supported any more

Changed in linaro-android:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers