"perf" test cases Performance counter stats for 'ls' data unavailable on Linaro-android jb panda builds

Bug #1183215 reported by Soumya Basak on 2013-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
HariGopal

Bug Description

linaro-android jb panda builds

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=296

perf test cases

https://wiki.linaro.org/Platform/QA/TestCases/Android#perf_.28Manually.29

performance counter stat 'ls' data is unavailable

from log:

root@android:/ # perf stat ls
LICENCE.ti-connectivity
acct
cache
config
d
data
default.prop
dev
etc
fstab.omap4pandaboard
init
init.goldfish.rc
init.omap4pandaboard.rc
init.omap4pandaboard.usb.rc
init.rc
init.trace.rc
init.usb.rc
mnt
proc
root
sbin
sdcard
storage
sys
system
ueventd.goldfish.rc
ueventd.omap4pandaboard.rc
ueventd.rc
vendor

 Performance counter stats for 'ls':

     <not counted> task-clock
     <not counted> context-switches
     <not counted> CPU-migrations
     <not counted> page-faults
     <not counted> cycles
     <not counted> stalled-cycles-frontend
     <not counted> stalled-cycles-backend
     <not counted> instructions
     <not counted> branches
     <not counted> branch-misses

       0.008422851 seconds time elapsed

root@android:/ #

###########################################
This issue is observed on following images:
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.05-release/#build=2
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=323
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.06-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.07-release/#build=2
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=378
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=384
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.08-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=409
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.09-release/#build=10
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=448
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.10-release/#build=3

description: updated
vishal (vishalbhoj) on 2013-06-10
Changed in linaro-android:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → HariGopal (harigopal-gollamudi)
description: updated
description: updated
Changed in linaro-android:
status: Confirmed → In Progress
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Botao (botao-sun) on 2013-10-17
description: updated
description: updated
HariGopal (harigopal-gollamudi) wrote :

Patch committed will be available in next release.

Changed in linaro-android:
status: In Progress → Fix Committed
vishal (vishalbhoj) on 2013-10-31
Changed in linaro-android:
milestone: none → 13.10
vishal (vishalbhoj) on 2013-10-31
Changed in linaro-android:
milestone: 13.10 → 13.11
Soumya Basak (soumya-basak) wrote :

tested with Linaro Android Jellybean Panda builds:

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=477

perf data is available. The issue is fixed now.

Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints