Cloning Toolchain sources from bzr not stable. Native toolchain disabled on Linaro Android

Bug #1182761 reported by Botao on 2013-05-22
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Low
Bernhard Rosenkraenzer

Bug Description

On ARM Versatile Express A9 board with Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=291

GCC and G++ compiler is unavailable.

root@android:/data # which gcc
1|root@android:/data #
root@android:/data # which g++
1|root@android:/data #

###########################################
This issue is observed on following images
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=291
https://android-build.linaro.org/builds/~linaro-android-member-ste/snowball-linaro-jb/#build=305
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.05-release/#build=2
https://android-build.linaro.org/builds/~linaro-android-member-ste/snowball-linaro-jb-13.05-release/
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=323
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=325
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.06-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.06-release/#build=1

https://android-build.linaro.org/builds/~linaro-android-member-ste/snowball-linaro-jb-13.06-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.07-release/#build=2

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.07-release/#build=2

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale-13.07-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro/#build=59
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=170

Ashutosh Tomar (ashutosh-tomar) wrote :

This is first ever bug...

Changed in linaro-android:
assignee: nobody → Ashutosh Tomar (ashutosh-tomar)
vishal (vishalbhoj) on 2013-05-22
Changed in linaro-android:
assignee: Ashutosh Tomar (ashutosh-tomar) → nobody
Soumya Basak (soumya-basak) wrote :

the issue reproduced with linaro-android jb panda builds also.

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=296

vishal (vishalbhoj) wrote :

We have disable developer tools from daily builds currently since we see build failures while fetching code from bzr.

description: updated
Botao (botao-sun) on 2013-05-29
description: updated
description: updated
vishal (vishalbhoj) on 2013-06-10
Changed in linaro-android:
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Bernhard Rosenkraenzer (berolinux)
description: updated
Botao (botao-sun) on 2013-06-19
description: updated
Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.06-release/#build=1

"perf" test now backs to work:

root@android:/ # perf stat ls
acct
cache
config
d
data
default.prop
dev
etc
fstab.arm-versatileexpress
fstab.arm-versatileexpress-usb
fstab.v2p-aarch64
init
init.arm-versatileexpress-usb.rc
init.arm-versatileexpress.rc
init.goldfish.rc
init.partitions.arm-versatileexpress-usb.rc
init.partitions.arm-versatileexpress.rc
init.rc
init.trace.rc
init.usb.rc
init.v2p-aarch64.rc
mnt
proc
root
sbin
sdcard
storage
sys
system
ueventd.arm-versatileexpress-usb.rc
ueventd.arm-versatileexpress.rc
ueventd.goldfish.rc
ueventd.rc
ueventd.v2p-aarch64.rc
vendor

 Performance counter stats for 'ls':

         13.578958 task-clock # 0.861 CPUs utilized
                 0 context-switches # 0.000 M/sec
                 1 CPU-migrations # 0.000 M/sec
               144 page-faults # 0.011 M/sec
           5385358 cycles # 0.397 GHz
           1333289 stalled-cycles-frontend # 24.76% frontend cycles idle
                 0 stalled-cycles-backend # 0.00% backend cycles idle
           1655805 instructions # 0.31 insns per cycle
                                             # 0.81 stalled cycles per insn
            139587 branches # 10.280 M/sec
             61065 branch-misses # 43.75% of all branches

       0.015772000 seconds time elapsed

root@android:/ #

description: updated
Changed in linaro-android:
status: Confirmed → Fix Released
Botao (botao-sun) wrote :

Please ignore comment #4, that should be for Bug 1182839.

Changed in linaro-android:
status: Fix Released → Confirmed
description: updated
description: updated
Botao (botao-sun) on 2013-07-23
description: updated
Soumya Basak (soumya-basak) wrote :

seems the same issue reproduced with Linaro android Jellybean arndale builds

https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale-13.07-release/#build=2

description: updated
description: updated
vishal (vishalbhoj) wrote :

Cloning the toolchain code base from bzr is not stable which resulted in broken daily builds and hence the support for native toolchain on Android was disabled in the builds. We will enable it when the toolchain hosting is moved to something more stable. For now we are proviging native toolchain in the Galaxy Nexus build.

summary: - GCC and G++ compiler is unavailable on Linaro Android image.
+ Cloning Toolchain sources from bzr not stable. Native toolchain disabled
+ on Linaro Android
Botao (botao-sun) on 2013-08-20
description: updated

Checkouts seem to be a lot more stable now that the toolchain is maintained in svn, this may be a good time to reenable it.

description: updated
vishal (vishalbhoj) on 2013-11-27
Changed in linaro-android:
milestone: none → 13.11
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints