1080p H.264 video playback failed on Linaro Android Kitkat, Panda builds

Bug #1175457 reported by Soumya Basak on 2013-05-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Won't Fix
Wishlist
Unassigned

Bug Description

On Linaro Android TI Panda build:

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.04-release/#build=4

Test case: https://wiki.linaro.org/Platform/QA/TestCases/Android#Hardware_Video

The 1080p video playback failed, screen is serious lagging, like a slide show:
http://samplemedia.linaro.org/H264/big_buck_bunny_1080p_H264_AAC_25fps_7200K.MP4

However, 480p video can be played well:
http://samplemedia.linaro.org/H264/big_buck_bunny_480p_H264_AAC_25fps_1800K.MP4

Audio playback is good for both video clips (No HDMI Audio though).

#################################################
This issue can be reproduced on following builds:
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.02-release/
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.03-release/
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=251
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=267
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=284
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=292
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=296
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.05-release/#build=2
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=323
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.06-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.07-release/#build=2
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=378
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=384
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.08-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=409
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.09-release/#build=10
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=448
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.10-release/#build=3
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=477
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.12-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.01-release/#build=2
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=564
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.02-release/#build=11
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=613
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.03-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=639
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.04-release/#build=1
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.06-release/#build=1

summary: - 1080p h.264 video can't be played on Linaro-android panda builds
+ 1080p h.264 video can't be playedsuccessfully on Linaro-android panda
+ builds
description: updated
summary: - 1080p h.264 video can't be playedsuccessfully on Linaro-android panda
+ 1080p h.264 video can't be played successfully on Linaro-android panda
builds

1080P video playback require h/w accelerated video codecs which are not available for panda.

Changed in linaro-android:
importance: Undecided → Wishlist
status: New → Confirmed
description: updated
description: updated
description: updated
description: updated
Botao (botao-sun) on 2013-06-11
description: updated
description: updated
description: updated
description: updated
Soumya Basak (soumya-basak) wrote :

the issue reproduced with 13.06 release, galaxy_nexus builds:
https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro-13.06-release/#build=7

the playback of video is not smoothly, the device is reboot automatically.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Botao (botao-sun) on 2013-10-17
description: updated
summary: - 1080p h.264 video can't be played successfully on Linaro-android panda
- builds
+ 1080p H.264 video playback failed on Linaro Android TI Panda Image
description: updated
description: updated
description: updated
description: updated
summary: - 1080p H.264 video playback failed on Linaro Android TI Panda Image
+ 1080p H.264 video playback failed on Linaro Android Kitkat TI Panda
+ Image
summary: - 1080p H.264 video playback failed on Linaro Android Kitkat TI Panda
- Image
+ 1080p H.264 video playback failed on Linaro Android Kitkat, Panda builds
description: updated
tags: added: android-kitkat
description: updated
description: updated
description: updated
Soumya Basak (soumya-basak) wrote :

the issue observed with Linaro Android Kitkat TI-panda builds:

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.03-release/#build=1

with Ti-panda 4430 board,

validate test cases: https://wiki.linaro.org/Platform/QA/TestCases/Android#Hardware_Video

720p & 1080p video playback not smoothly from Gallery.

description: updated
description: updated
Botao (botao-sun) on 2014-06-26
description: updated
Changed in linaro-android:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers