SunSpider JavaScript Benchmark doesn't work with Linaro Android Jelly Bean 4.2

Bug #1086599 reported by Botao on 2012-12-04
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
Yongqin Liu
linaro-landing-team-arm
Won't Fix
Undecided
Unassigned

Bug Description

On ARM Versatile Express A9 with Linaro Android Jelly Bean 4.2 build:

https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=117

SunSpider JavaScript Benchmark in 0xBenchmark can't be done successfully. It runs first, then freezing.

Reproduce procedures:

1. Launch 0xBenchmark;
2. Click MISC on top menu;
3. Select SunSpider;
4. Click MAIN on top menu then select Misc on left side panel;
5. Click Run at the bottom

###########################################
This issue is observed on following images:
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=117
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=126
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.12-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=152
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=158
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=167
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.01-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=179
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=185
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=191
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.02-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=220
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.03-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=250
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.04-release/#build=5
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=291
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.05-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=325
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.06-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.07-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro/#build=59
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-4.2.2-13.08-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro/#build=85
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.10-release/#build=2
###########################################
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=170
https://android-build.linaro.org/builds/~linaro-android/linux-linaro-arndale/#build=195
https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.10-release/#build=4
###########################################
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=384
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=409
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.09-release/#build=10
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=448
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.10-release/#build=3
###########################################
https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro/#build=417
https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro-13.08-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro/#build=441
https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro-13.09-release/#build=4
https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro/#build=472
https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro-13.10-release/#build=1
###########################################
https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk/#build=52
https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk-13.10-release/#build=2

Botao (botao-sun) on 2012-12-11
description: updated
summary: - SunSpider JavaScript Benchmark doesn't work on vexpress A9 with Linaro
+ SunSpider JavaScript Benchmark doesn't work on vexpress with Linaro
Android Jelly Bean 4.2
Botao (botao-sun) on 2012-12-19
description: updated
Botao (botao-sun) on 2013-01-08
description: updated
Botao (botao-sun) on 2013-01-15
description: updated
Botao (botao-sun) on 2013-01-23
description: updated
Botao (botao-sun) on 2013-01-30
description: updated
Botao (botao-sun) on 2013-02-07
description: updated
Botao (botao-sun) on 2013-02-14
description: updated
Botao (botao-sun) on 2013-02-19
description: updated
Botao (botao-sun) on 2013-02-25
description: updated
Botao (botao-sun) on 2013-03-21
description: updated
Botao (botao-sun) on 2013-03-27
description: updated
Botao (botao-sun) on 2013-04-11
description: updated
Botao (botao-sun) on 2013-04-23
description: updated
Ryan Harkin (ryanharkin) on 2013-04-25
Changed in linaro-landing-team-arm:
status: New → Won't Fix

Botao,

Do you have any logs on this ? do you see the bug across all the linaro builds ?

Download full text (3.2 KiB)

Hi Vishal,

Unfortunately I don't have the log in my hands right now, and I only
observed this issue on vexpress A9 board since all the other boards are
handled by Soumya.

The behaviour here is after triggered the SunSpider test, it will run for a
while then hang there, no more test output available after it hangs.
However, the system is fine, you can click the back button to exit this
test normally.

Thanks.

Best Regards
Botao Sun

On Thu, Apr 25, 2013 at 7:55 PM, vishal <email address hidden> wrote:

> Botao,
>
> Do you have any logs on this ? do you see the bug across all the linaro
> builds ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1086599
>
> Title:
> SunSpider JavaScript Benchmark doesn't work on vexpress with Linaro
> Android Jelly Bean 4.2
>
> Status in Linaro Android:
> New
> Status in Linaro ARM Landing Team Project:
> Won't Fix
>
> Bug description:
> On ARM Versatile Express A9 with Linaro Android Jelly Bean 4.2 build:
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-
> gcc47-armlt-tracking-open/#build=117
>
> SunSpider JavaScript Benchmark in 0xBenchmark can't be done
> successfully. It runs first, then freezing.
>
> Reproduce procedures:
>
> 1. Launch 0xBenchmark;
> 2. Click MISC on top menu;
> 3. Select SunSpider;
> 4. Click MAIN on top menu then select Misc on left side panel;
> 5. Click Run at the bottom
>
>
> ##########################################################################
> This issue is observed on following images:
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=117
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=126
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.12-release/#build=2
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=152
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=158
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=167
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.01-release/#build=1
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=179
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=185
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=191
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.02-release/#build=2
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=220
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.03-release/#build=1
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=250
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.04-release/#build=5
>
> To manage notifications about this bug go to:
> https://b...

Read more...

Botao (botao-sun) on 2013-05-21
description: updated
Botao (botao-sun) on 2013-05-28
description: updated
Botao (botao-sun) on 2013-06-18
description: updated

The same issue observed with builds:

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=323

with TI-Panda 4460 board:

according to the procedures, the same issue is reproduced with TI-Panda 4460 on my side.
after trigger the Sunspider test, it will run for a couple of minute then hang there.
on the other hand, the system is fine, to click the back button to exit this
test normally.

logcat attached for your references.

Download full text (3.8 KiB)

Is this a generic problem with all Android builds, or a problem with a
particular browser on Android? Or does it just affect TI and ARM?

On Tue, Jun 18, 2013 at 3:42 AM, Soumya Basak <email address hidden>wrote:

> The same issue observed with builds:
>
> https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-
> linaro/#build=323
>
> with TI-Panda 4460 board:
>
> according to the procedures, the same issue is reproduced with TI-Panda
> 4460 on my side.
> after trigger the Sunspider test, it will run for a couple of minute then
> hang there.
> on the other hand, the system is fine, to click the back button to exit
> this
> test normally.
>
> logcat attached for your references.
>
> ** Attachment added: "Sunspider_test_log"
>
> https://bugs.launchpad.net/linaro-android/+bug/1086599/+attachment/3706216/+files/0xbench.txt
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: ARM, which is subscribed to linaro-landing-team-arm.
> https://bugs.launchpad.net/bugs/1086599
>
> Title:
> SunSpider JavaScript Benchmark doesn't work on vexpress with Linaro
> Android Jelly Bean 4.2
>
> Status in Linaro Android:
> New
> Status in Linaro ARM Landing Team Project:
> Won't Fix
>
> Bug description:
> On ARM Versatile Express A9 with Linaro Android Jelly Bean 4.2 build:
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-
> gcc47-armlt-tracking-open/#build=117
>
> SunSpider JavaScript Benchmark in 0xBenchmark can't be done
> successfully. It runs first, then freezing.
>
> Reproduce procedures:
>
> 1. Launch 0xBenchmark;
> 2. Click MISC on top menu;
> 3. Select SunSpider;
> 4. Click MAIN on top menu then select Misc on left side panel;
> 5. Click Run at the bottom
>
>
> ##########################################################################
> This issue is observed on following images:
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=117
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=126
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.12-release/#build=2
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=152
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=158
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=167
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.01-release/#build=1
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=179
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=185
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=191
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.02-release/#build=2
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=220
>
> https://android-build.linaro.org/builds/~linaro-and...

Read more...

vishal (vishalbhoj) on 2013-06-19
Changed in linaro-android:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Yongqin Liu (liuyq0307)
milestone: none → 13.06

Hi Scott,
The issue reproduced with Linaro-android Jellybean snowball and Galaxy Nexus Builds also.
so, I think its a generic problems with all android builds.

Ryan Harkin (ryanharkin) wrote :

ARMLT marked this as "won't fix" because it appears to be a generic Android bug rather than a Versatile Express specific problem.

Botao (botao-sun) on 2013-06-24
description: updated
Soumya Basak (soumya-basak) wrote :
Fathi Boudra (fboudra) on 2013-06-28
Changed in linaro-android:
milestone: 13.06 → 13.07
Botao (botao-sun) on 2013-07-23
description: updated
summary: - SunSpider JavaScript Benchmark doesn't work on vexpress with Linaro
- Android Jelly Bean 4.2
+ SunSpider JavaScript Benchmark doesn't work with Linaro Android Jelly
+ Bean 4.2
Soumya Basak (soumya-basak) wrote :

seems the same issue reproduced with Linaro android Jellybean TI-panda builds

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.07-release/#build=2

Soumya Basak (soumya-basak) wrote :

also reproduced the same issue with Linaro android jellybean 4.2.2 Galaxy Nexus builds,

https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro-13.07-release/#build=2

description: updated
Botao (botao-sun) on 2013-08-20
description: updated
description: updated
description: updated
description: updated
description: updated
Botao (botao-sun) wrote :

On ARM Versatile Express A9 with Linaro Android Jelly Bean 4.3 build:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-4.3-13.08-release/#build=1

This test totally couldn't be run, only a white blank screen showed.

Soumya Basak (soumya-basak) wrote :

the issue observed on builds

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.08-release/#build=1

on TI-pandaboard 4460, with Android Jelllybean 4.3 the test can't run completely, only a white blank screen showed.

same issue as ARM Vexpress A9 , from above comments #11.

Soumya Basak (soumya-basak) wrote :

observed with Linaro android Jellybean 13.08 arndale release builds

https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.08-release/#build=1

 the test can't run completely, after running few minuites only a white blank screen showed.

description: updated
Botao (botao-sun) on 2013-08-29
description: updated
Fathi Boudra (fboudra) on 2013-09-03
Changed in linaro-android:
milestone: 13.07 → none
Botao (botao-sun) on 2013-09-18
description: updated
description: updated
description: updated
description: updated
Botao (botao-sun) wrote :

On ARM Versatile Express A9 with Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.09-release/#build=6

Now only a white screen shows after clicked to run this Sun Spider test, please refer to attachment.

description: updated
description: updated
description: updated
Botao (botao-sun) on 2013-10-17
description: updated
Botao (botao-sun) on 2013-10-18
description: updated
Botao (botao-sun) on 2013-10-21
description: updated
description: updated
vishal (vishalbhoj) on 2013-10-22
Changed in linaro-android:
milestone: none → 13.11
description: updated
description: updated
Yongqin Liu (liuyq0307) wrote :

I/ActivityManager( 1814): START u0 {cmp=org.zeroxlab.zeroxbenchmark/.TesterJavascript (has extras)} from pid 2236
D/dalvikvm( 1814): GC_FOR_ALLOC freed 962K, 23% free 6886K/8844K, paused 59ms, total 61ms
I/InputDispatcher( 1814): Dropping event because there is no touched window.
I/InputDispatcher( 1814): Dropping event because there is no touched window.
I/ActivityManager( 1814): Displayed org.zeroxlab.zeroxbenchmark/.TesterJavascript: +337ms
D/TilesManager( 2236): Starting TG #0, 0x41b830d0
W/webview_proxy( 2236): java.lang.Throwable: Warning: A WebView method was called on thread 'Thread-60'. All WebView methods must be called on the UI thread. Future versions of WebView may not support use on othe
r threads.
W/webview_proxy( 2236): at android.webkit.WebView.checkThread(WebView.java:1918)
W/webview_proxy( 2236): at android.webkit.WebView.loadUrl(WebView.java:771)
W/webview_proxy( 2236): at org.zeroxlab.zeroxbenchmark.TesterJavascript.oneRound(TesterJavascript.java:72)
W/webview_proxy( 2236): at org.zeroxlab.zeroxbenchmark.Tester$TesterThread.lazyLoop(Tester.java:173)
W/webview_proxy( 2236): at org.zeroxlab.zeroxbenchmark.Tester$TesterThread.run(Tester.java:204)
E/StrictMode( 2236): null
E/StrictMode( 2236): java.lang.Throwable: Warning: A WebView method was called on thread 'Thread-60'. All WebView methods must be called on the UI thread. Future versions of WebView may not support use on other t
hreads.
E/StrictMode( 2236): at android.webkit.WebView.checkThread(WebView.java:1918)
E/StrictMode( 2236): at android.webkit.WebView.loadUrl(WebView.java:771)
E/StrictMode( 2236): at org.zeroxlab.zeroxbenchmark.TesterJavascript.oneRound(TesterJavascript.java:72)
E/StrictMode( 2236): at org.zeroxlab.zeroxbenchmark.Tester$TesterThread.lazyLoop(Tester.java:173)
E/StrictMode( 2236): at org.zeroxlab.zeroxbenchmark.Tester$TesterThread.run(Tester.java:204)
W/System.err( 2236): java.lang.RuntimeException: java.lang.Throwable: Warning: A WebView method was called on thread 'Thread-60'. All WebView methods must be called on the UI thread. Future versions of WebView ma
y not support use on other threads.
W/System.err( 2236): at android.webkit.WebView.checkThread(WebView.java:1927)
W/System.err( 2236): at android.webkit.WebView.loadUrl(WebView.java:771)
W/System.err( 2236): at org.zeroxlab.zeroxbenchmark.TesterJavascript.oneRound(TesterJavascript.java:72)
W/System.err( 2236): at org.zeroxlab.zeroxbenchmark.Tester$TesterThread.lazyLoop(Tester.java:173)
W/System.err( 2236): at org.zeroxlab.zeroxbenchmark.Tester$TesterThread.run(Tester.java:204)
W/System.err( 2236): Caused by: java.lang.Throwable: Warning: A WebView method was called on thread 'Thread-60'. All WebView methods must be called on the UI thread. Future versions of WebView may not support use
 on other threads.
W/System.err( 2236): at android.webkit.WebView.checkThread(WebView.java:1918)
W/System.err( 2236): ... 4 more
V/tiny_hw ( 1350): out_standby(0x4001d008) closing PCM

Changed in linaro-android:
status: Confirmed → In Progress
Yongqin Liu (liuyq0307) wrote :

The above log is based on build#455

description: updated
Yongqin Liu (liuyq0307) wrote :
Changed in linaro-android:
status: In Progress → Fix Committed
Soumya Basak (soumya-basak) wrote :

Tested with Linaro Android Jellybean TI- Panda builds:

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=477

The issue is fixed now, SunSpider JavaScript Benchmark of 0xbench works well.

Changed in linaro-android:
status: Fix Committed → Fix Released
Botao (botao-sun) wrote :

@Soumya, on ARM Versatile Express A9 board with Linaro Android 13.11 release candidate image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.11-release/#build=2

The SunSpider JS Benchmark now can be launched and run, however, after quickly showing several components name on screen, the benchmark quitted without test result provided.

Did you observe the same phenomenon on your side when testing TI Panda board?

Yongqin Liu (liuyq0307) wrote :

I checked it with panda-linaro build#484, and the problems occurs again for 4.4.

The problem should be caused by following information in logcat cat:

11-26 05:42:26.581 I/chromium( 2857): [INFO:CONSOLE(107)] "Uncaught TypeError: Object [object Object] has no method 'finish'", source: file:///android_asset/driver.html (107)

Could you help to check if the the above information exists in the logcat on other builds?

Soumya Basak (soumya-basak) wrote :

Hi Botao,

reopen this bug,
this issue again reproduced with Linaro Android 4.4 builds for all the boards,

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.11-release/#build=2

https://android-build.linaro.org/builds/~linaro-android/arndale-linaro-13.11-release/#build=2

https://android-build.linaro.org/builds/~linaro-android/galaxynexus-linaro-13.11-release/#build=1

1. Panda 4460
2. Panda 4430
3. Samsung Arndale
4. Galaxy Nexus.

@ Yongqin, I got the same logcat message:

I/chromium( 2420): [INFO:CONSOLE(107)] "Uncaught TypeError: Object [object Object] has no method 'finish'", source: file:///android_asset

logcat attached for reference.

vishal (vishalbhoj) wrote :

 This is a different issue. Please report it in this bug:
https://bugs.launchpad.net/linaro-android/+bug/1254823

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints