Eth0 has to be manually selected from ECM list to make Ethernet work

Bug #1069648 reported by Soumya Basak on 2012-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Undecided
Unassigned

Bug Description

As I observed Linaro-android jellybean 4.2.2 TI-panda builds, on first boot ups ethernet can't come up auto.

Normally we follow our test wiki page either Ethernet configurable from command line or from settings and Ethernet Configuration list.
https://wiki.linaro.org/Platform/QA/TestCases/Android#ethernet_.28Manually.29

Initially Observed with panda JB android build
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=38

Also observed with below mentioned builds:

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=40
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=49
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob-12.09-release/#build=4
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=65
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=79
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=82
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob-12.10-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=100
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=106
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=115
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.03-release/
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=251
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=259
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=267

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.04-release/#build=4
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=277
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=284
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=292
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=296

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.05-release/#build=2

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=310

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=319

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=323

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.06-release/#build=1

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=336

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.07-release/#build=2

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=362

description: updated
description: updated
description: updated
Soumya Basak (soumya-basak) wrote :

Observed with panda jb android RC12.11 release builds
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob-12.11-release/#build=1

Ethernet connection manager is available but need to change Ethernet device to eth0 from the Ethernet configuration setting to make it work.

Soumya Basak (soumya-basak) wrote :

also observed with panda-es board with Linaro android jb re;ease build:
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.01-release/#build=2
ethernet can be configured from ECM
Configure Ethernet device make changes to "eth0" to make ethernet work.

Soumya Basak (soumya-basak) wrote :

for the panda Linaro android 13.02 release image
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.02-release/
I followed the procedure from wiki page https://wiki.linaro.org/Platform/QA/TestCases/Android#boot-test_-_dwm to make eth0 up

1. ifconfig eth0 192.168.1.8 netmask 255.255.255.0 up
2. route add default gw 192.168.1.1 dev eth0
3. setprop net.dns1 192.168.1.1

description: updated
summary: - Eth0 has to be manually selected from ECM to make Ethernet work
+ Eth0 has to be manually selected from ECM list to make Ethernet work
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Botao (botao-sun) wrote :

On TI Panda board with Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=372

Ethernet now works well automatically after system booted up:

PING www.google.com (74.125.237.16): 56 data bytes
64 bytes from 74.125.237.16: seq=0 ttl=51 time=40.526 ms
64 bytes from 74.125.237.16: seq=1 ttl=52 time=40.165 ms
64 bytes from 74.125.237.16: seq=2 ttl=52 time=42.662 ms
64 bytes from 74.125.237.16: seq=3 ttl=51 time=39.552 ms
64 bytes from 74.125.237.16: seq=4 ttl=51 time=39.729 ms
^C
--- www.google.com ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 39.552/40.526/42.662 ms

This bug now can be considered as "Fix Released".

Changed in linaro-android:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers