TC2: powertop doesn't show correct frequency stats

Bug #1042755 reported by Tixy (Jon Medhurst) on 2012-08-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
Linaro Landing Team: ARM

Bug Description

On TC2 running Android, powertop always shows Frequency stats claiming all cores are spending 100% of there time in idle.

Observed in the 12.08 release...
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1

Anmar Oueja (anmar) on 2012-10-26
summary: - powertop doesn't show correct frequency stats
+ TC2: powertop doesn't show correct frequency stats
Anmar Oueja (anmar) on 2012-11-08
Changed in linaro-landing-team-arm:
status: New → Won't Fix
importance: Undecided → Medium
tekstr1der (tekstr1der) wrote :

The same behavior is observed in 12.04.1 LTS desktop version as well.

tekstr1der (tekstr1der) wrote :

Please disregard my previous comment #1. This behavior is by design of ThinkPad BIOS when battery is not present and running on 65W AC adapter.

Ryan Harkin (ryanharkin) wrote :

This bug was noticed whilst investigating a different issue. ARMLT marked this bug as "won't fix" as it was considered too low a priority to be worth investigating further.

If a compelling use case is given, we will reopen the bug and investigate.

Powertop is a tool we support via PMWG. This tool should work with
Versatile Express. I think this should be investigated and fixed if not a
hardware problem.

Scott

On Thu, Jun 20, 2013 at 2:17 PM, Ryan Harkin <email address hidden>wrote:

> This bug was noticed whilst investigating a different issue. ARMLT
> marked this bug as "won't fix" as it was considered too low a priority
> to be worth investigating further.
>
> If a compelling use case is given, we will reopen the bug and
> investigate.
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: ARM, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1042755
>
> Title:
> TC2: powertop doesn't show correct frequency stats
>
> Status in Linaro Android:
> New
> Status in Linaro ARM Landing Team Project:
> Won't Fix
>
> Bug description:
> On TC2 running Android, powertop always shows Frequency stats claiming
> all cores are spending 100% of there time in idle.
>
> Observed in the 12.08 release...
>
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/1042755/+subscriptions
>

--
Scott Bambrough
Technical Director, Member Services
Linaro <http://www.linaro.org>

Tixy (Jon Medhurst) (tixy) wrote :

powertop shows sensible values when IKS is used

Observed when testing the 13.09 release candidate, which doesn't have big.LITTLE MP : https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-13.09-release/#build=6

Roger Teague (roger-teague) wrote :

Hi ya,

I'm assuming I read this correctly. That the bug only appears in IKS and Not MP?

If this is the case fine with wont fix but if the bug appears is MP why is it we are not fixing?

Thanks

Sent from yet another low power ARM device

On 24 Sep 2013, at 16:41, "Tixy (Jon Medhurst)" <email address hidden> wrote:

> powertop shows sensible values when IKS is used
>
> Observed when testing the 13.09 release candidate, which doesn't have
> big.LITTLE MP : https://android-build.linaro.org/builds/~linaro-android
> /vexpress-linaro-13.09-release/#build=6
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: ARM, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1042755
>
> Title:
> TC2: powertop doesn't show correct frequency stats
>
> Status in Linaro Android:
> New
> Status in Linaro ARM Landing Team Project:
> Won't Fix
>
> Bug description:
> On TC2 running Android, powertop always shows Frequency stats claiming
> all cores are spending 100% of there time in idle.
>
> Observed in the 12.08 release...
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/1042755/+subscriptions
>

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2557590
ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2548782

George Grey (gcgrey) wrote :

Hi Roger
I don't know the answer to this - forwarding to <email address hidden> for an explanation.
Questions:
1. Why are we not fixing for IKS
2. Have we verified the problem does not occur with the LSK release (ie with MP)
George

On Sep 24, 2013, at 4:42 PM, Roger Teague <email address hidden> wrote:

> Hi ya,
>
> I'm assuming I read this correctly. That the bug only appears in IKS
> and Not MP?
>
> If this is the case fine with wont fix but if the bug appears is MP why
> is it we are not fixing?
>
> Thanks
>
> Sent from yet another low power ARM device
>
> On 24 Sep 2013, at 16:41, "Tixy (Jon Medhurst)"
> <email address hidden> wrote:
>
>> powertop shows sensible values when IKS is used
>>
>> Observed when testing the 13.09 release candidate, which doesn't have
>> big.LITTLE MP : https://android-build.linaro.org/builds/~linaro-android
>> /vexpress-linaro-13.09-release/#build=6
>>
>> --
>> You received this bug notification because you are a member of Linaro
>> Landing Team: ARM, which is subscribed to the bug report.
>> https://bugs.launchpad.net/bugs/1042755
>>
>> Title:
>> TC2: powertop doesn't show correct frequency stats
>>
>> Status in Linaro Android:
>> New
>> Status in Linaro ARM Landing Team Project:
>> Won't Fix
>>
>> Bug description:
>> On TC2 running Android, powertop always shows Frequency stats claiming
>> all cores are spending 100% of there time in idle.
>>
>> Observed in the 12.08 release...
>> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/linaro-android/+bug/1042755/+subscriptions
>>
>
> -- IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy
> the information in any medium. Thank you.
>
> ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2557590
> ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2548782
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: ARM, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1042755
>
> Title:
> TC2: powertop doesn't show correct frequency stats
>
> Status in Linaro Android:
> New
> Status in Linaro ARM Landing Team Project:
> Won't Fix
>
> Bug description:
> On TC2 running Android, powertop always shows Frequency stats claiming
> all cores are spending 100% of there time in idle.
>
> Observed in the 12.08 release...
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/1042755/+subscriptions

Amit Kucheria (amitk) wrote :

Tixy: IIUC, You have only tested with the 13.09-RC LEB which contains the linux-linaro kernel. So a few follow up questions to make sure we're using the right kernels and images to reproduce:

1. Doesn't ARM supply forward-ported b.L MP patchsets for inclusion in linux-linaro anymore?
2. Does this occur on the LSK releases which do contain MP?

Ryan Harkin (ryanharkin) wrote :

This bug was marked "won't fix" in the "linaro-landing-team-arm" project, however, that project has been deleted so we are unable to change the status to "in progress".

Instead, I've removed the project and assigned the Android team defect to the landing team.

I hope that clears up some confusion about this defect.

We agreed with Andrew Pickard that we would investigate this issue during 13.09 and work out if it really is a problem and where the problem seems to be. Then we will be in a position to agree with Andrew what should do about it. So that's why Tixy has been updating the defect with new information.

Changed in linaro-android:
assignee: nobody → Linaro Landing Team: ARM (linaro-landing-team-arm)
no longer affects: linaro-landing-team-arm
Changed in linaro-android:
status: New → In Progress
Ryan Harkin (ryanharkin) wrote :

Amit,

To answer your questions:
Q1. Doesn't ARM supply forward-ported b.L MP patchsets for inclusion in linux-linaro anymore?
A2. No, MP has been removed from linux-linaro from 13.09 onwards

Q2. Does this occur on the LSK releases which do contain MP?
A2. Yes, I've just tested LSK 13.08 (which is essentially the same as 13.09) and it shows 100% idle

Amit Kucheria (amitk) wrote :

OK. Shaojie on our end will look into this too.

Tixy (Jon Medhurst) (tixy) wrote :

I have a few observations...

Running powertop with the default console output, all the CPUs and power states are far too long to show, and so these are trucate to the first 2 CPUs, these are the A15s, and if the system isn't doing anything other than running powertop, then with MP we would _expect_ to see those cores very close or at 100% idle. However, after making sure the system is busy by taking Android out of the lock screen and having the Linaro animated walpaer going, then I still see 100% idle, even though the power LEDs show the A15 CPUs running intermitently at high frequency.

To see an untrucated report of what powertop prodes I got a HTML report for 10seconds of activity using 'powertop --time=10 --html', I've attached what I get with this. One thing to note, is that as well as the 'CPU Frequency' tab showing 100% idle for Package 0 (the A15s) there is also an anomaly in the frequency stats for Package 1 where it gets an entry for 1200 MHz (that package can only go up to 1000Mhz). One hypothesis is that the frequency statistics for Package 0 is being credited to the Package 1.

Tixy (Jon Medhurst) (tixy) wrote :

Here's the attachment referred to in my previous comment...

Tixy (Jon Medhurst) (tixy) wrote :

I've found the cause of this bug: for cpu_frequency events, perf_power_bundle::handle_trace_point() is always being called with the same cpunr, one of the A7 cores but sometimes different between boots - I think this is the CPU running a workqueue or something which is generating the trace. The trace event themselves have a cpu_id field to say to which CPU event it relates, we should use that, this is what the attached patch does and fixes this bug.

Note, other trace events handled by this function also potentially suffer from the same problem, however, we may have been lucky if they are generated from the same cpu that the event corresponds to.

Tixy (Jon Medhurst) (tixy) wrote :

Discussed on upstream mailing lists in this thread:
https://lists.01.org/pipermail/powertop/2013-October/000959.html

Seems the final fix applied upstream is https://github.com/fenrus75/powertop/commit/af8431eb0062f9f785ec593f2e6747c75089962d

Not yet applied to Linaro's version.

shaojie.sun (shaojie-sun) wrote :

Hi sanjay.
    Please merge this patch. Thanks.

On Thu, Oct 10, 2013 at 4:58 PM, Tixy (Jon Medhurst)
<email address hidden> wrote:
> Discussed on upstream mailing lists in this thread:
> https://lists.01.org/pipermail/powertop/2013-October/000959.html
>
> Seems the final fix applied upstream is
> https://github.com/fenrus75/powertop/commit/af8431eb0062f9f785ec593f2e6747c75089962d
>
> Not yet applied to Linaro's version.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1042755
>
> Title:
> TC2: powertop doesn't show correct frequency stats
>
> Status in Linaro Android:
> In Progress
>
> Bug description:
> On TC2 running Android, powertop always shows Frequency stats claiming
> all cores are spending 100% of there time in idle.
>
> Observed in the 12.08 release...
> https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/1042755/+subscriptions

Tixy (Jon Medhurst) (tixy) wrote :

The fix is now in the git repository used by Linaro's Android builds [1] and so will find it's way into the 13.10 Android releases.
[1] http://android.git.linaro.org/gitweb?p=platform/external/powertop-2.0.git;a=commit;h=ab1706a4a9299f08cde121b161b4ff69b4c9c2e9

Done, the patch is merged. Thanks Tixy for verifying.

Ryan Harkin (ryanharkin) on 2013-10-17
Changed in linaro-android:
status: In Progress → Fix Committed
vishal (vishalbhoj) on 2013-10-30
Changed in linaro-android:
importance: Undecided → Medium
milestone: none → 13.10
Amit Kucheria (amitk) on 2013-11-04
Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers