Email can't safely connect to server on Origen Jelly Bean.

Bug #1035275 reported by Botao on 2012-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Undecided
Unassigned

Bug Description

On Samsung Origen board with Linaro Jelly Bean build:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=18

After added a Gmail address & filled password in Email app, click Next button, I got following error:

Couldn't finish
Can't safely connect to server.
(com.android.org.bouncycastle.jce.exception.
ExtCertPathValidatorException: Could not validate certificate:
current time: Sat Jan 01 00:34:23 GMT 2000, validation time: Mon
Jun 08 20:43:27 GMT 2009)

Network works well:

130|root@android:/ # busybox ping www.google.com
PING www.google.com (74.125.237.115): 56 data bytes
64 bytes from 74.125.237.115: seq=0 ttl=51 time=33.747 ms
64 bytes from 74.125.237.115: seq=1 ttl=51 time=218.991 ms
64 bytes from 74.125.237.115: seq=2 ttl=51 time=133.093 ms
^C
--- www.google.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 33.747/128.610/218.991 ms
root@android:/ #

Botao (botao-sun) on 2012-08-10
description: updated
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :
Download full text (9.1 KiB)

On Samsung Origen board with Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=33

Email app simply crashed after filled account & password and clicked "Next" button. It shows:

Unfortunately, Email has stopped.

Here is what I got in logcat output:

I/ActivityManager( 2525): START {flg=0x2000000 cmp=com.android.email/.activity.setup.AccountSetupBasics (has extr8
I/ActivityManager( 2525): Displayed com.android.email/.activity.Welcome: +487ms
I/ActivityManager( 2525): Displayed com.android.email/.activity.setup.AccountSetupBasics: +282ms
W/ActivityManager( 2525): Duplicate finish request for ActivityRecord{a6aa99c0 com.android.email/.activity.Welcom}
D/dalvikvm( 2828): GC_CONCURRENT freed 199K, 10% free 5727K/6343K, paused 14ms+7ms, total 56ms
D/InputEventConsistencyVerifier( 2828): KeyEvent: ACTION_UP but key was not down.
D/InputEventConsistencyVerifier( 2828): in android.widget.TableRow@a6976300
D/InputEventConsistencyVerifier( 2828): 0: sent at 339386000000, KeyEvent { action=ACTION_UP, keyCode=KEYCODE_T}
D/Email ( 2828): Begin check of incoming email settings
W/dalvikvm( 2828): threadid=14: thread exiting with uncaught exception (group=0xa637e300)
E/AndroidRuntime( 2828): FATAL EXCEPTION: AsyncTask #3
E/AndroidRuntime( 2828): java.lang.RuntimeException: An error occured while executing doInBackground()
E/AndroidRuntime( 2828): at android.os.AsyncTask$3.done(AsyncTask.java:299)
E/AndroidRuntime( 2828): at java.util.concurrent.FutureTask$Sync.innerSetException(FutureTask.java:273)
E/AndroidRuntime( 2828): at java.util.concurrent.FutureTask.setException(FutureTask.java:124)
E/AndroidRuntime( 2828): at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:307)
E/AndroidRuntime( 2828): at java.util.concurrent.FutureTask.run(FutureTask.java:137)
E/AndroidRuntime( 2828): at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1076)
E/AndroidRuntime( 2828): at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:569)
E/AndroidRuntime( 2828): at java.lang.Thread.run(Thread.java:856)
E/AndroidRuntime( 2828): Caused by: java.lang.IllegalArgumentException: sockaddrToInetAddress bad ss_family: 15152
E/AndroidRuntime( 2828): at libcore.io.Posix.getaddrinfo(Native Method)
E/AndroidRuntime( 2828): at libcore.io.ForwardingOs.getaddrinfo(ForwardingOs.java:55)
E/AndroidRuntime( 2828): at java.net.InetAddress.lookupHostByName(InetAddress.java:405)
E/AndroidRuntime( 2828): at java.net.InetAddress.getAllByNameImpl(InetAddress.java:236)
E/AndroidRuntime( 2828): at java.net.InetAddress.getByName(InetAddress.java:289)
E/AndroidRuntime( 2828): at java.net.InetSocketAddress.<init>(InetSocketAddress.java:105)
E/AndroidRuntime( 2828): at java.net.InetSocketAddress.<init>(InetSocketAddress.java:90)
E/AndroidRuntime( 2828): at com.android.email.mail.transport.MailTransport.open(MailTransport.java:168)
E/AndroidRuntime( 2828): at com.android.email.mail.store.ImapConnection.open(ImapConnection.java:109)
E/AndroidRuntime( 2...

Read more...

Botao (botao-sun) wrote :

Email now works well on Samsung Origen board with Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=47

Changed in linaro-android:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers