Panda android boots with "Unfortunately, Gallery has stopped" message" appear on first boot- Android kitkat.

Bug #1033911 reported by Amit Khare on 2012-08-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
Unassigned

Bug Description

Observed with panda jellybean build

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=16

Panda board boots with "Unfortunately, Gallery has stopped" message

Also observed with following images:

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=23

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=28

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=38

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=40

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=44

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=49

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=70

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=69

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=75

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=82

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=100

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=106

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=115

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=161

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=168

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=174

https://android-build.linaro.org/builds/~linaro-android-archive/panda-jb-gcc47-tilt-tracking-blob/#build=186

https://android-build.linaro.org/builds/~linaro-android-archive/panda-jb-gcc47-tilt-tracking-blob/#build=191

https://android-build.linaro.org/builds/~linaro-android-archive/panda-jb-gcc47-tilt-tracking-blob/#build=196

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.03-release/

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-13.05-release/#build=2

Amit Khare (amit-khare) wrote :

Also observed with panda JB android bild
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=28

and sdcard is not mounted

root@android:/data # df
Filesystem Size Used Free Blksize
/dev 474M 68K 474M 4096
/mnt/asec 474M 0K 474M 4096
/mnt/obb 474M 0K 474M 4096
/system 509M 351M 158M 4096
/cache 253M 15M 237M 1024
/data 508M 76M 432M 1024

Paul Larson (pwlars) on 2012-08-22
Changed in linaro-android:
importance: Undecided → Medium
milestone: none → 12.08
assignee: nobody → Linaro Android Team (linaro-android)
Zach Pfeffer (pfefferz) on 2012-08-28
Changed in linaro-android:
milestone: 12.08 → none
Zach Pfeffer (pfefferz) on 2012-09-04
Changed in linaro-android:
milestone: none → 12.09
assignee: Linaro Android Team (linaro-android) → Amit Pundir (pundiramit)
Amit Khare (amit-khare) wrote :

observed with panda JB tracking-blob build
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=44

Apart from this message "Unfortunately, Gallery has stopped" i also see some issues on serial console while the device is booting.

[ 17.126708] (stk) :ldisc installation timeout
[ 17.131408] (stk) :ldisc_install = 0
[ 18.134552] (stk) : timed out waiting for ldisc to be un-installed
[ 18.150451] Bluetooth: st_register failed -22
[ 38.463073] warning: `zygote' uses 32-bit capabilities (legacy support in us)
[ 55.075592] init: no such service 'dhcpcd_sit0'
[ 60.085083] init: no such service 'dhcpcd_sit0:-h android-7d0330245a910171 s'

Amit Khare (amit-khare) wrote :

observed with panda JB tracking-blob build
https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=49

Same behavior observed as comment #5

Yongqin Liu (liuyq0307) wrote :

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-stable-blob/#build=70 also has the problem.
logcat-stable-70.log is the logcat information

Zach Pfeffer (pfefferz) on 2012-09-24
Changed in linaro-android:
assignee: Amit Pundir (pundiramit) → Yongqin Liu (liuyq0307)
milestone: 12.09 → 12.10
Zach Pfeffer (pfefferz) on 2012-09-25
Changed in linaro-android:
milestone: 12.10 → backlog
assignee: Yongqin Liu (liuyq0307) → nobody
Yongqin Liu (liuyq0307) wrote :

logcat information for jp-panda-tracking-66, seems the same as stable build

Amit Khare (amit-khare) on 2012-10-07
description: updated
Amit Khare (amit-khare) on 2012-10-08
description: updated
Amit Khare (amit-khare) on 2012-10-15
description: updated
description: updated
description: updated
description: updated
Fathi Boudra (fboudra) on 2012-12-03
Changed in linaro-android:
milestone: backlog → none
status: New → Triaged
Soumya Basak (soumya-basak) wrote :

observed with Linaro panda android jb builds

https://android-build.linaro.org/builds/~linaro-android/panda-jb-gcc47-tilt-tracking-blob/#build=127

1. the pop-up message " Unfortunately, Gallery has stopped" appear, apart from that display resolution is not proper on HDMI monitor.

2. kernel panic occour on system boot phase and system crashes.

log file attached.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
summary: Panda android JB boots with "Unfortunately, Gallery has stopped"
- message"
+ message" appear on first boot
description: updated
summary: - Panda android JB boots with "Unfortunately, Gallery has stopped"
- message" appear on first boot
+ Panda android boots with "Unfortunately, Gallery has stopped" message"
+ appear on first boot- Android kitkat.
Soumya Basak (soumya-basak) wrote :

the issue is not reproduced again on panda with Linaro Android kitkat builds:

https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro-14.02-release/#build=11

"Unfortunately, Gallery has stopped" message not appear again.

the issue is fixed.

Changed in linaro-android:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers