HDMI doesn't work on Samsung Origen board with Linaro Android JB image.

Bug #1021156 reported by Botao on 2012-07-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
High
Fahad Kunnathadi
linaro-landing-team-samsung
Fix Released
Medium
Tushar Behera

Bug Description

For Samsung Origen board, plug out the LCD module, then plug in the Mini HDMI to HDMI cable to connect to a monitor, no display shows up.

Observed on image:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.06-release/#build=2

Please refer to attachment to find full serial output.

########################################################
This issue is observed on following images:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.06-release/#build=2

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=78

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=82

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=5

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=18

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=25

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=33

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob-12.08-release/#build=1

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=47

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob/#build=7

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob/#build=12

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob-12.09-release/#build=3

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob/#build=26

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob/#build=31

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob/#build=37

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob-12.10-release/#build=1

Botao (botao-sun) wrote :
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

Also observed on Origen Jelly Bean build:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=5

Now monitor can't detect any signal at all. Please refer to attachment to get serial console boot log.

Changed in linaro-landing-team-samsung:
assignee: nobody → Tushar Behera (tusharbehera)
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

Now Origen board simply hangs after switch to HDMI display. Observed on Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob-12.08-release/#build=1

Please refer to attachment to get detailed log output.

Botao (botao-sun) wrote :

Same behaviour observed as initial bug description on Samsung Origen board with Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-stable-blob/#build=47

No display comes out from HDMI although system doesn't hang any more.

Tushar Behera (tusharbehera) wrote :

Driver support is provided in the kernel. Need to add HAL layer code for JB.

Changed in linaro-landing-team-samsung:
status: New → Confirmed
Botao (botao-sun) wrote :

Also observed on Samsung Origen board with Linaro Jelly Bean tracking build:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob/#build=7

Zach Pfeffer (pfefferz) on 2012-09-11
Changed in linaro-android:
assignee: nobody → fahadkdi (fahad-k)
milestone: none → 12.10
importance: Undecided → High
summary: - HDMI doesn't work on Samsung Origen board with Linaro Android image.
+ HDMI doesn't work on Samsung Origen board with Linaro Android JB image.
Changed in linaro-landing-team-samsung:
importance: Undecided → Medium
Botao (botao-sun) on 2012-09-18
description: updated
Botao (botao-sun) on 2012-09-26
description: updated
Fahad Kunnathadi (fahad-k) wrote :

Done Vendor source integration.
After integrating vendor source, and HDMI enabling code in JB, HDMI works on HDMI TV connected.
With kernel 3.4 .

When the Kernel is update to 3.6 or kernel tracking HDMI stops working.There is some issue in after kernel 3.5 rc.
which is propogated from the same bug in ICS ,
https://bugs.launchpad.net/linaro-landing-team-samsung/+bug/1050336
So origen board hangs, because of a V4L Bug.

Botao (botao-sun) on 2012-10-04
description: updated
Botao (botao-sun) on 2012-10-10
description: updated
Changed in linaro-android:
status: New → Fix Committed
Botao (botao-sun) on 2012-10-16
description: updated
Zach Pfeffer (pfefferz) on 2012-10-16
Changed in linaro-android:
status: Fix Committed → In Progress
Botao (botao-sun) wrote :

Unfortunately this feature still doesn't work on Linaro Android 12.10 release candidate. Please refer to attachment to get serial log output. It always show "unplugged" & "plugged", the monitor is black screen.

Observed on:

https://android-build.linaro.org/builds/~linaro-android/origen-jb-gcc47-samsunglt-tracking-blob-12.10-release/#build=1

description: updated
vishal (vishalbhoj) wrote :

Botao,

HDMI works for me on 12.10 RC build #1 and this patch has been tested on Origen by Fahad. Can you please give a try once again.

Changed in linaro-android:
status: In Progress → Fix Released
Botao (botao-sun) wrote :

@Vishal, I tried twice yesterday, it didn't work on my board - the old Origen one. Since the Mini HDMI never works on my board, then perhaps we can check this issue when we meet next week.

Changed in linaro-landing-team-samsung:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers