Some builds fail due to gitweb being down

Bug #1025311 reported by Zygmunt Krynicki on 2012-07-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android Infrastructure
Fix Released
High
Paul Sokolovsky

Bug Description

My recent builds are failing on repo init.

See: https://android-build.linaro.org/jenkins/job/linaro-android_panda-ics-gcc47-tilt-tracking-blob/126/console

+ repo init -u git://android.git.linaro.org/platform/manifest.git -b linaro_android_4.0.4 -m tracking-panda.xml --repo-url=git://android.git.linaro.org/tools/repo.git --reference=/mnt/jenkins/workspace/linaro-android_panda-ics-gcc47-tilt-tracking-blob/build/uniseed
/usr/local/bin/repo: line 1: syntax error near unexpected token `<'
/usr/local/bin/repo: line 1: `<html><head><title>Gitweb down temporarily</title></head><body>gitweb is currently unavailable until we finish importing jellybean</body></html>'
++ infrastructure_error
++ echo 'Caught infrastructure error - finishing build with '\''Not Built'\'' status'
Caught infrastructure error - finishing build with 'Not Built' status
++ exit 123

Changed in linaro-android-infrastructure:
status: New → Confirmed
Zygmunt Krynicki (zyga) on 2012-07-16
no longer affects: linaro-android
Changed in linaro-android-infrastructure:
importance: Undecided → Critical
assignee: nobody → Paul Sokolovsky (pfalcon)
Paul Sokolovsky (pfalcon) wrote :

Ok, so what happened here is: we're getting "repo" initial binary from our servers, not google's (because they can be down any time). To get it, we use wget and download it from gitweb, because git doesn't allow to check out a single file from a repo (and because original google instructions also use wget, so we chaneg just URL, nothing else). Now, that gitweb was put down and replaced with a static page, we get that static page and trying to access, getting the error above.

More interesting question is though why this occurred just yesterday, while gitweb was disabled last week. It turned out that "linaro-android_panda-ics-gcc47-tilt-tracking-blob" job had it's "labels" field in Jenkins config set to wrong value, which caused old build slave type to selected for it, uncovering the issue as described above. All other jobs use custom AMI build slave, which has correct "repo" preinstalled and thus not susceptible to gitweb being down.

linaro-android_panda-ics-gcc47-tilt-tracking-blob was fixed, and it was checked that no other job has that issue.

What's left is probably to remove old non-custom AMI build slave types, because their presence leads to confusion now.

Changed in linaro-android-infrastructure:
status: Confirmed → In Progress
Paul Sokolovsky (pfalcon) wrote :

Ok, unneeded build slave types were removed.

Changed in linaro-android-infrastructure:
status: In Progress → Fix Committed
importance: Critical → High
Changed in linaro-android-infrastructure:
status: Fix Committed → Fix Released
Paul Sokolovsky (pfalcon) wrote :

Ok, we now have the same issue for restricted builds, because they're unconverted to custom AMIs:

https://android-build.linaro.org/jenkins/job/linaro-android-restricted_vexpress-rtsm-isw-ics-gcc47-armlt-stable-open/80/console

Changed in linaro-android-infrastructure:
status: Fix Released → In Progress
Paul Sokolovsky (pfalcon) wrote :
Changed in linaro-android-infrastructure:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers