spatialite tests fail on AArch64

Bug #1284199 reported by Matthias Klose on 2014-02-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro AArch64 cross-distro work
Undecided
Unassigned
spatialite (Ubuntu)
Undecided
Unassigned

Bug Description

https://launchpad.net/ubuntu/+source/spatialite/4.1.1-5/+build/5633785

make check-TESTS
make[5]: Entering directory `/build/buildd/spatialite-4.1.1/test'
make[6]: Entering directory `/build/buildd/spatialite-4.1.1/test'
PASS: check_endian
PASS: check_version
PASS: check_init
PASS: check_init2
PASS: check_geom_aux
PASS: check_geometry_cols
PASS: check_create
PASS: check_bufovflw
../test-driver: line 107: 11435 Segmentation fault "$@" > $log_file 2>&1
FAIL: check_fdo1
PASS: check_fdo2
../test-driver: line 107: 11485 Segmentation fault "$@" > $log_file 2>&1
FAIL: check_fdo3
PASS: check_fdo_bufovflw
PASS: check_md5
PASS: check_dbf_load
PASS: check_shp_load
PASS: check_shp_load_3d
PASS: shape_cp1252
PASS: shape_primitives
PASS: shape_utf8_1
PASS: shape_utf8_1ex
PASS: shape_utf8_2
PASS: shape_3d
PASS: check_xls_load
PASS: check_math_funcs
PASS: check_gaia_util
PASS: check_gaia_utf8
PASS: check_extension
PASS: check_recover_geom
../test-driver: line 107: 11923 Segmentation fault "$@" > $log_file 2>&1
FAIL: check_sql_stmt
PASS: check_virtualtable1
PASS: check_virtualtable2
PASS: check_virtualtable3
PASS: check_virtualtable4
PASS: check_virtualtable5
PASS: check_virtualtable6
PASS: check_virtual_ovflw
PASS: check_mbrcache
PASS: check_spatialindex
PASS: check_exif
PASS: check_exif2
../test-driver: line 107: 12217 Segmentation fault "$@" > $log_file 2>&1
FAIL: check_relations_fncts
PASS: check_extra_relations_fncts
PASS: check_geoscvt_fncts
PASS: check_libxml2
PASS: check_styling
PASS: check_virtualxpath
PASS: check_wfsin
../test-driver: line 107: 12385 Segmentation fault "$@" > $log_file 2>&1
FAIL: check_dxf
make[7]: Entering directory `/build/buildd/spatialite-4.1.1/test'
Making all in sql_stmt_geosadvanced_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_geosadvanced_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_geosadvanced_tests'
Making all in sql_stmt_geos_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_geos_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_geos_tests'
Making all in sql_stmt_geostrunk_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_geostrunk_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_geostrunk_tests'
Making all in sql_stmt_libxml2_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_libxml2_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_libxml2_tests'
Making all in sql_stmt_lwgeom_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_lwgeom_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_lwgeom_tests'
Making all in sql_stmt_mathsql_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_mathsql_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_mathsql_tests'
Making all in sql_stmt_proj_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_proj_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_proj_tests'
Making all in sql_stmt_security_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_security_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_security_tests'
Making all in sql_stmt_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_tests'
Making all in sql_stmt_xmlsec_tests
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_xmlsec_tests'
make[8]: Nothing to be done for `all'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test/sql_stmt_xmlsec_tests'
make[8]: Entering directory `/build/buildd/spatialite-4.1.1/test'
make[8]: Nothing to be done for `all-am'.
make[8]: Leaving directory `/build/buildd/spatialite-4.1.1/test'
make[7]: Leaving directory `/build/buildd/spatialite-4.1.1/test'
============================================================================
Testsuite summary for libspatialite 4.1.1
============================================================================
# TOTAL: 48
# PASS: 43
# SKIP: 0
# XFAIL: 0
# FAIL: 5
# XPASS: 0
# ERROR: 0
============================================================================
See test/test-suite.log
Please report to <email address hidden>

Matthias Klose (doko) on 2014-02-24
Changed in spatialite (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package spatialite - 4.1.1-5ubuntu1

---------------
spatialite (4.1.1-5ubuntu1) trusty; urgency=medium

  * Ignore test results on arm64. See LP: #1284199.
 -- Matthias Klose <email address hidden> Wed, 26 Feb 2014 12:31:05 +0100

Changed in spatialite (Ubuntu):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

ignored the test failures on arm64, still an issue

Changed in spatialite (Ubuntu):
status: Fix Released → Confirmed
Bas Couwenberg (sebastic) wrote :

Test failures are ignored for all architectures for some time now, and since 4.4.0 the tests are no longer executed in parallel resolving the related failures.

Changed in spatialite (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers