makedumpfile needs porting for AArch64

Bug #1238110 reported by Matthias Klose on 2013-10-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro AArch64 cross-distro work
Undecided
Unassigned
makedumpfile (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
dann frazier

Bug Description

[Impact]
kdump-tools is not installable on arm64 because it depends on makedumpfile, which is not currently built on arm64. Adding arm64 to the Architecture list in debian/control is all that is needed for it to build successfully.

That said, xenial's version was too old to support filtering kdump-enabled xenial kernels (>= 4.10.0). So, this doesn't actually produce a *useful* makedumpfile, but does allow kdump-tools to be installed, which unblocks collection of (unfiltered) crash dump files.

[Test Case]
On an arm64 system:
 sudo apt install kdump-tools

[Regression Risk]
The only change here is to make a binary package available on arm64 that previously was not - regression risk to existing architectures should therefore be negligible.

Note: Enabling a binary package for an architecture where it's known not to be useful - at last on it's own - is obviously non-ideal. I considered other options, but they all seem to add unnecessary regression risk:

- Demoting the "Depends:" to a "Recommends:". I actually think we should do this going forward (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=865701), but this would be a change in behavior to people who may install kdump-tools w/ Recommends-disabled and expect to stil get makedumpfile.

- Demoting only on arm64: This isn't possible unless we switch kdump-tools from Binary: any to Binary: all. I also think there are good reasons to do that in future releases (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=863858), but it seems overkill for just enabling arm64.

Matthias Klose (doko) on 2013-10-10
tags: added: arm64
Changed in makedumpfile (Ubuntu):
status: New → Confirmed
tags: added: ftbfs
Vicamo Yang (vicamo) wrote :

As today's version 1.5.9-5ubuntu0.1, there is already arch/arm64.c available, but it's still not included in debian/control. It does build in my arm64 docker env, haven't tried yet.

Vicamo Yang (vicamo) wrote :

https://bugzilla.redhat.com/show_bug.cgi?id=925630 "Kernel support for kexec and kprobes has landed upstream in the 4.8 kernel".

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.0-2ubuntu1

---------------
makedumpfile (1:1.6.0-2ubuntu1) yakkety; urgency=medium

  * Build on arm64. LP: #1238110.

 -- Matthias Klose <email address hidden> Thu, 06 Oct 2016 11:44:32 +0200

Changed in makedumpfile (Ubuntu):
status: Confirmed → Fix Released
dann frazier (dannf) on 2017-07-17
Changed in makedumpfile (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → dann frazier (dannf)
description: updated

Hello Matthias, or anyone else affected,

Accepted makedumpfile into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.5.9-5ubuntu0.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in makedumpfile (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.