xorg-cf needs porting

Bug #1137510 reported by Dirk Mueller on 2013-03-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro AArch64 cross-distro work
Low
Unassigned
X.Org X server
Fix Released
Medium
imake (Fedora)
Fix Released
Undecided
xutils-dev (Debian)
New
Undecided
Unassigned
xutils-dev (Ubuntu)
Undecided
Unassigned

Bug Description

imake based apps are all failing on aarch64 due to missing defines in linux.cf and imake.cf of xorg.org's cf module.

http://cgit.freedesktop.org/xorg/util/cf/log/

Dirk Mueller (dmllr) wrote :

Initial patch at http://pastebin.com/E4RBQzdN

this seems to be enough to get the most simple imake app compiling.

Riku Voipio (riku-voipio) wrote :

What software is still using imake for builds?

Dirk Mueller (dmllr) wrote :

mostly all the xorg.org related software (X11 and tools). on openSUSE it is used in the build environment of 811 packages. not that much anymore, but also not neglectible.

Riku Voipio (riku-voipio) wrote :

I am surprised as xorg in openembedded and debian don't seem to use imake. But yes we should submit this patch to xorg.

Created attachment 78328
Add Aarch64 defines

Imake doesn't know about Aarch64, the attached patch adds the needed bits. Originally reported at:

https://bugs.launchpad.net/linaro-aarch64/+bug/1137510

Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linaro-aarch64:
importance: Undecided → Low
status: New → In Progress

Created attachment 751714
aarch64 bits for imake

Description of problem:
imake is missing some aarch64-specific bits which is leading to some package building failures. Patch attached.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Thanks for the patch, pushed to git master:

To ssh://git.freedesktop.org/git/xorg/util/cf
   6630dfc..0d1be73 master -> master

Changed in xorg-server:
status: Confirmed → Fix Released
Changed in linaro-aarch64:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xutils-dev - 1:7.7~1ubuntu4

---------------
xutils-dev (1:7.7~1ubuntu4) saucy; urgency=low

  * Add missing defines in the xorg-cf-files. LP: #1137510.
 -- Matthias Klose <email address hidden> Tue, 30 Jul 2013 16:37:39 +0200

Changed in xutils-dev (Ubuntu):
status: New → Fix Released
Matthias Klose (doko) wrote :

with this patch, I still see nas failing to build:

make[3]: Entering directory `/home/ubuntu/nas-1.9.3/server/dia'
rm -f dispatch.o
gcc -c DefaultGcc2AArch64Opt -g -O2 -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -I. -I../include -I../../include -I../../lib/audio -I../../include -Dlinux -D__aarch64__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-DFUNCPROTO=15 -DNARROWPROTO -DNASCONFSEARCHPATH=\"/etc/nas/\" dispatch.c
gcc-4.7.real: error: DefaultGcc2AArch64Opt: No such file or directory
make[3]: *** [dispatch.o] Error 1
make[3]: Leaving directory `/home/ubuntu/nas-1.9.3/server/dia'
make[2]: *** [dia] Error 2

fail to see yet, why it is undefined, and not expanded.

Changed in xutils-dev (Ubuntu):
status: Fix Released → New
Changed in linaro-aarch64:
status: Fix Committed → New
Changed in linaro-aarch64:
status: New → Fix Released
Marcin Juszkiewicz (hrw) wrote :

I am building x3270 for AArch64. Patched imake with patch from this bug and now I have same issue as Matthias:

DEBUG: gcc DefaultGcc2AArch64Opt -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -grecord-gcc-switches -fno-stack-protector -I/usr/include -Dlinux -D__aarch64__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DFUNCPROTO=15 -DNARROWPROTO -DUSE_APP_DEFAULTS -D_POSIX_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE -DLIBX3270DIR=\"/usr/share/x3270\" -c -o CmplxMenu.o CmplxMenu.c
DEBUG: gcc: error: DefaultGcc2AArch64Opt: No such file or directory
DEBUG: make: *** [CmeBSB.o] Error 1

Riku Voipio (riku-voipio) wrote :

Hi Marcin,

Try the attached patch (on top of latest upstream). This defines DefaultGcc2AArch64Opt in xorg.cf . linux.cf includes xorg.cf rather than xfree86.cf where this was defined in the original patch.
'

Riku Voipio (riku-voipio) wrote :

Alternatively we could just skip defining and using DefaultGcc2AArch64Opt at all, it seems only used if the arch needs special optimization parameters (which we don't)

Changed in linaro-aarch64:
status: Fix Released → In Progress
Marcin Juszkiewicz (hrw) wrote :

Riku: this patch fixes issue.

The attachment "Define DefaultGcc2AArch64Opt in xorg.cf" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

Sorry, it seems the original patch was incomplete. While some distros use xfree86.cf, others take xorg.cf

Created attachment 90233
add DefaultGcc2AArch64Opt to xorg.cf

This is on top of the already accepted patch. Alternative would be just remove all references to DefaultGcc2AArch64Opt, since there is nothing unique about aarch64 optimization options.

Created attachment 833559
complete fix

This patch contains upstream fix + fix to the fix.

Changed in xorg-server:
status: Fix Released → Confirmed

Actually, any distro using xfree86.cf is either still using XFree86 and
not these files, or has patched it locally - either case it's a waste
of time to update our copy.

I've gone ahead and pushed this additional patch to git, since no one cares
enough to clean out the crud in the imake config files given how little used
they are these days since the mass migration to autotools.

Created attachment 837693
Patch with backports from upstream

Patches are same as in previous fix but this time they are cherry-picked from upstream git repository as they landed there.

Upgrading xorg-cf-files to 1.0.5 allows to kill imake-backport-aarch64-1.patch as it was integrated before release.

Changed in xorg-server:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

we've had this since 1:7.7+2

Changed in xutils-dev (Ubuntu):
status: New → Fix Released
Changed in imake (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.