Registry keys protected by ACL not being removed

Bug #520849 reported by QsecofrTM on 2010-02-12
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Little Registry Cleaner
Medium
Nick

Bug Description

There are same missing CLSID-s which are not removable by program, they are every time system is scanning:
Little Registry Cleaner 1.4
Website: http://sourceforge.net/projects/littlecleaner
Microsoft Windows NT 6.1.7600.0

Started scan at 2010-02-12 09:27:48

Starting scanning: Pliki startowe
Checking for invalid files in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
Checking for invalid files in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
Checking for invalid files in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\RunServicesOnce
Checking for invalid files in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\RunServices
Checking for invalid files in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
Checking for invalid files in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
Checking for invalid files in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunServicesOnce
Checking for invalid files in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunServices
Checking for invalid files in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce
Checking for invalid files in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
Finished scanning: Pliki startowe

Starting scanning: Współdzielone biblioteki DLL
Scanning for missing shared DLLs
Finished scanning: Współdzielone biblioteki DLL

Starting scanning: Czcionki systemowe
Scanning for invalid fonts
Finished scanning: Czcionki systemowe

Starting scanning: Informacje o programach
Verifying programs in Add/Remove list
Verifying registry entries in Add/Remove Cache
Finished scanning: Informacje o programach

Starting scanning: Ścieżki aplikacji
Checking for invalid installer folders
Checking for invalid application paths
Finished scanning: Ścieżki aplikacji

Starting scanning: ActiveX / COM Objects
Scanning HKEY_CLASSES_ROOT\CLSID for invalid CLSID's
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID for invalid CLSID's
Scanning HKEY_CLASSES_ROOT\Wow6432Node\CLSID for invalid CLSID's
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID for invalid CLSID's
Scanning HKEY_CLASSES_ROOT for invalid Classes
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_CLASSES_ROOT\ehGLID.GLIDPlugInUDCR"
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_CLASSES_ROOT\ehGLID.GLIDPlugInUDCR.1"
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes for invalid Classes
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ehGLID.GLIDPlugInUDCR"
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ehGLID.GLIDPlugInUDCR.1"
Scanning HKEY_CURRENT_USER\SOFTWARE\Classes for invalid Classes
Scanning HKEY_CLASSES_ROOT\Wow6432Node for invalid Classes
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes for invalid Classes
Scanning HKEY_CLASSES_ROOT\AppID for invalid AppID's
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID for invalid AppID's
Scanning HKEY_CLASSES_ROOT\Wow6432Node\AppID for invalid AppID's
Checking for invalid browser helper objects
Checking for invalid explorer toolbars
Checking for invalid explorer extensions
Checking for invalid explorer file extensions
Finished scanning: ActiveX / COM Objects

Starting scanning: Sterowniki systemowe
Scanning for missing drivers
Finished scanning: Sterowniki systemowe

Starting scanning: Pliki Pomocy systemu Windows
Checking for missing help files in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\HTML Help
Finished scanning: Pliki Pomocy systemu Windows

Starting scanning: Dźwięki systemu Windows
Scanning for missing sound events
Finished scanning: Dźwięki systemu Windows

Starting scanning: Ustawienia aplikacji
Scanning HKEY_LOCAL_MACHINE\SOFTWARE for empty registry keys
Scanning HKEY_CURRENT_USER\SOFTWARE for empty registry keys
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node for empty registry keys
Scanning HKEY_CURRENT_USER\SOFTWARE\Wow6432Node for empty registry keys
Finished scanning: Ustawienia aplikacji

Starting scanning: Ostatnie dokumenty
Cleaning invalid references in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs
Bad Registry Value Found! Problem: "Nieprawidłowy plik lub folder" Path: "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs" Value Name: "9"
Bad Registry Value Found! Problem: "Nieprawidłowy plik lub folder" Path: "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs" Value Name: "87"
Bad Registry Value Found! Problem: "Nieprawidłowy plik lub folder" Path: "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs\.zip" Value Name: "1"
Bad Registry Value Found! Problem: "Nieprawidłowy plik lub folder" Path: "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs\.zip" Value Name: "8"
Finished scanning: Ostatnie dokumenty

Total time elapsed: 20,0871489 seconds
Total problems found: 8
Total objects scanned: 39996

Finished scan at 2010-02-12 09:28:08

Little Registry Cleaner 1.4
Website: http://sourceforge.net/projects/littlecleaner
Microsoft Windows NT 6.1.7600.0

Started scan at 2010-02-12 09:36:27

Starting scanning: ActiveX / COM Objects
Scanning HKEY_CLASSES_ROOT\CLSID for invalid CLSID's
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID for invalid CLSID's
Scanning HKEY_CLASSES_ROOT\Wow6432Node\CLSID for invalid CLSID's
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID for invalid CLSID's
Scanning HKEY_CLASSES_ROOT for invalid Classes
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_CLASSES_ROOT\ehGLID.GLIDPlugInUDCR"
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_CLASSES_ROOT\ehGLID.GLIDPlugInUDCR.1"
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes for invalid Classes
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ehGLID.GLIDPlugInUDCR"
Bad Registry Key Found! Problem: "Zaginione CLSID odniesienia" Path: "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ehGLID.GLIDPlugInUDCR.1"
Scanning HKEY_CURRENT_USER\SOFTWARE\Classes for invalid Classes
Scanning HKEY_CLASSES_ROOT\Wow6432Node for invalid Classes
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes for invalid Classes
Scanning HKEY_CLASSES_ROOT\AppID for invalid AppID's
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID for invalid AppID's
Scanning HKEY_CLASSES_ROOT\Wow6432Node\AppID for invalid AppID's
Checking for invalid browser helper objects
Checking for invalid explorer toolbars
Checking for invalid explorer extensions
Checking for invalid explorer file extensions
Finished scanning: ActiveX / COM Objects

Nick (ub3rst4r) on 2010-02-14
Changed in lilregcleaner:
status: New → Confirmed
assignee: nobody → Nick (ub3rst4r)
Nick (ub3rst4r) on 2010-02-16
summary: - Missing CLSID in Win 7 Professional 64
+ Problems are not being removed properly

I have created a blueprint for it to scan during startup. This should help with registry keys that get locked by some programs. If someone would like to start on this that would be great :D

sutra1977 (sutra) wrote :

but my windows is 7600 86x

sutra1977 (sutra) wrote :

... win 7 ultimate 86x

sutra1977 (sutra) wrote :

...how to fix it???

Nick (ub3rst4r) wrote :

I have asked jomy if he could look into it for me. The only other way is to manually remove them by right clicking on the problem and going to 'view in regedit'. Then u will have to edit the permissions so you can remove them. I will be away until next week so there is not much else I can do. Chou

Nick (ub3rst4r) wrote :

I have looked at the code and found that it is not changing the permissions when trying to remove values. Can someone please try the patch to see if this might fix it. If not, then it might be a problem with installed programs. Thanks!

Changed in lilregcleaner:
status: Confirmed → Fix Committed
assignee: Nick (ub3rst4r) → nobody
assignee: nobody → Bongcaivang@netscape.net (tutinhkhuc05)
Curtis Hovey (sinzui) on 2010-02-23
Changed in lilregcleaner:
assignee: Bongcaivang@netscape.net (tutinhkhuc05) → Nick (ub3rst4r)
status: Fix Committed → Confirmed
Nick (ub3rst4r) on 2010-02-24
Changed in lilregcleaner:
importance: Undecided → Medium
status: Confirmed → Fix Committed
Nick (ub3rst4r) on 2010-04-01
Changed in lilregcleaner:
status: Fix Committed → Fix Released
milestone: none → 1.4.1
Nick (ub3rst4r) on 2010-04-11
summary: - Problems are not being removed properly
+ Registry keys protected by ACL not being removed
Changed in lilregcleaner:
status: Fix Released → Confirmed
milestone: 1.4.1 → 1.4.2
Nick (ub3rst4r) wrote :

Log File: http://tinypaste.com/05a6a

I have reopened this bug because it seems that LRC is still not removing keys that are protected, after a user reported to it to me. I suggest that these keys should be ignored because they are possibly protected because they are essential to the system.

Travis Lloyd (t-lloyd) wrote :

This is running me nuts! (And a good number of other people here too, I suspect; if it's happening to us then it's happening to everybody else with our configurations). This bug has apparently been know for months now, without much done in the way of fixing it.
I'm running Dell OEM Windows 7 Professional 32-bit on a new Dell computer and I've had no other problems with the software save for this.
I've gone into the Registry and manually set the permissions to "Everyone" for all of the affected keys over and over again but LRC still won't remove them nor can I do so "by hand".
Please either fix this damnable bug or just give us a patch or some instructions on how we can do it ourselves by hacking the Registry and we'll all be Happy Campers, I assure you. I'm enclosing the log below...
---------------------------------------------------------------------------------------------

Little Registry Cleaner 1.4.1
Website: http://sourceforge.net/projects/littlecleaner
Microsoft Windows NT 6.1.7600.0

Started scan at 6/28/2010 12:10:51 AM

Starting scanning: ActiveX/COM Objects
Scanning HKEY_CLASSES_ROOT\CLSID for invalid CLSID's
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID for invalid CLSID's
Scanning HKEY_CURRENT_USER\SOFTWARE\Classes\CLSID for invalid CLSID's
Scanning HKEY_CLASSES_ROOT for invalid Classes
Bad Registry Key Found! Problem: "Missing CLSID reference" Path: "HKEY_CLASSES_ROOT\ehGLID.GLIDPlugInUDCR"
Bad Registry Key Found! Problem: "Missing CLSID reference" Path: "HKEY_CLASSES_ROOT\ehGLID.GLIDPlugInUDCR.1"
Scanning HKEY_LOCAL_MACHINE\SOFTWARE\Classes for invalid Classes
Bad Registry Key Found! Problem: "Missing CLSID reference" Path: "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ehGLID.GLIDPlugInUDCR"
Bad Registry Key Found! Problem: "Missing CLSID reference" Path: "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ehGLID.GLIDPlugInUDCR.1"

Total time elapsed: 13.8216242 seconds
Total problems found: 4
Total objects scanned: 25888

Finished scan at 6/28/2010 12:11:05 AM
-----------------------------------------------------------------------------------
It simply can't be that big a deal to modify the script so that it removes the necessary permission requirements from these 4 little keys, so please notify us at your earliest convenience when it's fixed, as this bug is really getting to be a Royal Pain the A**! Thank you.

Nick (ub3rst4r) wrote :

Hi Travis, The only way you can remove these is by changing the permissions which is being prevented so I would suggest trying Sysinteral's RegDelNull @ http://technet.microsoft.com/en-ca/sysinternals/bb897448.aspx to try and remove keys with null embedded characters. I am going to have LRC ignore these keys because if you read other forums they all state that it is dangerous to remove these keys because they are used by the system.

- Nick

Nick (ub3rst4r) on 2010-07-19
Changed in lilregcleaner:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Related blueprints