Chromium browser web application Angry Bird has no sound

Bug #807389 reported by Eric on 2011-07-08
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Chromium
New
Undecided
Unassigned
Lightspark
Medium
Unassigned

Bug Description

Play the chrome web store app Angry Bird with lighspark plugin, but no sound
========================================
lightspark verison: 0.5.0-rc1
ubuntu 10.10
linux 2.6.35-28-generic x86_64
========================================
First it will have download voice file error,
and I modify the plugin/plugin.cpp line 500 (change m_sys->setOrigin(stream->url) to m_sys->setOrigin(getPageURL()) )
It can download voice file successfully,
But when call Sound::play , it will throw exception and error

Eric (janhwa-lee) wrote :

CALLS: callProperty [privns:] [pakns:] [privns:] [pakintns:] [staticprotns:Object] [protns:Voices] [staticprotns:Voices] [staticprotns:flash.display:DisplayObject] [staticprotns:flash.display:DisplayObjectContainer] [staticprotns:flash.display:InteractiveObject] [staticprotns:flash.display:Sprite] [staticprotns:flash.events:EventDispatcher] [ns:http://adobe.com/AS3/2006/builtin] play 3
CALLS: flash.media:Sound
ERROR: Error in VM argslen==1 /home/eric/build_flash/build_spark/lightspark-0.5.0~rc1/src/scripting/flashmedia.cpp:305

Changed in lightspark:
status: New → Confirmed
importance: Undecided → Medium

Just noticed this yesterday and it's driving me nuts!!

Changed in chromium:
assignee: nobody → Kyle Hall (pcfreak2)

Steps to repeat:

Go to:
http://chrome.angrybirds.com/

In Chromium

Chris Miles (chrismil-cix) wrote :

After the last two updates (oneric) sound on http://chrome.angrybirds.com in Chromium has stopped. Other HTML5 sound works, flash sound works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers