OpenStreetMap flash editor (Potlatch 2) doesn't work

Reported by enqd on 2010-09-04
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Lightspark
Medium
Unassigned

Bug Description

Hi, the new alpha version of Openstreetmap flash editor (potlatch 2 alpha version) doesn't work with Lighspark.
As Potlatch is a Opensource editor of the important OSM service, I think we should support it.

To test, go here: http://random.dev.openstreetmap.org/potlatch2/potlatch2.html

Obs: The Potlatch version 1 appear to work ok.

Timon Van Overveldt (timonvo) wrote :

Potlatch version 1 is not supported by Lightspark but is run by the gnash fallback.

I'm adding the websitesupport tag to mark this as a request to support Potlatch v2.

tags: added: websitesupport
Changed in lightspark:
status: New → Confirmed

FWIW, it is now live in a newer version at http://www.openstreetmap.org/edit?editor=potlatch2

For reference, on lightspark 0.4.5 the error is "Invalid frame count in Sprite", see https://github.com/lightspark/lightspark/blob/master/parsing/tags.cpp#L399

Jasper St. Pierre (jstpierre) wrote :

A page that doesn't require login would help.

The link in the summary ( i.e. http://random.dev.openstreetmap.org/potlatch2/potlatch2.html ) doesn't require a login. The link in comment #2 just indicates that it's now live on the main openstreetmap.org project pages too.

OK, I just wanted to make sure that the Potlatch SWF at
http://random.dev.openstreetmap.org/potlatch2/potlatch2.swf is up to
date.

Seems it fails with the "Invalid frame count in Sprite" error -- may I
ask what tool you used to author Potlatch? Adobe Flash (CS3? CS4?
CS5?) or Flex?

It's authored using the open-source version of the Flex 3.5 SDK (command line compiler)

Matthias Gehre (m-gehre) wrote :

With rev 1743, I do not see any error, not even on the console, but the SWF does not show any content.
Seems to be related to bug #722870.

With 0.4.8-RC1, I no longer get any error messages shown by lightspark, but instead get a pale blue screen. I've captured the terminal output from running the .swf, and it seems there is a lot of NOT_IMPLEMENTED errors.

NOT_IMPLEMENTED: Multibyte not handled
NOT_IMPLEMENTED: Getter not linkable
NOT_IMPLEMENTED: Setter not linkable
NOT_IMPLEMENTED: Method not linkable
NOT_IMPLEMENTED: We got a Undefined function addEventListener
NOT_IMPLEMENTED: Add buildTraits for class flash.filters:DropShadowFilter
NOT_IMPLEMENTED: We got a Undefined function drawRoundRectComplex on obj type flash.display:Graphics

and more. Full ouput attached.

summary: - Openstreetmap flash editor (potlatch 2 alpha version) doesn't work
+ OpenStreetMap flash editor (Potlatch 2) doesn't work
Changed in lightspark:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers