Lightread should be integrated to the messaging menu

Reported by Bence Lukács on 2012-07-09
110
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Lightread
Low
Unassigned

Bug Description

Lightread should be integrated to the messaging menu in order to easily notice you have unread messages if you use the unity launcher in autohide mode.

consindo (cooperjona) wrote :

Thanks, in the future we'll add this in with a tray icon as well.

Changed in lightread:
importance: Undecided → Low
status: New → Confirmed
Glen (glen-h) wrote :

Lightread should also be able to run in the background in the messaging menu so without the window open you can still see unread messages.

f_padia (f-padia) wrote :

I agree with both suggestions.

Khurshid Alam (khurshid-alam) wrote :

YES! That would be nice!

Albert Cutrona (acutbal) wrote :

I think the same.

Best regards-

Victor Choueiri (victor-oc) wrote :

I've submitted a pull request with a basic implementation of this: https://github.com/stayradiated/LightRead/pull/13

consindo (cooperjona) wrote :

Cheers

Changed in lightread:
status: Confirmed → Fix Committed
Niclas Kiefer (niclas-kiefer) wrote :

I appreciate the fix, works nice but the messaging menu envelope stays blue because of starred feeds. Can't it switch to blue only when there are new feeds? Like this it looks like i got new feeds, mail etc but its just Lightread starred feeds suggesting that.

Lightread currently does not appear in the messaging menu in quantal.

Nekhelesh Ramananthan (nik90) wrote :

James you need to enable the option through the settings menu. It is not enabled by default. Please file a new bug report if you still cannot see it in the messaging menu in quantal.

Changed in lightread:
status: Fix Committed → Fix Released

I have the newest packages from Ubuntu repos, and Lightread 1.22, and I have no option for Lightread in messaging menu. I enabled all necessary options in Preferences.

Edwin Lee (leeed2001) wrote :

I confirm that enabling the messaging menu setting doesn't seem to do anything related to the messaging menu. I certainly look forward to this!

Wesley (wesley-wezside) wrote :

It works for me however the icon is missing. I get the missing "red circle" icon. Lightread 1.2.2 Ubuntu 12.04.

@Wesly. It worked fine when I was using Ubuntu 12.04 but after I upgraded to 12.10 it didn't.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments