Exchange Data Provider for Lightning

Plugin not working on thunderbird 5

Reported by mirweb on 2011-07-04
104
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Exchange Data Provider for Lightning
Undecided
Unassigned

Bug Description

On Ubuntu 11.04 with thunderbird 5.0 and lightning 1.0 b4 (from the ppa:mozillateam/thunderbird-stable) the plugin stops working. The new add ons manager disabled the plugin on startup and shows a message, that is not compatible.

It would be nice, if the plugin works again with the stable thunderbird version.

Changed in lightning-exchange-provider:
status: New → Confirmed
daniel V. (dvalfre) wrote :

Hi,

I've done what is described at https://bugs.launchpad.net/lightning-exchange-provider/+bug/777673 with the same results. Also there is not useful debug I could gather since, even as the plugin is active, the account canot be configured.
I'm happy to provide debugging info, just let me know how to gather it.

saludos
daniel

Hari (haridara) wrote :

I installed the "Add-on Compatibility Reporter" and this extension seems to be working fine so far. I had to explicitly reload remote calendars to start seeing my events and I was able to open them as well. I haven't tested any other functionality yet.

Changed in lightning-exchange-provider:
status: Confirmed → Fix Released
Brian Guan (brian-guan) wrote :

I tried installing the latest 0.15 which was marked to be compatible with Thunderbird 5 (AMD64 on Ubuntu 11), while creating a Calendar against our Exchange server, I get this error:

"""
An error was encountered preparing the calendar located at https://${our ADS domain}%5C${my login ID}@${our exchange server hostname}/EWS/Exchange.asmx for use. It will not be available.

Error Code: 0x80570015
Description:
[Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]" nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/bguan/.thunderbird/yqdzvkbl.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 583" data: no]

"""

FYI, for other users stuck while waiting for the final fix, I am able to use Lightning via CalDAV against the latest DavMail gateway (http://davmail.sourceforge.net/) as an interim solution for now.

Changed in lightning-exchange-provider:
status: Fix Released → New
specimen (specimen) wrote :

I am using Windows 7 (64 bit). I get the same error as Brian Guan above.

The only thing I have been able to confirm so far is that the error is the same, whatever I use for the username/password/webmail server.

So, it feels like the request is not getting anywhere out of my computer. Just to remove the possibility of a corrupt installation, is there any way to clean up my profile, after removing the extension, before re-installing it?

why2jjj (why2jjj) wrote :

I don't know if this helps, but in my Ubuntu 10.04 64-bit machine, I have to start thunderbird 5.0 as root to successfully install ANY plugin for thunderbird 5- this plugin, Lightning itself, etc.

Don't know if this would relate to the problem or not. But I get the same error as Brian Guam, regardless if I start thunderbird 5.0 as root or as my user login.

Graeme Hanson (graeme-r-hanson) wrote :

I also see a similar error on MacOSX 10.6.8 Thunderbird 5

An error was encountered preparing the calendar located at https://uq%2Eedu%2Eau%<email address hidden>/EWS/Exchange.asmx for use. It will not be available.

Details are in the attached tiff file (screen shot)

Just thinking out loud.
Is it important that the microsoft exchange addon be added before lightning is added?

It was done in reverse during the upgrade of thunderbird.

Harry S (hsoeterb) wrote :

Using Ubuntu Maverick, TB 5.0, lightning 1.0b4 and Provider for Microsoft exchange 0.15, I have the same problem as Brian Guan and Graeme Hanson have.

I will try davmail as Brian suggested.

Jörg Esser (jackfritt) wrote :

Same Problem here with Windows XP(German) and TBversion=5.0&os=WINNT&buildid=20110624125636
Lightning 1.0b4 and Provider for Microsoft Exchange 0.15

[Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]" nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/xxx/Anwendungsdaten/Thunderbird/Profiles/5zlxuega.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 583" data: no]

Maybe I entered the wrong exchange URLs ? I tried
https://quad/EWS/exchange.asmx
https://quad/username@quad/EWS/Exchange.asmx
https://quad/owa/
https://quad/EWS/Services.wsdl
https://quad/username@auto where username is <email address hidden>

Jörg Esser (jackfritt) wrote :

https://username@quad/EWS/Exchange.asmx where username is loginname for exchange server
This is how it worked for me.
Maybe this is the problem ?

But the next problem is that I can´t see any entry´s. The calendar is completely empty.

Simon Schubert (corecode) wrote :

So using a different URL makes the error go away? That is very obscure.

On Wed, Jul 13, 2011 at 5:21 AM, Jörg Esser <email address hidden>wrote:

> https://username@quad/EWS/Exchange.asmx where username is loginname for
> exchange server
> This is how it worked for me.
> Maybe this is the problem ?
>

I know for my company setup, that would not work.

I'd need the:

http://AMR\login_name@auto

that was mentioned earlier.

> But the next problem is that I can´t see any entry´s. The calendar is
> completely empty.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (808906).
> https://bugs.launchpad.net/bugs/805379
>
> Title:
> Plugin not working on thunderbird 5
>
> Status in Exchange Data Provider for Lightning:
> New
>
> Bug description:
> On Ubuntu 11.04 with thunderbird 5.0 and lightning 1.0 b4 (from the
> ppa:mozillateam/thunderbird-stable) the plugin stops working. The new
> add ons manager disabled the plugin on startup and shows a message,
> that is not compatible.
>
> It would be nice, if the plugin works again with the stable
> thunderbird version.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/lightning-exchange-provider/+bug/805379/+subscriptions
>

I also had this "Component returned failure code: 0x80570015...." error after I upgraded to Thunderbird 5 and this plugin version 0.15. As a test I removed the calendar and tried to recreate it, but this failed with the same error message. Later I uninstalled the plugin, restarted Thunderbird, installed the plugin, again restarted Thunderbird and recreated the calendar. This seemed to work, but I don't see any entries in the calendar and I can't add new entries. I used ethereal to look at the network traffic, but reloading the calendar doesn't seem to generate any traffic. But maybe I'm looking at the wrong port or protocol, what things should I check? I'm running Thunderbird 5.0 on Linux 2.6.32.36-0.5-default #1 SMP 2011-04-14 10:12:31 +0200 x86_64 x86_64 x86_64 GNU/Linux.

Martin Wildam (mwildam) wrote :

I think, I got the right url, but using it in the webbrowser asks me for the password (login popup dialog in the browser) - I tried to add it to the url so to have it:

https://domain\user:<email address hidden>/EWS/Exchange.asmx

But either this did not help (Using TB 5.0 and Exchange Data Provider v 0.15.

Nathan (nathan-e) wrote :

I had the same error (Component returned failure code: 0x80570015) and loaded the latest version from git. Now it is working like it did on 0.14

specimen (specimen) wrote :

I wonder if the extension is being installed properly for this version. In my extensions folder in my profile, I just see a "<email address hidden>" file of size about 30KB. There is no additional folder created for this addon.

Maybe this is the correct behaviour, but it looks suspicious to me.

Joshua Roys (roysjosh) wrote :

I might have a fix available. If you are comfortable creating the extension from git, try these patches: https://gitorious.org/lightning-exchange-provider/lightning-exchange-provider/merge_requests/6 . They get it working for me under 64-bit linux under TB5 (also 64-bit). Some feedback on these changes would be good so a new release can be done if it works for other people too.

specimen (specimen) wrote :

Unfortunately I have no idea how to get the stuff out of git. If you could create an xpi package for me, I will be happy to try it out.

Joshua Roys (roysjosh) wrote :

Here's one built from my local git. The paranoid can unzip and verify it matches upstream with my changes. The slightly less paranoid can verify these hashes:
SHA1: 4cba322813378fe4bfc7a1d2271b3827a143886f lightning-exchange-provider-v0.15.jrr.xpi
SHA256: 7dae3307097db2557858e489ceaa280504439cb755e8c13bd69fcc2b476459bf lightning-exchange-provider-v0.15.jrr.xpi

specimen (specimen) wrote :

Many thanks! It works like a charm now, and is very fast too.

Mahesh Asolkar (asolkar) wrote :

I can confirm that the .xpi from comment #18 works on Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110714 Thunderbird/8.0a1.

Thanks Joshua!

Works for me too, with Thunderbird 5.0 running on 32-bit Ubuntu 10.10.

Thanks very much!

why2jjj (why2jjj) wrote :

The error did go away for me too, though I still can't read my calendar on Microsoft Exchange using http://AMR\<login>@auto...now it could be some server thing..

Joshua's fix works for me on thunderbird 5.0.1 (upgraded from 5.0 after bug was found) macosx 10.6.8, running 64-bit kernel.

No error message. Calendar initially blank, had to select exchange calendar and then everything is fine.

Thanks for your help.

Graeme

This fix works for me too on Linux Mint 11 with TB5.
Everything in 32-Bit.

On 07/15/2011 01:51 AM, Graeme Hanson wrote:
> Joshua's fix works for me on thunderbird 5.0.1 (upgraded from 5.0 after
> bug was found) macosx 10.6.8, running 64-bit kernel.
>
> No error message. Calendar initially blank, had to select exchange
> calendar and then everything is fine.
>
> Thanks for your help.
>
> Graeme
>

--
kind regards/Mit freundlichen Gruessen

Nils Jungebluth
System-/Netzwerkadministrator

Tellja GmbH
Solmsstr. 12
D-60486 Frankfurt am Main

Fon: +49 (0)69 8700 429 - 21

Email <email address hidden>
Web www.tellja.de

Geschäftsführer: Jens Rode, Michael Stöhr
Sitz der Gesellschaft: Frankfurt am Main
Amtsgericht Frankfurt am Main HRB 76290

I can also confirm: Joshua's Fix works.

Joshua's fix works for me too. Many thanks!

Slammy (slammy) wrote :

Using the 0.16 version fixes everything.
Thanks Joshua :D

Slammy (slammy) wrote :

And of course, many thanks to Simon :)

Bolick (alexey-brodkin) wrote :

Have the same issue on Ubuntu 10.10 32 bit Thunderbird 5.0 from ppa, Lightning 1.0 b4
(also tried the same config on 11.04 64 bit - all the same)
Tried both 0.15 patched and 0.16 versions of plugin.
Was able to add calendar but it remains empty.
Tried both auto discovery and manual address entering. Still no luck.

BTW it is not clear for me from posts above:
> No error message. Calendar initially blank, had to select exchange
> calendar and then everything is fine.

So how am I supposed to "select exchange calendar". I'm wondering if it will help?

Regards,
Alexey

Bolick (alexey-brodkin) wrote :

Update with error messages

1. In case of auto discovery (https://_DOMAIN_\_USER_@auto) I got this in "Error console"
=============
Error: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIXMLHttpRequest.open]" nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/abrodkin/.thunderbird<email address hidden>/js/calExchange.js :: <TOP_LEVEL> :: line 278" data: no]
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/abrodkin/.thunderbird<email address hidden>/js/calExchange.js
Line: 278
=============

2.
In case I manually enter address (https://_DOMAIN_\_USER_@_EXCH_SERVER_/EWS/Exchange.asmx) I got this in "Error console"
(_EXCH_SERVER_ i get from working Outlook setup in Windows)
=============
Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXMLHttpRequest.status]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/abrodkin/.thunderbird<email address hidden>/js/calExchange.js :: <TOP_LEVEL> :: line 421" data: no]
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/abrodkin/.thunderbird<email address hidden>/js/calExchange.js
Line: 421
=============

Hope this will help

Bolick (alexey-brodkin) wrote :

Another update:

our company just moved from Exchange 2007 to 2010.

I know, that in add-on description it is said:
==========
This addon only works with Microsoft Exchange 2007 and __above__. Exchange 2003 is not supported.
==========

But have anybody tried if current add-on version works well with Exchange 2010?

Simon Schubert (corecode) wrote :

Yes, it does.

Simon Schubert (corecode) wrote :

Bolick, can you please post a full debug output?

Bolick (alexey-brodkin) wrote :

Do you mean "Error console" reports?

So in case of auto discovery calendar creation only 1 message appears and it is reported above.
In case of manually entered address the message also reported earlier appears a number of times.

Or are there any other sources of debug data?

BTW, do I understood correctly that "server address" should be of Exchange server itself, not OWA?

Simon Schubert (corecode) wrote :

I think this is a different bug alltogether, could you please open a new bugreport and include the debug messages as described on the Wiki? Thanks!

Bolick (alexey-brodkin) wrote :

Thanks, will do it shortly.

Bolick (alexey-brodkin) wrote :

Well, finally I got it working!

After enabling verbose logging into console I saw that problem was in getting answer from server.
To be short our company has quite tricky IT infrastructure and some direct approaches don't work.
For example "http://domain\user@company_name.com/EWS/Exchange.asmx".

So I then tried to get "Exchange.asmx" in browser in different ways.
And the one that worked for me was with address similar with OWA!

OWA interface is here: "https://prefix1.prefix2.company_name.com/owa/"

And "https://prefix1.prefix2.company_name.com/EWS/Exchange.asmx" gave me desired xml.
(the tricky thing is our Exchange server address has way different prefixes, so that's why I got my problems)

So I entered this address and got calendar sync.

Anyway thanks for tips and nice add-on.
I hope my findings will be of any help.

Eric Lee Green (eric-badtux) wrote :

Version zipped up from GIT works here. Fedora 15, 32 bit, Thunderbird 5.0. Using Exchange 2007 hosted with (nasty_hosted_exchange_provider). For those wanting a recipe:

git clone git://gitorious.org/lightning-exchange-provider/lightning-exchange-provider.git lightning-exchange-provider
cd lightning-exchange-provider
zip -r ../lightning-exchange-provider.xpi *

Then add by clicking on the "Install Add-On From A File" in the Add-ons Manager and point it at the lightning-exchange-provider.xpi file. It'll whine that it's unsigned, but so it goes. Then it'll prompt you to restart. Do so.

Then go into calendars, right-click in the Calendar area to add your calendar, put in your usual
https://DOMAIN\<email address hidden>/EWS/Exchange.asmx as the path, and when it prompts you for your password add it in. Voila. All works.

Note: If your company is using a hosted Exchange service you'll need to go into their web services dashboard and get your "real" Exchange user name and Windows domain. It's usually something like <email address hidden> with a random Windows domain name of their choice. Just one of the joys of outsourcing, sigh...

Simon Schubert (corecode) wrote :

Does the 0.16 package not work for you?

Eric Lee Green (eric-badtux) wrote :

Did not get 0.16 when I downloaded the package itself via link on Mozilla Thunderbird site, got 0.15. It may be that a cache somewhere in the Internets was still serving the old package.

Simon Schubert (corecode) wrote :

You need to select 0.16 explicitly until 0.16 is reviewed.

Changed in lightning-exchange-provider:
status: New → Fix Released
Willo vd Merwe (qbitza) wrote :

OS: Linux #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Thunderbird 7.0 / Lightning 1.0b7 / Provider for Microsoft Exchange 0.17

Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXMLHttpRequest.status]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/willo/.thunderbird<email address hidden>/js/calExchange.js :: <TOP_LEVEL> :: line 422" data: no]
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/willo/.thunderbird<email address hidden>/js/calExchange.js
Line: 422

The same setup on WinXP works however.

Peter (peter123) wrote :

Hello,

I have very similar compatibility problems with lightning and exchange provider.

I have installed Thunderbird 9.0.1 on Win7 64-bit machine, Lightning 1.1.1 plugin and Provider for Microsoft Exchange 0.17 plugin.

I can add my MS Exchange calendar, and lightning asks me for username and Password. But then, the calendar is added empty and no data are loaded.

In thunderbirds debug console, this error pops up:

Fehler: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIXMLHttpRequest.open]"
nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"
location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///T:/.thunderbird<email address hidden>/js/calExchange.js :: <TOP_LEVEL> :: line 278" data: no]

I suspect following bug (since the error sounds like malformed URI):
When I enter the dates for my Exchange account, it is
http://<email address hidden>@auto

but after adding the calender, lightning asks me for the username and password for
http://my%2Ename%40my%2Eserver%2Ech@auto/

While the second "@" remains an "@", the other points and "@" have transcoded to %2E and %40 symbols. Maybe this is the malformed URI.

This error is permanently, reproducible and also there on a RedHat Linux RHEL 6 machine with thunderbird 9.0.1 and lightning 1.1.1 and Provider for MS Exchange 0.17.

In a webbrowser, I can come to my xml file with
https://mail.ethz.ch/EWS/Exchange.asmx

Maybe you can help me?

By the way, I can add other calendars (not Exchange ones), there are no problems.

Thank you,
 Peter

Peter (peter123) wrote :

Very well, thank you.

This is not compatible with sunbird 1.01b, but it works fine for me with tunderbird 9.0.1 and lightning 1.1.1.

Peter (peter123) wrote :

The plugin exchange 2007/2010 calendar works, but there seems to be one bug:

The plugin keeps asking me for username and password, everytime I start tunderbird, and even if I use the password manager to save these dates.

Further, my username is "pschu", but the plugin keeps asking me for the password for username "mail.ethz.ch\pschu". So I have to correct the username everytime.

And even if I enter the correct dates, it asks me two or three times until it stops and successfully connects the calendar.

What could that be? Is there a way to save the username and password?

Thank you!

Thomas Conroy (thomas-conroy) wrote :

I recently had to rebuyild my Windows 7 machine. Sionce the rebuild I cannot get any sync to work between exchange calendar and lightning....I'm getting the error message

[Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]" nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/TJC/AppData/Roaming/Thunderbird/Profiles/sz7ds0pm.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 474" data: no]

I SURE Could use any tool that allows sync between Lightning and Outlook - what a fatal flaw for Lightning!

Any help would be greatly appreciated.

Thanks, Tom

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers