Canot delete one instance of recurring meeting

Bug #723314 reported by Blair on 2011-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exchange Data Provider for Lightning
Undecided
Unassigned

Bug Description

Right click on one old instance of a meeting and choose "just this occurence". Doesn't delete. Reload remote calendars still is there.

Login through the web to web Outlook. Delete one instance of a meeting. Is successful in web Outlook. Go back to t-bird--all instance of that meeting are now gone.

Simon Schubert (corecode) wrote :

I can not reproduce this. Could you please capture a debug log of the delete?

Kind of busy but will try to get to it. Might just be that I was
deleting an event in the past, ie..

Recurring meeting every Monday with reminder set
On Feb 22nd, still reminding me of Feb 14th meeting, which I keep
dismissing, but keeps reappearing like a zombie.
Go into Outlook web and delete the Feb 14th meeting as a workaround to
the "non-dismissal" issue (weirdly doesn't ask me in Outlook whether I
want to delete that one or all of them)
Outlook deletes only that one (desired effect)
Thunderbird has now deleted all of the occurrences of that meeting.
Reload calendar, no joy.

--this is something that normally wouldn't be important to do, but I was
doing because of the problem with not being able to Dismiss meetings
(which is the more important issue--saw the bug already posted on your
site as 4 alarm hot).

Thanks for looking into this. Helpful plugin for me. Will try to do the
debug thing and test later on.

Blair

On 2/22/11 2:16 PM, Simon Schubert wrote:
> I can not reproduce this. Could you please capture a debug log of the
> delete?
>

Blair (crazy-fingers-16) wrote :

Seems it isn't refreshing anything from Exchange anymore. Just added an event in my web Outlook, refreshed all calendars, no joy.

I tried to debug--added the Boolean value, then launched Thunderbird from Terminal (I have a Mac). There is no output in Terminal after running--thought I should see some output there...

Looking at the Tools/Error Console I see the following errors related to the Exchange Provider:

Error: nextOcc is null
Source File: file:///Volumes/<MyProfilePathCensored>.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Volumes/<MyProfilePathCensored>.<email address hidden>/js/soapin.js
Line: 392

Thanks for any help.

Blair (crazy-fingers-16) wrote :

More weirdness:

1. Add an event in Lightning. Shows in Lightning. Shows up immediately in web Outlook, but two events have been created at the same time, same name.
2. Reload remote calendars. Event now missing from Lightning. The two duplicated events still show up in Outlook/Exchange.

If it matters, Exchange server is in PST, my local machine is in EST timezone. Generally timezones were working before, when this was all working.

Also note that meetings used to show up in my Thunderbird email box with "Accept" "Decline" buttons but that doesn't happen anymore.

I could try just deleting and re-adding the calendar but I'll wait in case my current situation can be of any help for debugging purposes.

Blair (crazy-fingers-16) wrote :

I also have Google Provider add on installed, and have 3 standard Google holiday calendars synced as well as my personal Google calendar. Don't know it that matters...

Simon Schubert (corecode) wrote :

Does this still happen with the latest version?

Changed in lightning-exchange-provider:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers