Exchange Data Provider for Lightning

Exch. calendar hides local tasks

Reported by dergilb willspam on 2011-02-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Exchange Data Provider for Lightning
Undecided
Unassigned

Bug Description

I have three calendars in Lightning 1.0b2 / Exchange Provider 0.12:

1. via Exchange
2. via Google
3. local .ics

If I enable the Exchange calendar, all tasks from the local calendar are hidden, until the Exchange calendar is deactivated. It is sufficient to disable the calendar, disabling the plugin is not necessary. No problem with the Google calendar.

Simon Schubert (corecode) wrote :

This is strange. Does it happen if you only don't display the calendar?

I've enabled the calendar (not displayed) -> no problem. Restart -> no problem. -> display calendar -> no problem. Restart -> tasks hidden. -> Restart -> tasks hidden. -> don't display calendar & reload external calendars -> no change, still no tasks visible -> Restart -> tasks are shown.

(only TB was restartet)

I've also seen this bug, and so do other people in my company.

I have tasks defined in the local calendar, but they will not be displayed as long as the Exchange Calendar is selected. So I have to deselect the calendar (or disable the entire add-on) and then restart Thunderbird. Then I can add see and edit the tasks again.

Chris Bandy (bandy-chris) wrote :

I can confirm this behavior on Thunderbird 3.1.9, Lightning 1.0b3pre, Exchange Provider 0.12.

I have three calendars: Google, Exchange and Local ( moz-storage-calendar:// )
All my tasks are in the local calendar.

Starting Thunderbird with the Exchange calendar visible causes my previously saved local tasks not to display. I can still create local tasks in this state. These tasks are visible during the session, behave normally and persist after quitting.

I'm able and willing to provide more info and/or try patches.

Chris Bandy (bandy-chris) wrote :

While testing this further I noticed that the Today Pane and Tasks tab seemed to behave differently depending when they were opened.

1. Prior to enabling my Exchange calendar, I can see all my local tasks in both the Today Pane and the Tasks tab. Disabling my local calendar hides its tasks from both, and creating a local task works correctly (it remains hidden). Enabling my local calendar shows all its tasks in both.

2. If I open the Today Pane and Tasks tab before enabling my Exchange calendar, my previously saved local tasks will appear in both correctly. If I do not open the Tasks tab prior to enabling my Exchange calendar, then the Tasks tab later appears empty.

3. After enabling my Exchange calendar, disabling my local calendar hides its tasks from both the Today Pane and the Tasks tab. Creating a local task works correctly (it remains hidden). Enabling my local calendar does not show any local tasks, but I can create a local task and it appears in both the Today Pane and Tasks tab. I tried many combinations of enabling/disabling calendars in this state, and the only way to show local tasks again is to restart Thunderbird (with my Exchange calendar disabled).

So the reliable way to reproduce this bug seems to be: enable the Exchange calendar, disable the local calendar, enable the local calendar.

Changed in lightning-exchange-provider:
status: New → Confirmed
summary: - Exch. calendar hides lokal tasks
+ Exch. calendar hides local tasks
Chris Bandy (bandy-chris) wrote :

When no events are being requested (tasks only?) completeGetRequest() is called with incorrect parameters.

This patch fixed for me.

Simon Schubert (corecode) wrote :

Great, thank you! Committed as 588cf460.

Changed in lightning-exchange-provider:
status: Confirmed → Fix Committed
Changed in lightning-exchange-provider:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers