Exchange Data Provider for Lightning

Double entry of event in the OWA, for an event created with Lightning

Reported by Nicola Ferralis on 2011-02-02
112
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Exchange Data Provider for Lightning
High
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Using version 0.12. Every time an event is created with Lightning, the same event appears as two identical events when viewing using the Outlook web Access (OWA).

Reproducible every time:

1. Create an event with Lightning,
2. Open OWA in the browser and go to the event you just created.

Expected:
only one event should be created.

Actual:
Two identical events are created.

Simon Schubert (corecode) wrote :

Can you please capture a debug log?

Nicola Ferralis (feranick) wrote :
Nicola Ferralis (feranick) wrote :
Nicola Ferralis (feranick) wrote :

Please find the debug log attached (debug.txt).

I have further details about the bug. When trying to delete an event created with Lightning, only one of the previously created events are deleted in the OWA. THe other copy persists, but it doesn't show up in TB. I also attached a debug log for that.

Nicola Ferralis (feranick) wrote :

Another update. I just reverted to version 0.11 of the provider for MS Exchange and the bug is not reproducible (i.e. events are correctly created as single instances, and can be removed completely). So the bug applies to the latest version 0.12 only.

Simon Schubert (corecode) wrote :

I see, thanks for the report. Something makes the connection state look like an error. Then we retry and it works. However, the first try already created an even (that we don't see).

I'm aware of the connection problem, but I don't know how to fix it.

Nicola Ferralis (feranick) wrote :

Well, something must have changed in the way the connection between 0.11 and 0.12, since the problem wasn't there in 0.11.

I wonder if I am the only one seeing this issue. If not, I recommend a downgrade to 0.11 (which for me works just fine).

Samuel Wang (samuel-wang) wrote :

Using 0.12

Creation:
When I create an appointment in TB, the double entry appears in my outlook calendar.

Deletion:
When I delete the entry in TB, while the entry is deleted in TB, but only 1 entry is deleted on outlook.
I have to refresh my TB calendar to see the additional entry and be able to completely remove it from both TB and Outlook calendar

Simon Schubert (corecode) wrote :

Does the entry never show up double in Thunderbird, even when you restart Thunderbird?

Samuel Wang (samuel-wang) wrote :

I reinstalled 0.12 and ran the test.
Thunderbird does not show the double entry upon refresh or restart.

Creation of concurrent events:
When I create a concurrent event, another 2 more entries appear in my outlook calendar.
Resulting in a total of 4 events reflected in outlook.
But Thunderbird only shows 2 events, even upon restart

Just for visualization
What I see in Thunderbird:
              |-------------|------------|
5:00 pm | Event 1 | Event 2 |
6:00 pm |-------------|------------|

What I see in Outlook:
              |-------------|------------|-------------|------------|
5:00 pm | Event 1 | Event 1 | Event 2 | Event 2 |
6:00 pm |-------------|------------|-------------|------------|

Simon Schubert (corecode) wrote :

could you capture a debug log? I have a log of the creation, but not of the viewing/refreshing.

Samuel Wang (samuel-wang) wrote :

pardon my ignorance. But how do I generate a debug report?

Samuel Wang (samuel-wang) wrote :

Here's the debug log.
The event created is: Test Event - Double

James O'Cull (houndeyex) wrote :

Happening for me too. I haven't figured out how to make a debug log on Windows yet, sorry.

- I do not have caching enabled
- I am using Thunderbird 3.1.9 on Windows 7 x64
- Lightning 1.0b2
- Exchange Provider 0.12

I am experiencing this bug also.
If I create a new calendar entry, it shows up twice in outlook and once in Lightning.
If I then delete the entry from Lightning, it disappears from Lightning and one entry disappears from Outlook.
If I then reload the calendar in Lightning, the entry reappears (now showing the duplicate which I could previously see in outlook)
If I delete the remaining entry from outlook, the entry disappears from Lightning or alternatively if I delete the entry from Lightning, the entry disappears from Outlook.

I reverted to v0.11 and then problem was not present.
I returned to v0.12 and now I cannot reproduce the problem at all... ??

I'm using:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.15) Gecko/20110307 Fedora/3.1.9-0.39.b3pre.fc14 Lightning/1.0b2 Thunderbird/3.1.9

ConiKost (conikost) wrote :

I've the same problem, as described here with the version from git.

Mari (mari-nl) wrote :

This seems to occur for me too.
Create a new item in Lightning and it will appear twice in Outlook.
Thunderbird will only show one item.

Thunderbird 3.1.9
Lightning 1.0b2
Exchange provider 0.12
Windows 7 x64

Mari (mari-nl) wrote :

... and when you delete the item in Lightning one item is deleted in Outlook, one duplicate stays there.
When you start Thunderbird the next time, that one item is resynced to Lightning, so your deleted item came back.
Now you have one item in Lightning and one item in Outlook again, for a item that you wanted to delete.

Craig Watson (craig-cwatson) wrote :

Same problem:

Thunderbird 3.1.8 on Ubuntu 10.04 x64
Lightning 1.0b2
Exchange Provider 0.12

Max Baryshnikov (mephius) wrote :

Same problem:

Thunderbird 3.1.10 on Kubuntu 10.04 x64
Lightning 1.0b2
Provider for Microsoft Exchange 0.13

Samuel Wang (samuel-wang) wrote :

Still experiencing the double entry problem when using version 0.13

Marcos Lenharo (lenharo-h) wrote :

Hi,

I don't know if it helps, but after a bisect I can see that the problem was introduced on commit d09f098c4fdc732a6aa78ba7a41e7fac07b2b7c4 rewrite request setup/queueing

Simon Schubert (corecode) wrote :

Hmm yes. But why is it happening? The problem is that sometimes POST requests will just fail, but actually go through on the server side...

Johan (deberghes-johan) wrote :

Same problem with the new 0.14 version
Lightning 1.0b2
Thunderbird 3.1.10
Ubuntu 10.04.2

Changed in lightning-exchange-provider:
status: New → Confirmed
indium (indium) wrote :

the duplicate appointment bug also appears in ubuntu 11.04 with TB/3.1.10, lightning/1.02b, MS-Exhange addon 0.14

Changed in ubuntu:
status: New → Invalid
Sven (sven-solberg) wrote :

Affects me too..

Why is this invalid?

Simon Schubert (corecode) wrote :

Perfectly valid, just not related to the Ubuntu distribution.

Sven (sven-solberg) wrote :

Ok.. thanks .

Changed in lightning-exchange-provider:
importance: Undecided → High
Garwood Pang (garwoodpang) wrote :

I dont know if this helps but if you press "Save" instead of the big "Save and Close" button you will only have one event in both outlook and tb. I tried it in both lightning/1.02b and lightning/1.04, TB 5.0 and TB 3.1.11, exchange addon lightning-exchange-provider-v0.15.jrr.xpi and 0.13.

Vlado Plaga (vlado-gmx) wrote :

Thanks for the tip to use "Save" instead of "Sava and Close", Garwood! I tested it once (with lightning-exchange-provider-v0.15) and it worked. Now I can finally use Thunderbird directly to add events to a shared Exchange calendar, and no longer have to use Outlook Web Access for it.
A fix to "Save and Close" should be easy to implement now, shouldn't it? Why is it different from first saving and then closing?

Bingo Tailspin (bingotailspin) wrote :

I would like to confirm that Ctrl+S, then Ctrl+W works great! So there is something different in the "Save and Close" handler code that makes the double event happen. Ubuntu 10.10 x86_64, Thunderbird 5, Exchange Provider 0.16

roemer2201 (roemer2201) wrote :

I can confirm this bug and would like to add this information:

I'm using an iPhone and iPod Touch which access the same calendar as this TB-Addon does, but the duplicate entries I see in Outlook an WebOWA are just a single entry in the iOS. Maybe the helps.

iOS-Version on both devices: 4.2.1 (8C148)

Lucky (luckyplanet) wrote :

I use lightning and an android device that accesses the same calendar and I can confirm that the double entries appear in the android device when I hit save and close; the problem seems to be gone when I hit save first and then manually close as someone previously had suggested.

ubuntu 11.04/64 - Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.18) Gecko/20110617 Lightning/1.0b2 Thunderbird/3.1.11 ms exchange 0.16

and

ubuntu 10.10/64 - Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.18) Gecko/20110617 Lightning/1.0b2 Thunderbird/3.1.11 ms exchange 0.16..

both systems generates double entries in my outlook/exchange 2010 calendar when "save & close" - single entry (correct!) when "ctrl-s" - "ctrl-w"

no invitations seems to be send out in either case

Simon Schubert (corecode) wrote :

Good news, I found the bug!

The problem is that if you click Save+Close, Thunderbird will do this in exactly this sequence. The save triggers an update XMLHttpRequest which also gets sent. The subsequent close, however, will cancel the XMLHttpRequest (even though it already was sent and was received by the server). That makes the request return a bogus error, and the request gets retried. Voila, 2 events created.

I'll look into how to fix this, but any help is appreciated.

Changed in lightning-exchange-provider:
status: Confirmed → Fix Committed
Changed in lightning-exchange-provider:
status: Fix Committed → Fix Released
lhecking (lhecking) wrote :

Simon, I cannot confirm this bug fix. But this may simply be a matter of missing information. Is it supposed to be fixed in 0.16 or 0.17?

Would you be able to update http://gitorious.org/lightning-exchange-provider/pages/Home
with a better changelog that lists the last N releases, with release dates and bug # references?

Also, it always seems to take a pretty long time before releases hit mozilla.org.

Simon Schubert (corecode) wrote :

Should be fixed in 0.17.

I'll try to update the changelog -- that's a good idea.

Yes, addons.mozilla.org takes quite a long time to review new versions. Unfortunately there is nothing I can do about this.

lhecking (lhecking) wrote :

Looks good. Thank you so much!

Looking forward to 0.17.

lhecking (lhecking) wrote :

Got 0.17 yesterday and I can confirm the fix. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers