~/xsession-errors is owned by root, incorrect consolekit session breaking DRI

Bug #863119 reported by Doug McMahon on 2011-09-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
lightdm (Ubuntu)
High
Robert Ancell
Oneiric
High
Robert Ancell

Bug Description

If not intended then the description will suffice

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 1.0.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Fri Sep 30 04:55:31 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110929)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

This was a 09/29 install that had 1 very weird login Bug 863054
After removing and re-installing lightdm (& deleting the root owned xseession-errors can't duplicate so marking invalid

Changed in lightdm:
status: New → Invalid
Changed in lightdm (Ubuntu):
status: New → Invalid

the daily image from today have this issue (09/30)

Doug McMahon (mc3man) wrote :

Will put back to new, what I see atm on 09/25
admin user is no longer get a root owned here
non admin users are
the ubuntu-user on live session is getting a root owned

I may have gotten the root owned as an offshoot of bug linked above, it has yet to re-occur

Changed in lightdm:
status: Invalid → New
Changed in lightdm (Ubuntu):
status: Invalid → New
Changed in lightdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Doug McMahon (mc3man) wrote :

As of today my main admin user session is now getting a root owned .xession.errors on every login.

Changed in lightdm (Ubuntu):
importance: Undecided → High
Changed in lightdm (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
summary: - ~/xsession-errors is owned by root
+ ~/xsession-errors is owned by root, incorrect consolekit session
+ breaking DRI
Jean-Baptiste Lallement (jibel) wrote :

I confirm this issue on a fresh installation with daily desktop image (20111003)
I attached the output of "LIBGL_DEBUG=verbose glxinfo"

important bits:
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/i965_dri.so
libGL error: failed to open drm device: Permission denied
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so

and ck-list-sessions:
Session3:
 unix-user = '1000'
 realname = 'ubuntu'
 seat = 'Seat1'
 session-type = ''
 active = FALSE
 x11-display = ''
 x11-display-device = ''
 display-device = '/dev/tty1'
 remote-host-name = ''
 is-local = TRUE
 on-since = '2011-10-03T08:45:46.135467Z'
 login-session-id = ''
 idle-since-hint = '2011-10-03T09:09:06.602876Z'

tags: added: rls-mgr-o-tracking
Jean-Baptiste Lallement (jibel) wrote :

Together with this problem I get bug 851345 which is maybe a symptom of this issue.

Robert Ancell (robert-ancell) wrote :

Fixed in lightdm 1.0.1, but I can't reproduce the console kit issue

Changed in lightdm:
status: New → Fix Committed
Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.1-0ubuntu1

---------------
lightdm (1.0.1-0ubuntu1) oneiric; urgency=low

  * New upstream release:
    - GTK greeter now remembers last user
    - GTK greeter now initializes i18n (LP: #862427)
    - Start authentication for automatically selected user in GTK greeter
    - Link liblightdm-qt against QtGui
    - Fix liblightdm-qt crashing when face images are installed (LP: #850095)
    - Set correct permissions on session log files (LP: #863119)
    - Prefer a locale with a codeset over one without for setting LANG
      (LP: #864618)
    - Introduce a lightdm-guest-session-wrapper session command which MAC
      systems like AppArmor and SELinux can use for attaching a restrictive
      policy to guest sessions.
    - Provide an AppArmor profile for guest session lockdown.
  * debian/patches/01_guest_session_lockdown.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Tue, 04 Oct 2011 19:58:25 +1100

Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in lightdm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers