Automatic login doesn't remember session

Bug #834515 reported by Julien Olivier on 2011-08-26
104
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Medium
Unassigned
lightdm (Ubuntu)
Medium
Unassigned
Oneiric
High
Robert Ancell

Bug Description

I use lightdm with auto-login. Whenever lightdm starts, the unity session is loaded automatically. If, then, I exit this session, log into gnome-shell, log out, and restart lightdm, the unity session is loadad again instead of gnome-shell.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 0.9.3-0ubuntu8
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic-pae 3.0.3
Uname: Linux 3.0.0-9-generic-pae i686
Architecture: i386
Date: Fri Aug 26 10:36:07 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
SourcePackage: lightdm
UpgradeStatus: Upgraded to oneiric on 2011-08-12 (13 days ago)

Julien Olivier (julo) wrote :
Changed in lightdm (Ubuntu):
status: New → Confirmed
Luke Yelavich (themuso) wrote :

Another way to reproduce this bug is as follows:

1. Boot a daily live CD image.
2. At the try/install unity screen, switch to a console.
3. Run the following command to change the live session user's session from unity to unity-2d:

dbus-send --system --type=method_call --print-reply --dest=org.freedesktop.Accounts /org/freedesktop/Accounts/User999 org.freedesktop.Accounts.User.SetXSession string:ubuntu-2d

You may need to run that command twice, as the first time may error out, due to the account service daemon not being running and ready to receive that method call yet.

4. Switch back to the GUI.
5. Click try Ubuntu.

You should get unity-2d loaded instead of unity 3D, however unity 3D gets loaded, dispite the individual user session set in accountsservice.

I have the same bug if I have autologin; if I disable it, then lightdm remembers the last session type used.

Changed in lightdm:
status: New → Triaged
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
Changed in lightdm:
importance: Undecided → Medium
Changed in lightdm (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

bug #871881 is a duplicate with some infos:

"1. dmrc=ubuntu, d-feet->xsession=ubuntu

logout, login to gnome:

2. dmrc=gnome-shell, d-feet->xsession=gnome-shell

Restart and everything's back to "ubuntu" (autologins to unity)

3. dmrc=ubuntu, d-feet->xsession=ubuntu

=========================================

after that, I tried: sudo /usr/lib/lightdm/lightdm-set-defaults -s *gnome-shell* (instead of just *gnome*)

System autologins to gnome-shell. All is good: dmrc=gnome-shell, d-feet->xsession=gnome-shell. :D

========================================="

mangelasakis (mangelasakis) wrote :

I have the same bug too

Colin Law (colin-law) wrote :

I need to use unity-2d and have autologin. If I logout, login with unity-2d and then reboot it comes back up as unity 3D. Is that the same bug as reported here?

Andreas (andreas-kotowicz) wrote :

@Colin: that's exactly the bug. whatever your previous choice was, it will be ignored and unity3d will be used.

Colin Law (colin-law) wrote :

I think the fact that it affects those who have to use Unity-2D and want autologin means this is an important bug. Many ordinary users will fall over it.

Sebastien Bacher (seb128) wrote :

Robert, could you have a look to this one? That's one of the frequently mentioned issues on user forums after Oneiric, quite some users try to default to i.e gnome-shell or xfce and get bitten by this bug

Changed in lightdm (Ubuntu Oneiric):
importance: Medium → High
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Fixed on stable branch

summary: - Lightdm auto-login doesn't remember session
+ Automatic login doesn't remember session
Changed in lightdm:
status: Triaged → Fix Committed
Changed in lightdm (Ubuntu):
status: Triaged → Fix Committed
Changed in lightdm (Ubuntu Oneiric):
status: Triaged → Fix Committed
mangelasakis (mangelasakis) wrote :

This bug still exists in my ubuntu amd64. While I do login to gnome-shell environment when I restart to automatically puts in unity. Is there any update?

Colin Law (colin-law) wrote :

The fix was only committed a few hours ago, it will take time to work through the system. I guess we will see an an update to lightdm at some point.

Hello Julien, or anyone else affected,

Accepted lightdm into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Smeuuh (smeuuh) wrote :

I can confirm this works fine now.

Martin Pitt (pitti) on 2011-10-27
tags: added: verification-done
removed: verification-needed
Andreas (andreas-kotowicz) wrote :

still not working for me.

Colin Law (colin-law) wrote :

Sorry to hassle but is there an estimate of when this might get released?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu2

---------------
lightdm (1.0.6-0ubuntu2) precise; urgency=low

  * Upload to precise.

lightdm (1.0.6-0ubuntu1) oneiric-proposed; urgency=low

  [ Martin Pitt ]
  * debian/lightdm.upstart: Put back check for "text" in kernel command line,
    for inhibiting automatic lightdm start. Check $JOB to still allow a manual
    "start lightdm" command to work. (LP: #873334)

  [ Robert Ancell ]
  * New upstream release:
    - Use lchown for correcting ownership of ~/.Xauthority instead of chown

lightdm (1.0.5-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    [1.0.5]
    - Relax AppArmor guest profile to allow compiz to start
    - Connect up VNC settings for width, height, depth
    [1.0.4]
    - Fix --enable-gtk-greeter=yes not working
    - Fix X sessions with arguments in Exec not working
    - Use previous session for automatic login or if greeter does not request
      one. (LP: #834515)
    - Correct ownership of ~/.Xauthority if upgrading from buggy version of
      LightDM that had it root owned. (LP: #871667)
    - Set default resolution of VNC to 1024x768, add settings for width, height,
      depth into lightdm.conf.
    - AppArmor profile: Fix broken gnome-keyring and dbus/gwibber, and quiesce
      annoying kernel audit messages for privileges that we definitively do not
      want to grant. (LP: #877736) (LP: #874635)
    - Set LOGNAME environment variable (LP: #875705)
    - Mark strings as translatable in GTK greeter (LP: #868613)
    [ 1.0.3]
    - Fix reference counting issue in ConsoleKit code
    - Really add the lightdm-guest-session-wrapper
    [ 1.0.2 ]
    - Fix daemon from blocking if Accounts Service does not exist
    - Fix greeter log file not being written
    - Don't set LANG environment variable if using Accounts Service.
    - Fix gdmflexiserver not working due to it not being in PATH
    - Don't authenticate the greeter user
    - Allow greeters to be disabled in configure flags
    - Fix over allocation of read buffer in greeter protocol
    - Make sure objects are cleaned up on exit
    - Fix minor memory leaks
    - Fix hugely oversized allocation in greeter buffer. Can trigger
      crashes when entering very long passwords.
  * debian/patches/00bzr_guest_session_wrapper.diff:
  * debian/patches/07_long_password_crash.patch:
  * debian/patches/08_correct_ck_ref.patch:
    - Applied upstream
  * New upstream release.
 -- Martin Pitt <email address hidden> Thu, 10 Nov 2011 07:19:12 +0100

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu1

---------------
lightdm (1.0.6-0ubuntu1) oneiric-proposed; urgency=low

  [ Martin Pitt ]
  * debian/lightdm.upstart: Put back check for "text" in kernel command line,
    for inhibiting automatic lightdm start. Check $JOB to still allow a manual
    "start lightdm" command to work. (LP: #873334)

  [ Robert Ancell ]
  * New upstream release:
    - Use lchown for correcting ownership of ~/.Xauthority instead of chown

lightdm (1.0.5-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    [1.0.5]
    - Relax AppArmor guest profile to allow compiz to start
    - Connect up VNC settings for width, height, depth
    [1.0.4]
    - Fix --enable-gtk-greeter=yes not working
    - Fix X sessions with arguments in Exec not working
    - Use previous session for automatic login or if greeter does not request
      one. (LP: #834515)
    - Correct ownership of ~/.Xauthority if upgrading from buggy version of
      LightDM that had it root owned. (LP: #871667)
    - Set default resolution of VNC to 1024x768, add settings for width, height,
      depth into lightdm.conf.
    - AppArmor profile: Fix broken gnome-keyring and dbus/gwibber, and quiesce
      annoying kernel audit messages for privileges that we definitively do not
      want to grant. (LP: #877736) (LP: #874635)
    - Set LOGNAME environment variable (LP: #875705)
    - Mark strings as translatable in GTK greeter (LP: #868613)
    [ 1.0.3]
    - Fix reference counting issue in ConsoleKit code
    - Really add the lightdm-guest-session-wrapper
    [ 1.0.2 ]
    - Fix daemon from blocking if Accounts Service does not exist
    - Fix greeter log file not being written
    - Don't set LANG environment variable if using Accounts Service.
    - Fix gdmflexiserver not working due to it not being in PATH
    - Don't authenticate the greeter user
    - Allow greeters to be disabled in configure flags
    - Fix over allocation of read buffer in greeter protocol
    - Make sure objects are cleaned up on exit
    - Fix minor memory leaks
    - Fix hugely oversized allocation in greeter buffer. Can trigger
      crashes when entering very long passwords.
  * debian/patches/00bzr_guest_session_wrapper.diff:
  * debian/patches/07_long_password_crash.patch:
  * debian/patches/08_correct_ck_ref.patch:
    - Applied upstream
  * New upstream release.
 -- Robert Ancell <email address hidden> Wed, 02 Nov 2011 11:37:43 -0400

Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Colin Law (colin-law) wrote :

Great, working fine for me now on Oneiric. Many thanks.

Changed in lightdm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers